/[packages]/cauldron/libxml++/current/SPECS/libxml++.spec
ViewVC logotype

Annotation of /cauldron/libxml++/current/SPECS/libxml++.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 16609 - (hide annotations) (download)
Thu Jan 13 21:57:20 2011 UTC (13 years, 3 months ago) by dmorgan
File size: 2132 byte(s)
Remove mdv macros
1 dmorgan 16606 %define version 2.32.0
2     %define release %mkrel 1
3    
4     %define major 2
5     %define api_version 2.6
6     %define libname %mklibname xml++ %{api_version} %major
7     %define libnamedev %mklibname -d xml++ %{api_version}
8    
9     Name: libxml++
10     Summary: C++ interface for working with XML files
11     Version: %{version}
12     Release: %{release}
13     Source: http://ftp.gnome.org/pub/GNOME/sources/%{name}/%{name}-%{version}.tar.bz2
14     URL: http://libxmlplusplus.sf.net/
15     License: LGPLv2+
16     Group: System/Libraries
17     BuildRoot: %{_tmppath}/libxmlpp-%{version}-buildroot
18     BuildRequires: libxml2-devel >= 2.6.1 glibmm2.4-devel >= 2.4.0
19     BuildRequires: doxygen
20    
21     %description
22     libxml++ is a C++ interface for working with XML files, using libxml
23     (gnome-xml) to parse and write the actual XML files. It has a simple
24     but complete API.
25    
26     %package -n %{libname}
27     Summary: C++ interface for working with XML files
28     Group: System/Libraries
29    
30     %description -n %{libname}
31     libxml++ is a C++ interface for working with XML files, using libxml
32     (gnome-xml) to parse and write the actual XML files. It has a simple
33     but complete API.
34    
35     %package -n %{libnamedev}
36     Summary: Headers for developing programs that will use %name
37     Group: Development/C++
38     Provides: %{name}-devel = %{version}-%{release}
39     Provides: %{name}%{api_version}-devel = %{version}-%{release}
40     Requires: %{libname} = %{version}
41     Obsoletes: %mklibname -d xml++ 2.6 2
42    
43     %description -n %{libnamedev}
44     This package contains the headers that programmers will need to develop
45     applications which will use libraries from %name.
46    
47     %prep
48     %setup -q
49    
50     %build
51     %configure2_5x
52     %make
53    
54     %install
55     rm -rf $RPM_BUILD_ROOT
56     %makeinstall_std
57    
58     %clean
59     rm -rf $RPM_BUILD_ROOT
60    
61     %files -n %{libname}
62     %defattr(-,root,root)
63     %{_libdir}/libxml++-%{api_version}.so.%{major}*
64    
65     %files -n %{libnamedev}
66     %defattr(-,root,root)
67     %doc AUTHORS ChangeLog NEWS README
68     %doc %_datadir/doc/%name-%{api_version}/reference
69     %_datadir/devhelp/books/%name-%{api_version}/%name-%{api_version}.devhelp2
70     %{_includedir}/*
71     %dir %_libdir/libxml++-%{api_version}
72     %_libdir/libxml++-%{api_version}/include/libxml++config.h
73     %{_libdir}/pkgconfig/*.pc
74     %{_libdir}/*.so
75     %attr(644,root,root) %{_libdir}/*.la
76    
77    
78    
79    

  ViewVC Help
Powered by ViewVC 1.1.30