1 |
%define api 1.0 |
2 |
%define major 1 |
3 |
%define libname %mklibname zeitgeist %api %major |
4 |
%define develname %mklibname -d zeitgeist |
5 |
|
6 |
Name: libzeitgeist |
7 |
Version: 0.3.18 |
8 |
Release: %mkrel 5 |
9 |
Summary: Client library for applications that want to interact with the Zeitgeist daemon |
10 |
Group: System/Libraries |
11 |
License: LGPLv3 and GPLv3 |
12 |
URL: https://launchpad.net/libzeitgeist |
13 |
Source0: http://launchpad.net/%{name}/0.3/%{version}/+download/%{name}-%{version}.tar.gz |
14 |
BuildRequires: pkgconfig(gio-2.0) >= 2.26 |
15 |
BuildRequires: pkgconfig(gio-unix-2.0) |
16 |
BuildRequires: pkgconfig(glib-2.0) >= 2.26 |
17 |
BuildRequires: pkgconfig(gobject-2.0) >= 2.26 |
18 |
BuildRequires: gtk-doc |
19 |
# for tests: |
20 |
BuildRequires: dbus-x11 |
21 |
# zeitgeist is just a runtime and the reason to install libzeitgeist |
22 |
Requires: zeitgeist |
23 |
|
24 |
%description |
25 |
This project provides a client library for applications that want to interact |
26 |
with the Zeitgeist daemon. The library is written in C using glib and provides |
27 |
an asynchronous GObject oriented API. |
28 |
|
29 |
%package -n %libname |
30 |
Summary: Shared library for %name |
31 |
Group: System/Libraries |
32 |
|
33 |
%description -n %libname |
34 |
This project provides a client library for applications that want to interact |
35 |
with the Zeitgeist daemon. The library is written in C using glib and provides |
36 |
an asynchronous GObject oriented API. |
37 |
|
38 |
%package -n %develname |
39 |
Summary: Development files for %{name} |
40 |
Group: Development/C |
41 |
Requires: %{libname} = %{version}-%{release} |
42 |
|
43 |
%description -n %develname |
44 |
The %{name}-devel package contains libraries and header files for |
45 |
developing applications that use %{name}. |
46 |
|
47 |
%prep |
48 |
%setup -q |
49 |
|
50 |
%build |
51 |
%configure2_5x --disable-static |
52 |
%make |
53 |
|
54 |
%install |
55 |
%makeinstall_std |
56 |
|
57 |
install -d -p -m 755 %{buildroot}%{_datadir}/vala/vapi |
58 |
install -D -p -m 644 bindings/zeitgeist-1.0.{vapi,deps} %{buildroot}%{_datadir}/vala/vapi |
59 |
find %{buildroot} -name '*.la' -exec rm -f {} ';' |
60 |
|
61 |
# remove duplicate documentation |
62 |
rm -fr %{buildroot}%{_defaultdocdir}/%{name} |
63 |
|
64 |
%files -n %libname |
65 |
%doc COPYING COPYING.GPL README |
66 |
%{_libdir}/libzeitgeist-%{api}.so.%{major} |
67 |
%{_libdir}/libzeitgeist-%{api}.so.%{major}.* |
68 |
|
69 |
%files -n %develname |
70 |
%doc AUTHORS ChangeLog COPYING COPYING.GPL MAINTAINERS NEWS |
71 |
%doc examples/*.vala examples/*.c |
72 |
%{_datadir}/gtk-doc/html/zeitgeist-1.0/ |
73 |
%{_includedir}/zeitgeist-1.0/ |
74 |
%{_libdir}/pkgconfig/zeitgeist-1.0.pc |
75 |
%{_libdir}/*.so |
76 |
%{_datadir}/vala/vapi/ |