/[packages]/cauldron/links/current/SPECS/links.spec
ViewVC logotype

Annotation of /cauldron/links/current/SPECS/links.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 125765 - (hide annotations) (download)
Mon Jul 18 05:22:45 2011 UTC (12 years, 8 months ago) by fwang
File size: 4468 byte(s)
rebuild for new directfb
1 tv 73200 %define version 2.2
2 fwang 125765 %define rel 11
3 tv 73200
4     Summary: Lynx-like text WWW browser
5     Name: links
6     Version: %{version}
7     Release: %mkrel %rel
8     License: GPLv2+
9     Group: Networking/WWW
10    
11     Source0: http://atrey.karlin.mff.cuni.cz/~clock/twibright/links/download/%name-%version.tar.bz2
12     Source4: links.cfg
13     Patch1: links-2.1pre18-no-flashy-white.patch
14     Patch3: links-0.96-no-weird-unhx-ing-of-command-line-args.patch
15     Patch6: cookies-save-0.96.patch
16     Patch7: links-0.96-no-domain-security.patch
17     Patch8: links-current-color-by-default--and-vt100-frames.patch
18     Patch10: links-2.2-be-graphic-when-called-_links-graphic_.patch
19     Patch11: links-2.2-convert-old-bookmarks-in-new-format.patch
20     Patch12: links-2.1pre31-gz.patch
21     Patch14: links-2.1pre17-automake.patch
22     Patch21: links-2.1pre17-fix-segfault-on-loading-cookies.patch
23     Patch22: links-2.1pre2-64bit-fixes.patch
24     Patch23: links-2.1pre31-dont-have-two-assocations-with-same-label--otherwise-one-cant-override-shared-config.patch
25     Patch24: links-2.1pre18-CVE-2006-5925--disable-SMB.patch
26    
27     URL: http://links.twibright.com/
28     BuildRequires: libx11-devel
29     BuildRequires: libpng-devel
30     BuildRequires: libtiff-devel
31     BuildRequires: openssl-devel
32     BuildRequires: jpeg-devel
33     BuildRequires: bzip2-devel
34     BuildRequires: gpm-devel
35     BuildRequires: zlib-devel
36     BuildRequires: svgalib-devel
37     BuildRequires: directfb-devel >= 0.9.17
38     Provides: webclient
39     Requires: links-common = %{version}
40    
41     %description
42     Links is a text based WWW browser, at first look similar to Lynx, but
43     somehow different:
44    
45     - renders tables and frames
46     - displays colors as specified in current HTML page
47     - uses drop-down menu (like in Midnight Commander)
48     - can download files in background
49     - partially handle Javascript
50    
51     %package graphic
52     Summary: Lynx-like text/X11 WWW browser
53     Group: Networking/WWW
54     Requires: links-common = %{version}
55     Provides: webclient, links = %{version}-%{release}
56     Requires: indexhtml
57    
58     %description graphic
59     Links is a text/X11 based WWW browser, at first look similar to Lynx, but
60     somehow different:
61    
62     - renders tables and frames
63     - displays colors as specified in current HTML page
64     - uses drop-down menu (like in Midnight Commander)
65     - can download files in background
66     - partially handle Javascript
67    
68     %package common
69     Summary: Lynx-like text/X11 WWW browser
70     Group: Networking/WWW
71     Requires: links-common = %{version}
72     Conflicts: links < 2.1-0.pre18.5mdk, links-graphic < 2.1-0.pre18.5mdk
73    
74     %description common
75     Common files for links and links-graphic
76    
77     %prep
78     %setup -q -n %name-%version
79     %patch1 -p1
80     %patch3 -p1
81     %patch6 -p1
82     %patch7 -p1
83     %patch8 -p1
84     %patch10 -p1 -b .be-graphic-when-called-_links-graphic_
85     %patch11 -p1 -b .convert-old-bookmarks-in-new-format
86     %patch12 -p1 -b .gzip
87     %patch14 -p1 -b .automake18
88     %patch21 -p1
89     %patch22 -p1 -b .64bit-fixes
90     %patch23 -p1
91     %patch24 -p1
92    
93     %build
94     autoreconf -fi
95     %configure2_5x
96     (cd Unicode ; LC_ALL=C ./gen )
97     %make
98    
99     cp -f links links-text
100    
101     # Needed to fix linkage problem
102     #rm -f bfu.o dip.o lru.o x.o framebuffer.o terminal.o kbd.o links_icon.o
103     make clean
104     %configure2_5x --enable-graphics
105     %make
106    
107     cp -f links links-graphic
108    
109     %install
110     rm -rf $RPM_BUILD_ROOT
111    
112     %makeinstall_std
113    
114     rm -f %buildroot%{_bindir}/links
115     install links-graphic links-text %buildroot%{_bindir}
116    
117     install -D -m 644 %SOURCE4 %buildroot/etc/links.cfg
118    
119     mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
120 wally 91747 cat > $RPM_BUILD_ROOT%{_datadir}/applications/%{_real_vendor}-%{name}.desktop << EOF
121 tv 73200 [Desktop Entry]
122     Name=Links
123     Comment=Lynx-like text/graphic Web browser
124 rda 76936 Exec=/usr/bin/links-graphic /usr/share/indexhtml/index.html
125 tv 73200 Icon=web_browser_section
126     Terminal=false
127     Type=Application
128     Categories=Network;WebBrowser;
129     EOF
130    
131    
132     %clean
133     rm -rf $RPM_BUILD_ROOT
134    
135     %triggerpostun -- links
136     if [ ! -e /usr/bin/links ]; then
137     update-alternatives --auto links
138     fi
139    
140     %triggerpostun graphic -- links
141     if [ ! -e /usr/bin/links ]; then
142     update-alternatives --auto links
143     fi
144    
145     %post
146     update-alternatives --install /usr/bin/links links /usr/bin/links-text 10
147    
148     %postun
149     if [ "$1" = "0" ]; then
150     update-alternatives --remove links /usr/bin/links-text
151     fi
152    
153     %post graphic
154     update-alternatives --install /usr/bin/links links /usr/bin/links-graphic 20
155    
156     %postun graphic
157     if [ "$1" = "0" ]; then
158     update-alternatives --remove links /usr/bin/links-graphic
159     fi
160    
161     %files
162     %defattr(-,root,root)
163     %{_bindir}/links-text
164    
165     %files graphic
166     %defattr(-,root,root)
167     %{_bindir}/links-graphic
168     %{_datadir}/applications/*
169    
170     %files common
171     %defattr(-,root,root)
172     %doc AUTHORS BUGS ChangeLog README SITES TODO
173     %config(noreplace) /etc/links.cfg
174     %{_mandir}/*/*
175    
176    
177    
178    

  ViewVC Help
Powered by ViewVC 1.1.30