/[packages]/cauldron/links/current/SPECS/links.spec
ViewVC logotype

Annotation of /cauldron/links/current/SPECS/links.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 145334 - (hide annotations) (download)
Mon Sep 19 07:00:13 2011 UTC (12 years, 7 months ago) by fwang
File size: 4521 byte(s)
fix build with latest libpng
1 tv 73200 %define version 2.2
2 fwang 145330 %define rel 12
3 tv 73200
4     Summary: Lynx-like text WWW browser
5     Name: links
6     Version: %{version}
7     Release: %mkrel %rel
8     License: GPLv2+
9     Group: Networking/WWW
10    
11     Source0: http://atrey.karlin.mff.cuni.cz/~clock/twibright/links/download/%name-%version.tar.bz2
12     Source4: links.cfg
13 fwang 145334 Patch0: links-2.3_pre1-libpng-1.5.patch
14 tv 73200 Patch1: links-2.1pre18-no-flashy-white.patch
15     Patch3: links-0.96-no-weird-unhx-ing-of-command-line-args.patch
16     Patch6: cookies-save-0.96.patch
17     Patch7: links-0.96-no-domain-security.patch
18     Patch8: links-current-color-by-default--and-vt100-frames.patch
19     Patch10: links-2.2-be-graphic-when-called-_links-graphic_.patch
20     Patch11: links-2.2-convert-old-bookmarks-in-new-format.patch
21     Patch12: links-2.1pre31-gz.patch
22     Patch14: links-2.1pre17-automake.patch
23     Patch21: links-2.1pre17-fix-segfault-on-loading-cookies.patch
24     Patch22: links-2.1pre2-64bit-fixes.patch
25     Patch23: links-2.1pre31-dont-have-two-assocations-with-same-label--otherwise-one-cant-override-shared-config.patch
26     Patch24: links-2.1pre18-CVE-2006-5925--disable-SMB.patch
27    
28     URL: http://links.twibright.com/
29     BuildRequires: libx11-devel
30     BuildRequires: libpng-devel
31     BuildRequires: libtiff-devel
32     BuildRequires: openssl-devel
33     BuildRequires: jpeg-devel
34     BuildRequires: bzip2-devel
35     BuildRequires: gpm-devel
36     BuildRequires: zlib-devel
37     BuildRequires: svgalib-devel
38     BuildRequires: directfb-devel >= 0.9.17
39     Provides: webclient
40     Requires: links-common = %{version}
41    
42     %description
43     Links is a text based WWW browser, at first look similar to Lynx, but
44     somehow different:
45    
46     - renders tables and frames
47     - displays colors as specified in current HTML page
48     - uses drop-down menu (like in Midnight Commander)
49     - can download files in background
50     - partially handle Javascript
51    
52     %package graphic
53     Summary: Lynx-like text/X11 WWW browser
54     Group: Networking/WWW
55     Requires: links-common = %{version}
56     Provides: webclient, links = %{version}-%{release}
57     Requires: indexhtml
58    
59     %description graphic
60     Links is a text/X11 based WWW browser, at first look similar to Lynx, but
61     somehow different:
62    
63     - renders tables and frames
64     - displays colors as specified in current HTML page
65     - uses drop-down menu (like in Midnight Commander)
66     - can download files in background
67     - partially handle Javascript
68    
69     %package common
70     Summary: Lynx-like text/X11 WWW browser
71     Group: Networking/WWW
72     Requires: links-common = %{version}
73     Conflicts: links < 2.1-0.pre18.5mdk, links-graphic < 2.1-0.pre18.5mdk
74    
75     %description common
76     Common files for links and links-graphic
77    
78     %prep
79     %setup -q -n %name-%version
80 fwang 145334 %patch0 -p0
81 tv 73200 %patch1 -p1
82     %patch3 -p1
83     %patch6 -p1
84     %patch7 -p1
85     %patch8 -p1
86     %patch10 -p1 -b .be-graphic-when-called-_links-graphic_
87     %patch11 -p1 -b .convert-old-bookmarks-in-new-format
88     %patch12 -p1 -b .gzip
89     %patch14 -p1 -b .automake18
90     %patch21 -p1
91     %patch22 -p1 -b .64bit-fixes
92     %patch23 -p1
93     %patch24 -p1
94    
95     %build
96     autoreconf -fi
97     %configure2_5x
98     (cd Unicode ; LC_ALL=C ./gen )
99     %make
100    
101     cp -f links links-text
102    
103     # Needed to fix linkage problem
104     #rm -f bfu.o dip.o lru.o x.o framebuffer.o terminal.o kbd.o links_icon.o
105     make clean
106     %configure2_5x --enable-graphics
107     %make
108    
109     cp -f links links-graphic
110    
111     %install
112     rm -rf $RPM_BUILD_ROOT
113    
114     %makeinstall_std
115    
116     rm -f %buildroot%{_bindir}/links
117     install links-graphic links-text %buildroot%{_bindir}
118    
119     install -D -m 644 %SOURCE4 %buildroot/etc/links.cfg
120    
121     mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
122 wally 91747 cat > $RPM_BUILD_ROOT%{_datadir}/applications/%{_real_vendor}-%{name}.desktop << EOF
123 tv 73200 [Desktop Entry]
124     Name=Links
125     Comment=Lynx-like text/graphic Web browser
126 rda 76936 Exec=/usr/bin/links-graphic /usr/share/indexhtml/index.html
127 tv 73200 Icon=web_browser_section
128     Terminal=false
129     Type=Application
130     Categories=Network;WebBrowser;
131     EOF
132    
133    
134     %clean
135     rm -rf $RPM_BUILD_ROOT
136    
137     %triggerpostun -- links
138     if [ ! -e /usr/bin/links ]; then
139     update-alternatives --auto links
140     fi
141    
142     %triggerpostun graphic -- links
143     if [ ! -e /usr/bin/links ]; then
144     update-alternatives --auto links
145     fi
146    
147     %post
148     update-alternatives --install /usr/bin/links links /usr/bin/links-text 10
149    
150     %postun
151     if [ "$1" = "0" ]; then
152     update-alternatives --remove links /usr/bin/links-text
153     fi
154    
155     %post graphic
156     update-alternatives --install /usr/bin/links links /usr/bin/links-graphic 20
157    
158     %postun graphic
159     if [ "$1" = "0" ]; then
160     update-alternatives --remove links /usr/bin/links-graphic
161     fi
162    
163     %files
164     %defattr(-,root,root)
165     %{_bindir}/links-text
166    
167     %files graphic
168     %defattr(-,root,root)
169     %{_bindir}/links-graphic
170     %{_datadir}/applications/*
171    
172     %files common
173     %defattr(-,root,root)
174     %doc AUTHORS BUGS ChangeLog README SITES TODO
175     %config(noreplace) /etc/links.cfg
176     %{_mandir}/*/*
177    
178    
179    
180    

  ViewVC Help
Powered by ViewVC 1.1.30