/[packages]/cauldron/links/current/SPECS/links.spec
ViewVC logotype

Annotation of /cauldron/links/current/SPECS/links.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 76940 - (hide annotations) (download)
Thu Mar 24 15:52:07 2011 UTC (13 years, 1 month ago) by rda
File size: 4507 byte(s)
SILENT bump release
1 tv 73200 %define version 2.2
2 rda 76940 %define rel 9
3 tv 73200
4     Summary: Lynx-like text WWW browser
5     Name: links
6     Version: %{version}
7     Release: %mkrel %rel
8     License: GPLv2+
9     Group: Networking/WWW
10    
11     Source0: http://atrey.karlin.mff.cuni.cz/~clock/twibright/links/download/%name-%version.tar.bz2
12     Source4: links.cfg
13     Patch1: links-2.1pre18-no-flashy-white.patch
14     Patch3: links-0.96-no-weird-unhx-ing-of-command-line-args.patch
15     Patch6: cookies-save-0.96.patch
16     Patch7: links-0.96-no-domain-security.patch
17     Patch8: links-current-color-by-default--and-vt100-frames.patch
18     Patch10: links-2.2-be-graphic-when-called-_links-graphic_.patch
19     Patch11: links-2.2-convert-old-bookmarks-in-new-format.patch
20     Patch12: links-2.1pre31-gz.patch
21     Patch14: links-2.1pre17-automake.patch
22     Patch21: links-2.1pre17-fix-segfault-on-loading-cookies.patch
23     Patch22: links-2.1pre2-64bit-fixes.patch
24     Patch23: links-2.1pre31-dont-have-two-assocations-with-same-label--otherwise-one-cant-override-shared-config.patch
25     Patch24: links-2.1pre18-CVE-2006-5925--disable-SMB.patch
26    
27     URL: http://links.twibright.com/
28     BuildRequires: libx11-devel
29     BuildRequires: libpng-devel
30     BuildRequires: libtiff-devel
31     BuildRequires: openssl-devel
32     BuildRequires: jpeg-devel
33     BuildRequires: bzip2-devel
34     BuildRequires: gpm-devel
35     BuildRequires: zlib-devel
36     BuildRequires: svgalib-devel
37     BuildRequires: directfb-devel >= 0.9.17
38     Provides: webclient
39     Requires: links-common = %{version}
40     BuildRoot: %{_tmppath}/%{name}-%{version}-root
41    
42     %description
43     Links is a text based WWW browser, at first look similar to Lynx, but
44     somehow different:
45    
46     - renders tables and frames
47     - displays colors as specified in current HTML page
48     - uses drop-down menu (like in Midnight Commander)
49     - can download files in background
50     - partially handle Javascript
51    
52     %package graphic
53     Summary: Lynx-like text/X11 WWW browser
54     Group: Networking/WWW
55     Requires: links-common = %{version}
56     Provides: webclient, links = %{version}-%{release}
57     Requires: indexhtml
58    
59     %description graphic
60     Links is a text/X11 based WWW browser, at first look similar to Lynx, but
61     somehow different:
62    
63     - renders tables and frames
64     - displays colors as specified in current HTML page
65     - uses drop-down menu (like in Midnight Commander)
66     - can download files in background
67     - partially handle Javascript
68    
69     %package common
70     Summary: Lynx-like text/X11 WWW browser
71     Group: Networking/WWW
72     Requires: links-common = %{version}
73     Conflicts: links < 2.1-0.pre18.5mdk, links-graphic < 2.1-0.pre18.5mdk
74    
75     %description common
76     Common files for links and links-graphic
77    
78     %prep
79     %setup -q -n %name-%version
80     %patch1 -p1
81     %patch3 -p1
82     %patch6 -p1
83     %patch7 -p1
84     %patch8 -p1
85     %patch10 -p1 -b .be-graphic-when-called-_links-graphic_
86     %patch11 -p1 -b .convert-old-bookmarks-in-new-format
87     %patch12 -p1 -b .gzip
88     %patch14 -p1 -b .automake18
89     %patch21 -p1
90     %patch22 -p1 -b .64bit-fixes
91     %patch23 -p1
92     %patch24 -p1
93    
94     %build
95     autoreconf -fi
96     %configure2_5x
97     (cd Unicode ; LC_ALL=C ./gen )
98     %make
99    
100     cp -f links links-text
101    
102     # Needed to fix linkage problem
103     #rm -f bfu.o dip.o lru.o x.o framebuffer.o terminal.o kbd.o links_icon.o
104     make clean
105     %configure2_5x --enable-graphics
106     %make
107    
108     cp -f links links-graphic
109    
110     %install
111     rm -rf $RPM_BUILD_ROOT
112    
113     %makeinstall_std
114    
115     rm -f %buildroot%{_bindir}/links
116     install links-graphic links-text %buildroot%{_bindir}
117    
118     install -D -m 644 %SOURCE4 %buildroot/etc/links.cfg
119    
120     mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
121     cat > $RPM_BUILD_ROOT%{_datadir}/applications/mandriva-%{name}.desktop << EOF
122     [Desktop Entry]
123     Name=Links
124     Comment=Lynx-like text/graphic Web browser
125 rda 76936 Exec=/usr/bin/links-graphic /usr/share/indexhtml/index.html
126 tv 73200 Icon=web_browser_section
127     Terminal=false
128     Type=Application
129     Categories=Network;WebBrowser;
130     EOF
131    
132    
133     %clean
134     rm -rf $RPM_BUILD_ROOT
135    
136     %triggerpostun -- links
137     if [ ! -e /usr/bin/links ]; then
138     update-alternatives --auto links
139     fi
140    
141     %triggerpostun graphic -- links
142     if [ ! -e /usr/bin/links ]; then
143     update-alternatives --auto links
144     fi
145    
146     %post
147     update-alternatives --install /usr/bin/links links /usr/bin/links-text 10
148    
149     %postun
150     if [ "$1" = "0" ]; then
151     update-alternatives --remove links /usr/bin/links-text
152     fi
153    
154     %post graphic
155     update-alternatives --install /usr/bin/links links /usr/bin/links-graphic 20
156    
157     %postun graphic
158     if [ "$1" = "0" ]; then
159     update-alternatives --remove links /usr/bin/links-graphic
160     fi
161    
162     %files
163     %defattr(-,root,root)
164     %{_bindir}/links-text
165    
166     %files graphic
167     %defattr(-,root,root)
168     %{_bindir}/links-graphic
169     %{_datadir}/applications/*
170    
171     %files common
172     %defattr(-,root,root)
173     %doc AUTHORS BUGS ChangeLog README SITES TODO
174     %config(noreplace) /etc/links.cfg
175     %{_mandir}/*/*
176    
177    
178    
179    

  ViewVC Help
Powered by ViewVC 1.1.30