/[packages]/cauldron/lxqt-panel/current/SPECS/lxqt-panel.spec
ViewVC logotype

Diff of /cauldron/lxqt-panel/current/SPECS/lxqt-panel.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

revision 779827 by umeabot, Tue Oct 14 22:50:20 2014 UTC revision 779828 by doktor5000, Fri Oct 17 19:10:42 2014 UTC
# Line 1  Line 1 
1    %define qt5 1
2    
3  Name: lxqt-panel  Name: lxqt-panel
4  Version: 0.7.0  Version: 0.8.0
5  Release: %mkrel 5  Release: %mkrel 1
6  Source0: http://lxqt.org/downloads/lxqt/%{version}/%{name}-%{version}.tar.xz  Source0: http://lxqt.org/downloads/lxqt/%{version}/%{name}-%{version}.tar.xz
7  Patch0: lxqt-panel-0.7.0-mga-customize-default-panel.patch  Patch0: lxqt-panel-0.7.0-mga-customize-default-panel.patch
8  Summary: Panel for the LXQt desktop  Summary: Panel for the LXQt desktop
# Line 8  URL: http://lxqt.org/ Line 10  URL: http://lxqt.org/
10  License: GPL  License: GPL
11  Group: Graphical desktop/KDE  Group: Graphical desktop/KDE
12  BuildRequires: cmake  BuildRequires: cmake
13    %if "%{qt5}" == "1"
14    BuildRequires: pkgconfig(lxqt-qt5)
15    BuildRequires: pkgconfig(lxqt-globalkeys-qt5)
16    BuildRequires: pkgconfig(lxqt-globalkeys-ui-qt5)
17    BuildRequires: pkgconfig(lxqtmount-qt5)
18    BuildRequires: pkgconfig(sysstat-qt5)
19    %else
20    BuildRequires: pkgconfig(lxqt)
21  BuildRequires: pkgconfig(lxqt-globalkeys)  BuildRequires: pkgconfig(lxqt-globalkeys)
22  BuildRequires: pkgconfig(lxqt-globalkeys-ui)  BuildRequires: pkgconfig(lxqt-globalkeys-ui)
23  BuildRequires: pkgconfig(lxqtmount)  BuildRequires: pkgconfig(lxqtmount)
24  BuildRequires: pkgconfig(lxqt)  BuildRequires: qt4-devel
25    BuildRequires: libsysstat-devel
26    %endif
27  BuildRequires: pulseaudio-devel  BuildRequires: pulseaudio-devel
28  BuildRequires: pkgconfig(icu-uc)  BuildRequires: pkgconfig(icu-uc)
29  BuildRequires: pkgconfig(libstatgrab)  BuildRequires: pkgconfig(libstatgrab)
30  BuildRequires: pkgconfig(libmenu-cache)  BuildRequires: pkgconfig(libmenu-cache)
31  BuildRequires: pkgconfig(xcomposite)  BuildRequires: pkgconfig(xcomposite)
32  BuildRequires: lm_sensors-devel  BuildRequires: lm_sensors-devel
33  BuildRequires: libsysstat-devel  
 BuildRequires: qt4-devel  
34  Obsoletes: razorqt-panel < 0.5.3-1  Obsoletes: razorqt-panel < 0.5.3-1
35    
36  %description  %description
37  Panel for the LXQt desktop  Panel for the LXQt desktop
38    
39  %prep  %prep
40  %setup -q -c %{name}-%{version}  %setup -q %{name}-%{version}
41  %apply_patches  %apply_patches
42    %if "%{qt5}" == "1"
43    %cmake -DUSE_QT5=ON
44    %else
45  %cmake  %cmake
46    %endif
47    
48  %build  %build
49  %make -C build  %make -C build

Legend:
Removed from v.779827  
changed lines
  Added in v.779828

  ViewVC Help
Powered by ViewVC 1.1.28