1 |
%define name magicpoint |
2 |
%define version 1.13a |
3 |
%define release %mkrel 3 |
4 |
|
5 |
Summary: Presentation tool |
6 |
Name: %{name} |
7 |
Version: %{version} |
8 |
Release: %{release} |
9 |
License: BSD like |
10 |
URL: http://member.wide.ad.jp/wg/mgp/ |
11 |
Group: Office |
12 |
Source: ftp://sh.wide.ad.jp/WIDE/free-ware/mgp/%{name}-%{version}.tar.gz |
13 |
Patch0: magicpoint-1.10a-remove-rpath.patch |
14 |
Patch1: magicpoint-1.09a-defaults-to-latin1.patch |
15 |
Patch2: magicpoint-1.09a-emacs-mode--add-font-lock.patch |
16 |
Patch3: magicpoint-1.09a-xfont-force-same-one.patch |
17 |
#Patch4: magicpoint-1.10a-freetype.patch |
18 |
#Patch5: magicpoint-1.10a-missing-decl.patch |
19 |
BuildRoot: %_tmppath/%{name}-buildroot |
20 |
Buildrequires: freetype-devel flex byacc X11-devel |
21 |
BuildRequires: imake gccmakedep |
22 |
BuildRequires: imlib-devel |
23 |
Requires: libjpeg-progs |
24 |
#Requires: fonts-ttf-japanese |
25 |
|
26 |
%description |
27 |
MagicPoint is an X11 based presentation tool. It is designed to make |
28 |
simple presentations easy while making complicated presentations |
29 |
possible. Its presentation file is just text so that you can create |
30 |
presentation files quickly with your favorite editor (e.g. Emacs). |
31 |
|
32 |
It includes a true type library for elegant looking text and effects. |
33 |
|
34 |
%prep |
35 |
rm -rf %{buildroot} |
36 |
|
37 |
%setup -q |
38 |
#%patch0 -p1 |
39 |
%patch1 -p1 |
40 |
%patch2 -p1 |
41 |
#%patch4 -p0 |
42 |
#%patch5 -p0 |
43 |
|
44 |
%build |
45 |
%configure2_5x --enable-locale |
46 |
xmkmf -a |
47 |
make Makefiles |
48 |
|
49 |
|
50 |
%install |
51 |
%makeinstall_std install.man |
52 |
|
53 |
install -m 644 -D contrib/mgp-mode.el %{buildroot}%{_datadir}/emacs/site-lisp/mgp-mode.el |
54 |
|
55 |
install -d %{buildroot}%{_sysconfdir}/emacs/site-start.d |
56 |
cat <<EOF >%{buildroot}%{_sysconfdir}/emacs/site-start.d/%{name}.el |
57 |
(autoload 'mgp-mode "mgp-mode" "MagicPoint editing mode" t) |
58 |
(add-to-list 'auto-mode-alist '("\\\\.mgp$" . mgp-mode)) |
59 |
EOF |
60 |
|
61 |
#clean cvs things |
62 |
for i in `find . -type d -name CVS` `find . -type f -name .cvs\*` `find . -type f -name .#\*`; do |
63 |
if [ -e "$i" ]; then rm -r $i; fi >&/dev/null |
64 |
done |
65 |
rm -rf %{buildroot}/usr/X11R6/lib*/X11/doc/html |
66 |
|
67 |
%clean |
68 |
rm -rf %{buildroot} |
69 |
|
70 |
%files |
71 |
%defattr (-,root,root) |
72 |
%doc COPYRIGHT FAQ README* RELNOTES SYNTAX USAGE |
73 |
%doc sample/ |
74 |
%{_datadir}/emacs/site-lisp/* |
75 |
%config(noreplace) %{_sysconfdir}/emacs/site-start.d/* |
76 |
%{_bindir}/* |
77 |
%{_mandir}/*/* |
78 |
%{_prefix}/lib/X11/mgp/* |
79 |
|
80 |
|