1 |
%define url_ver %(echo %{version}|cut -d. -f1,2) |
2 |
|
3 |
Name: mate-terminal |
4 |
Summary: MATE terminal emulator |
5 |
Version: 1.6.2 |
6 |
Release: %mkrel 1 |
7 |
URL: http://mate-desktop.org |
8 |
License: GPLv2+ |
9 |
Group: Graphical desktop/MATE |
10 |
Source0: http://pub.mate-desktop.org/releases/%{url_ver}/%{name}-%{version}.tar.xz |
11 |
# (fc) add -geometry support |
12 |
Patch0: gnome-terminal-2.25.3-geometry.patch |
13 |
# (fc) change default background (grey on black) |
14 |
Patch2: gnome-terminal-2.10.0-background.patch |
15 |
|
16 |
BuildRequires: docbook-dtd412-xml |
17 |
BuildRequires: intltool |
18 |
BuildRequires: mate-common |
19 |
BuildRequires: rarian |
20 |
BuildRequires: xsltproc |
21 |
BuildRequires: pkgconfig(glib-2.0) |
22 |
BuildRequires: pkgconfig(gtk+-2.0) |
23 |
BuildRequires: pkgconfig(ice) |
24 |
BuildRequires: pkgconfig(mate-doc-utils) |
25 |
BuildRequires: pkgconfig(sm) |
26 |
BuildRequires: pkgconfig(vte) |
27 |
BuildRequires: pkgconfig(x11) |
28 |
BuildRequires: pkgconfig(dconf) |
29 |
|
30 |
%description |
31 |
Mate-terminal is a terminal emulator for MATE. It supports translucent |
32 |
backgrounds, opening multiple terminals in a single window (tabs) and |
33 |
clickable URLs. |
34 |
|
35 |
%prep |
36 |
%setup -q |
37 |
%apply_patches |
38 |
|
39 |
%build |
40 |
%configure2_5x |
41 |
%make |
42 |
|
43 |
%install |
44 |
%makeinstall_std |
45 |
rm -rf %{buildroot}/var |
46 |
|
47 |
desktop-file-install --vendor="" \ |
48 |
--remove-category="Application" \ |
49 |
--add-only-show-in="MATE" \ |
50 |
--dir %{buildroot}%{_datadir}/applications %{buildroot}%{_datadir}/applications/* |
51 |
|
52 |
%find_lang %{name} |
53 |
for omf in %{buildroot}%_datadir/omf/%name/%name-??*.omf;do |
54 |
echo "%lang($(basename "$omf"|sed -e s/%name-// -e s/.omf//)) $(echo "$omf"|sed -e s!%{buildroot}!!)" >> %name.lang |
55 |
done |
56 |
|
57 |
%post |
58 |
if [ "$1" = "2" ]; then |
59 |
update-alternatives --remove xvt %{_bindir}/mate-terminal |
60 |
fi |
61 |
|
62 |
%files -f %{name}.lang |
63 |
%doc AUTHORS COPYING NEWS README ChangeLog |
64 |
%{_mandir}/man1/* |
65 |
%{_bindir}/mate-terminal |
66 |
%{_bindir}/mate-terminal.wrapper |
67 |
%{_datadir}/mate-terminal |
68 |
%{_datadir}/mate/help/mate-terminal |
69 |
%{_datadir}/applications/mate-terminal.desktop |
70 |
%{_datadir}/glib-2.0/schemas/org.mate.terminal.gschema.xml |
71 |
%dir %{_datadir}/omf/mate-terminal |
72 |
%{_datadir}/omf/mate-terminal/*-C.omf |
73 |
|