/[packages]/cauldron/maven-license-plugin/current/SPECS/maven-license-plugin.spec
ViewVC logotype

Contents of /cauldron/maven-license-plugin/current/SPECS/maven-license-plugin.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1099842 - (show annotations) (download)
Tue May 9 11:06:32 2017 UTC (7 years, 5 months ago) by neoclust
File size: 3564 byte(s)
Fix build against current plexus-utils
1 Name: maven-license-plugin
2 Epoch: 1
3 Version: 1.8.0
4 Release: %mkrel 4
5 Summary: Maven plugin to update header licenses of source files
6
7 Group: Development/Java
8 License: ASL 2.0
9 URL: http://code.google.com/p/maven-license-plugin
10 ### upstream only provides binaries or source without build scripts
11 # tar creation instructions
12 # svn export http://maven-license-plugin.googlecode.com/svn/tags/maven-license-plugin-1.8.0 maven-license-plugin
13 # tar cfJ maven-license-plugin-1.8.0.tar.xz maven-license-plugin
14 Source0: %{name}-%{version}.tar.xz
15 # remove testng dep (tests are skipped) and maven-license-plugin call
16 Patch0: 001-mavenlicenseplugin-fixbuild.patch
17 BuildArch: noarch
18
19 BuildRequires: java-devel
20 BuildRequires: jpackage-utils
21 BuildRequires: apache-resource-bundles
22 BuildRequires: maven-local
23 BuildRequires: maven-assembly-plugin
24 BuildRequires: maven-deploy-plugin
25 BuildRequires: maven-jar-plugin
26 BuildRequires: maven-javadoc-plugin
27 BuildRequires: maven-source-plugin
28 BuildRequires: maven-changelog-plugin
29 BuildRequires: maven-changes-plugin
30 BuildRequires: maven-clean-plugin
31 BuildRequires: maven-compiler-plugin
32 BuildRequires: maven-dependency-plugin
33 BuildRequires: maven-help-plugin
34 BuildRequires: maven-idea-plugin
35 BuildRequires: maven-install-plugin
36 BuildRequires: maven-plugin-plugin
37 BuildRequires: maven-pmd-plugin
38 BuildRequires: maven-resources-plugin
39 BuildRequires: maven-repository-plugin
40 BuildRequires: maven-remote-resources-plugin
41 BuildRequires: maven-site-plugin
42 BuildRequires: maven-shared
43 BuildRequires: maven-surefire-plugin
44 BuildRequires: maven-plugin-testing-harness
45 BuildRequires: maven-release-plugin
46 BuildRequires: plexus-utils
47 BuildRequires: plexus-classworlds
48 BuildRequires: xml-commons-apis
49 BuildRequires: xmltool
50 BuildRequires: maven-source-plugin
51
52 Requires: jpackage-utils
53 Requires: maven
54 Requires: maven-shared
55 Requires: xmltool
56
57 %description
58 maven-license-plugin is a Maven plugin that help you managing license
59 headers in source files. Basically, when you are developing a project
60 either in open source or in a company, you often need to add at the top
61 of your source files a license to protect your work.
62 This plugin lets you maintain the headers, including checking if the
63 header is present, generating a report and of course having the
64 possibility to update / reformat missing license headers.
65
66
67 %package javadoc
68 Summary: Javadocs for %{name}
69 Group: Documentation
70 Requires: jpackage-utils
71 BuildArch: noarch
72
73 %description javadoc
74 This package contains the API documentation for %{name}.
75
76
77 %prep
78 %setup -q -n %{name}
79 %patch0 -p1
80 # fix EOL
81 sed -i 's/\r//' LICENSE.txt
82 sed -i 's/\r//' NOTICE.txt
83
84 # Remove wagon-webdav extension which is not available
85 %pom_xpath_remove pom:build/pom:extensions
86
87 %build
88 mvn-rpmbuild -Dmaven.test.skip=true install javadoc:aggregate
89
90 %install
91 mkdir -p $RPM_BUILD_ROOT%{_javadir}
92
93 # jar
94 install -Dp -m 644 target/%{name}-%{version}.jar \
95 $RPM_BUILD_ROOT%{_javadir}/%{name}.jar
96
97 # javadoc
98 mkdir -p $RPM_BUILD_ROOT%{_javadocdir}/%{name}
99 cp -rp target/site/apidocs/ $RPM_BUILD_ROOT%{_javadocdir}/%{name}
100
101 # pom
102 install -d -m 755 $RPM_BUILD_ROOT%{_mavenpomdir}
103 install -pm 644 pom.xml $RPM_BUILD_ROOT%{_mavenpomdir}/JPP-%{name}.pom
104
105 %add_maven_depmap JPP-%{name}.pom %{name}.jar
106
107 %files
108 %doc NOTICE.txt LICENSE.txt
109 %{_mavenpomdir}/*
110 %{_datadir}/maven-metadata/*
111 %{_javadir}/*
112
113 %files javadoc
114 %doc LICENSE.txt
115 %{_javadocdir}/%{name}

  ViewVC Help
Powered by ViewVC 1.1.30