1 |
Name: maven-license-plugin |
2 |
Version: 1.8.0 |
3 |
Epoch: 1 |
4 |
Release: %mkrel 7 |
5 |
Summary: Maven plugin to update header licenses of source files |
6 |
|
7 |
Group: Development/Java |
8 |
License: ASL 2.0 |
9 |
URL: http://code.google.com/p/maven-license-plugin |
10 |
### upstream only provides binaries or source without build scripts |
11 |
# tar creation instructions |
12 |
# svn export http://maven-license-plugin.googlecode.com/svn/tags/maven-license-plugin-1.8.0 maven-license-plugin |
13 |
# tar cfJ maven-license-plugin-1.8.0.tar.xz maven-license-plugin |
14 |
Source0: %{name}-%{version}.tar.xz |
15 |
# remove testng dep (tests are skipped) and maven-license-plugin call |
16 |
Patch0: 001-mavenlicenseplugin-fixbuild.patch |
17 |
BuildArch: noarch |
18 |
|
19 |
BuildRequires: java-devel |
20 |
BuildRequires: jpackage-utils |
21 |
BuildRequires: apache-resource-bundles |
22 |
BuildRequires: maven-local |
23 |
BuildRequires: maven-plugin-plugin |
24 |
BuildRequires: maven-shared |
25 |
BuildRequires: plexus-utils |
26 |
BuildRequires: plexus-classworlds |
27 |
BuildRequires: xml-commons-apis |
28 |
BuildRequires: xmltool |
29 |
BuildRequires: maven-source-plugin |
30 |
|
31 |
Requires: jpackage-utils |
32 |
Requires: java-headless >= 1:1.6.0 |
33 |
Requires: maven |
34 |
Requires: maven-shared |
35 |
Requires: xmltool |
36 |
|
37 |
%description |
38 |
maven-license-plugin is a Maven plugin that help you managing license |
39 |
headers in source files. Basically, when you are developing a project |
40 |
either in open source or in a company, you often need to add at the top |
41 |
of your source files a license to protect your work. |
42 |
This plugin lets you maintain the headers, including checking if the |
43 |
header is present, generating a report and of course having the |
44 |
possibility to update / reformat missing license headers. |
45 |
|
46 |
|
47 |
%package javadoc |
48 |
Summary: Javadocs for %{name} |
49 |
Group: Documentation |
50 |
Requires: jpackage-utils |
51 |
BuildArch: noarch |
52 |
|
53 |
%description javadoc |
54 |
This package contains the API documentation for %{name}. |
55 |
|
56 |
|
57 |
%prep |
58 |
%setup -q -n %{name} |
59 |
%patch0 -p1 |
60 |
# fix EOL |
61 |
sed -i 's/\r//' LICENSE.txt |
62 |
sed -i 's/\r//' NOTICE.txt |
63 |
|
64 |
# Remove wagon-webdav extension which is not available |
65 |
%pom_xpath_remove pom:build/pom:extensions |
66 |
|
67 |
# Set sources/resources encoding |
68 |
%pom_xpath_inject "pom:properties" "<project.build.sourceEncoding>UTF-8</project.build.sourceEncoding>" |
69 |
|
70 |
%build |
71 |
%mvn_build -f |
72 |
|
73 |
%install |
74 |
%mvn_install |
75 |
mkdir -p $RPM_BUILD_ROOT%{_javadir} |
76 |
|
77 |
%files -f .mfiles |
78 |
%dir %{_javadir}/%{name} |
79 |
%license LICENSE.txt |
80 |
%doc NOTICE.txt |
81 |
|
82 |
%files javadoc -f .mfiles-javadoc |
83 |
|
84 |
|