1 |
%global pkg_version 1.0-alpha-2 |
2 |
|
3 |
Name: maven-repository-builder |
4 |
Version: 1.0 |
5 |
# See http://fedoraproject.org/wiki/Packaging:NamingGuidelines#Package_Versioning |
6 |
Release: %mkrel 0.alpha2.4 |
7 |
# Maven-shared defines maven-repository-builder version as 1.0 |
8 |
Epoch: 1 |
9 |
Summary: Maven repository builder |
10 |
License: ASL 2.0 |
11 |
URL: http://maven.apache.org/shared/maven-repository-builder/ |
12 |
Group: Development/Java |
13 |
|
14 |
# svn export http://svn.apache.org/repos/asf/maven/shared/tags/maven-repository-builder-1.0-alpha-2 maven-repository-builder-1.0-alpha-2 |
15 |
# tar caf maven-repository-builder-1.0-alpha-2.tar.xz maven-repository-builder-1.0-alpha-2/ |
16 |
Source0: %{name}-%{pkg_version}.tar.xz |
17 |
# ASL mandates that the licence file be included in redistributed source |
18 |
Source1: http://www.apache.org/licenses/LICENSE-2.0.txt |
19 |
|
20 |
BuildArch: noarch |
21 |
|
22 |
BuildRequires: easymock |
23 |
BuildRequires: java-devel |
24 |
BuildRequires: junit |
25 |
BuildRequires: maven-local |
26 |
BuildRequires: maven-surefire-provider-junit |
27 |
BuildRequires: maven-test-tools |
28 |
BuildRequires: maven-wagon |
29 |
BuildRequires: maven-shared |
30 |
|
31 |
Obsoletes: maven-shared-repository-builder < %{epoch}:%{version}-%{release} |
32 |
Provides: maven-shared-repository-builder = %{epoch}:%{version}-%{release} |
33 |
|
34 |
%description |
35 |
Maven repository builder. |
36 |
|
37 |
This is a replacement package for maven-shared-repository-builder |
38 |
|
39 |
%package javadoc |
40 |
Group: Documentation |
41 |
Summary: Javadoc for %{name} |
42 |
|
43 |
%description javadoc |
44 |
API documentation for %{name}. |
45 |
|
46 |
|
47 |
%prep |
48 |
%setup -q -n %{name}-%{pkg_version} |
49 |
|
50 |
# Replace plexus-maven-plugin with plexus-component-metadata |
51 |
find -name 'pom.xml' -exec sed \ |
52 |
-i 's/<artifactId>plexus-maven-plugin<\/artifactId>/<artifactId>plexus-component-metadata<\/artifactId>/' '{}' ';' |
53 |
find -name 'pom.xml' -exec sed \ |
54 |
-i 's/<goal>descriptor<\/goal>/<goal>generate-metadata<\/goal>/' '{}' ';' |
55 |
|
56 |
# Removing JARs because of binary code contained |
57 |
find -iname '*.jar' -delete |
58 |
|
59 |
cp %{SOURCE1} LICENSE.txt |
60 |
|
61 |
%build |
62 |
# Skipping tests because they don't work without the JARs |
63 |
%mvn_build -f |
64 |
|
65 |
%install |
66 |
%mvn_install |
67 |
|
68 |
%files -f .mfiles |
69 |
%doc LICENSE.txt |
70 |
|
71 |
%files javadoc -f .mfiles-javadoc |
72 |
%doc LICENSE.txt |
73 |
|
74 |
|