/[packages]/cauldron/maxima/current/SPECS/maxima.spec
ViewVC logotype

Annotation of /cauldron/maxima/current/SPECS/maxima.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 85392 - (hide annotations) (download)
Thu Apr 14 19:09:04 2011 UTC (13 years ago) by tv
File size: 5656 byte(s)
new release
1 dmorgan 62078 %define enable_clisp 1
2     %define enable_gcl 1
3     %define enable_sbcl 1
4     %define enable_ecl 1
5     %define defaultlisp clisp
6    
7     %if %enable_clisp
8     %define clisp_flags --enable-clisp
9     %else
10     %define clisp_flags --disable-clisp
11     %endif
12    
13     %if %enable_gcl
14     %define gcl_flags --enable-gcl
15     %else
16     %define gcl_flags --disable-gcl
17     %endif
18    
19     %if %enable_sbcl
20     %define sbcl_flags --enable-sbcl
21     %else
22     %define sbcl_flags --disable-sbcl
23     %endif
24    
25     %if %enable_ecl
26     %define ecl_flags --enable-ecl
27     %else
28     %define ecl_flags --disable-ecl
29     %endif
30    
31     Summary: Maxima Symbolic Computation Program
32     Name: maxima
33 tv 85392 Version: 5.24.0
34 dmorgan 62078 Release: %mkrel 1
35     License: GPLv2
36     Group: Sciences/Mathematics
37     URL: http://maxima.sourceforge.net
38     Source0: http://prdownloads.sourceforge.net/maxima/%{name}-%{version}.tar.gz
39     Source1: icons-%{name}.tar.bz2
40     Patch0: maxima-5.22.0-xdg-utils.patch
41     Patch1: maxima-5.14.0-missed-extract-categories.patch
42     Patch2: maxima-fix-contrib-docs.patch
43     Patch3: maxima-5.23.0-clisp-noreadline.patch
44     Patch4: maxima-5.22.0-ecl-ldflags.patch
45     BuildRequires: texinfo
46     BuildRequires: texlive-latex
47     BuildRequires: texlive-dvips
48     BuildRequires: python
49     Suggests: tk
50     Suggests: tcl
51     Requires: maxima-runtime
52     Requires: gnuplot
53     %if %{enable_clisp}
54     BuildRequires: clisp
55     %endif
56     %if %{enable_gcl}
57     BuildRequires: gcl > 2.5.3
58     %endif
59     %if %{enable_sbcl}
60     BuildRequires: sbcl
61     %endif
62     %if %{enable_ecl}
63     BuildRequires: ecl
64     %endif
65     BuildRoot: %{_tmppath}/%{name}-%{version}
66    
67     %description
68     Maxima is a full symbolic computation program. It is full featured
69     doing symbolic manipulation of polynomials, matrices, rational
70     functions, integration, Todd-coxeter, graphing, bigfloats. It has a
71     symbolic debugger source level debugger for maxima code. Maxima is
72     based on the original Macsyma developed at MIT in the 1970's. It is
73     quite reliable, and has good garbage collection, and no memory leaks.
74     It comes with hundreds of self tests.
75    
76     #--------------------------------------------------------------------
77    
78     %package gui
79     Summary: Tcl/Tk GUI interface to Maxima
80     Group: Sciences/Mathematics
81     Requires: maxima
82     Requires: tk
83     Provides: xmaxima = %{version}-%{release}
84     %description gui
85     Tcl/Tk GUI interface to Maxima.
86    
87     %files gui
88     %defattr(-,root,root)
89     %{_bindir}/xmaxima
90     %{_datadir}/applications/mandriva-%{name}.desktop
91     %{_iconsdir}/hicolor/*/apps/*.png
92    
93     #--------------------------------------------------------------------
94    
95     %if %{enable_clisp}
96     %package runtime-clisp
97     Summary: Maxima compiled with clisp
98     Group: Sciences/Mathematics
99     Requires: clisp
100     Requires: maxima = %{version}-%{release}
101     Provides: maxima-runtime = %{version}-%{release}
102     %description runtime-clisp
103     Maxima compiled with clisp.
104    
105     %files runtime-clisp
106     %defattr(-,root,root)
107     %dir %{_libdir}/maxima/%{version}/binary-clisp
108     %{_libdir}/maxima/%{version}/binary-clisp/*
109     %endif
110    
111     #--------------------------------------------------------------------
112    
113     %if %{enable_gcl}
114     %package runtime-gcl
115     Summary: Maxima compiled with GCL
116     Group: Sciences/Mathematics
117     Requires: maxima = %{version}-%{release}
118     Suggests: rlwrap
119     Provides: maxima-runtime = %{version}-%{release}
120     %description runtime-gcl
121     Maxima compiled with Gnu Common Lisp.
122    
123     %files runtime-gcl
124     %defattr(-,root,root)
125     %{_bindir}/rmaxima
126     %dir %{_libdir}/maxima/%{version}/binary-gcl
127     %{_libdir}/maxima/%{version}/binary-gcl/*
128     %endif
129    
130     #--------------------------------------------------------------------
131     %if %{enable_sbcl}
132     %package runtime-sbcl
133     Summary: Maxima compiled with SBCL
134     Group: Sciences/Mathematics
135     Requires: sbcl = 1.0.45
136     Requires: maxima = %{version}-%{release}
137     Provides: maxima-runtime = %{version}-%{release}
138    
139     %description runtime-sbcl
140     Maxima compiled with SBCL.
141    
142     %files runtime-sbcl
143     %defattr(-,root,root)
144     %dir %{_libdir}/maxima/%{version}/binary-sbcl
145     %{_libdir}/maxima/%{version}/binary-sbcl/*
146     %endif
147    
148     %if %{enable_ecl}
149     %package runtime-ecl
150     Summary: Maxima compiled with ECL
151     Group: Sciences/Mathematics
152     Requires: maxima = %{version}-%{release}
153     Provides: maxima-runtime = %{version}-%{release}
154    
155     %description runtime-ecl
156     Maxima compiled with ECL.
157    
158     %files runtime-ecl
159     %defattr(-,root,root)
160     %dir %{_libdir}/maxima/%{version}/binary-ecl
161     %{_libdir}/maxima/%{version}/binary-ecl/*
162     %endif
163    
164     #--------------------------------------------------------------------
165    
166     %prep
167     %setup -q -n %{name}-%{version}
168     %patch0 -p1
169     %patch1 -p1
170     %patch2 -p1
171     %patch3 -p1
172     %patch4 -p1
173    
174     %build
175     export GCL_ANSI=y
176     %if %{enable_sbcl}
177     export SBCL_HOME=%{_libdir}/sbcl
178     %endif
179     CFLAGS="%optflags -fno-fast-math" \
180     CXXFLAGS="%optflags -fno-fast-math" \
181     %configure2_5x \
182     %{clisp_flags} \
183     %{gcl_flags} \
184     %{sbcl_flags} \
185     %{ecl_flags} \
186     --with-default-lisp=%{defaultlisp}
187    
188     make
189     make check
190    
191     (cd doc/info
192     texi2dvi -p -t @afourpaper -t @finalout maxima.texi
193     )
194    
195     %install
196     rm -rf $RPM_BUILD_ROOT
197     %makeinstall
198     rm -f $RPM_BUILD_ROOT%{_infodir}/dir
199    
200     # menu
201     mkdir -p $RPM_BUILD_ROOT%{_datadir}/applications
202 dmorgan 62081 cat > $RPM_BUILD_ROOT%{_datadir}/applications/%_real_vendor-%{name}.desktop << EOF
203 dmorgan 62078 [Desktop Entry]
204     Name=Maxima
205     Comment=Tcl/Tk interface to Maxima
206     Exec=%{_bindir}/xmaxima
207     Icon=%{name}
208     Terminal=false
209     Type=Application
210     Categories=Science;Math;
211     EOF
212    
213     # icons
214     mkdir -p $RPM_BUILD_ROOT%{_iconsdir}
215     tar xjf %{SOURCE1} -C $RPM_BUILD_ROOT%{_iconsdir}
216    
217     # don't compress info pages
218     export EXCLUDE_FROM_COMPRESS=info
219    
220     %post
221     %_install_info maxima.info
222     %update_icon_cache hicolor
223    
224     %postun
225     %_remove_install_info maxima.info
226     %clean_icon_cache hicolor
227    
228     %clean
229     rm -rf $RPM_BUILD_ROOT
230    
231     %files
232     %defattr(-,root,root)
233     %doc AUTHORS COPYING README README.lisps
234     %doc doc/info/maxima.pdf
235     %{_bindir}/maxima
236     %{_bindir}/rmaxima
237     %{_libdir}/maxima/%{version}/mgnuplot
238     %{_datadir}/maxima/%{version}/*
239     %{_infodir}/*.info*
240     %{_infodir}/maxima-index.lisp*
241     %{_mandir}/man1/maxima.*
242    
243    

  ViewVC Help
Powered by ViewVC 1.1.30