1 |
%define bootstrap 0 |
2 |
%{?_without_bootstrap: %global bootstrap 0} |
3 |
%{?_with_bootstrap: %global bootstrap 1} |
4 |
|
5 |
%if "%distro_section" == "tainted" |
6 |
%global build_plf 1 |
7 |
%else |
8 |
%global build_plf 0 |
9 |
%endif |
10 |
|
11 |
# (cg) Cheater... |
12 |
%define Werror_cflags %nil |
13 |
|
14 |
# (aco) Needed for the dri drivers |
15 |
%define _disable_ld_no_undefined 1 |
16 |
|
17 |
# http://cgit.freedesktop.org/mesa/mesa/commit/?h=9.1&id=38e728498b8ef63bb7dce77c64af11c98ec2efa4 |
18 |
%define git 0 |
19 |
%define git_branch 9.2 |
20 |
%define with_hardware 1 |
21 |
|
22 |
%define opengl_ver 3.0 |
23 |
|
24 |
%define relc 0 |
25 |
%define name mesa |
26 |
%define fversion 10.2.1 |
27 |
%define version 10.2.1 |
28 |
%define rel 3 |
29 |
|
30 |
%define release %mkrel %{rel} |
31 |
%define src_type tar.bz2 |
32 |
#define vsuffix %{expand:} |
33 |
%define vsuffix %nil |
34 |
|
35 |
%if %{relc} |
36 |
%define release %mkrel 0.rc%{relc}.%{rel} |
37 |
%define vsuffix -rc%{relc} |
38 |
%define src_type tar.bz2 |
39 |
%endif |
40 |
|
41 |
%if %{git} |
42 |
%if %{relc} |
43 |
%define release %mkrel 0.rc%{relc}.1.git%{git}.%{rel} |
44 |
%else |
45 |
%define release %mkrel 0.git%{git}.%{rel} |
46 |
%endif |
47 |
%endif |
48 |
|
49 |
%define makedepend %{_bindir}/gccmakedep |
50 |
|
51 |
%define eglname mesaegl |
52 |
%define glname mesagl |
53 |
%define glwname mesaglw |
54 |
%define glesv1name mesaglesv1 |
55 |
%define glesv2name mesaglesv2 |
56 |
%define openvgname mesaopenvg |
57 |
%define glapiname glapi |
58 |
%define gbmname gbm |
59 |
%define waylandeglname wayland-egl |
60 |
%define xaname xatracker |
61 |
|
62 |
%define eglmajor 1 |
63 |
%define glmajor 1 |
64 |
%define glwmajor 1 |
65 |
%define glesv1major 1 |
66 |
%define glesv2major 2 |
67 |
%define openvgmajor 1 |
68 |
%define glapimajor 0 |
69 |
%define gbmmajor 1 |
70 |
%define waylandeglmajor 1 |
71 |
%define osmesamajor 8 |
72 |
%define xamajor 2 |
73 |
|
74 |
%define libeglname %mklibname %{eglname} %{eglmajor} |
75 |
%define libglname %mklibname %{glname} %{glmajor} |
76 |
%define libglwname %mklibname %{glwname} %{glwmajor} |
77 |
%define libglesv1name %mklibname %{glesv1name}_ %{glesv1major} |
78 |
%define libglesv2name %mklibname %{glesv2name}_ %{glesv2major} |
79 |
%define libopenvgname %mklibname %{openvgname} %{openvgmajor} |
80 |
%define libglapiname %mklibname %{glapiname} %{glapimajor} |
81 |
%define libgbmname %mklibname %{gbmname} %{gbmmajor} |
82 |
%define libwaylandeglname %mklibname %{waylandeglname} %{waylandeglmajor} |
83 |
%define libosmesaname %mklibname osmesa %{osmesamajor} |
84 |
%define libxaname %mklibname %{xaname} %{xamajor} |
85 |
|
86 |
%define dridrivers %mklibname dri-drivers |
87 |
|
88 |
%define osmesadevel %mklibname osmesa -d |
89 |
|
90 |
# Architecture-independent Virtual provides: |
91 |
%define libeglname_virt lib%{eglname} |
92 |
%define libglname_virt lib%{glname} |
93 |
%define libglwname_virt lib%{glwname} |
94 |
%define libglesv1name_virt lib%{glesv1name} |
95 |
%define libglesv2name_virt lib%{glesv2name} |
96 |
%define libopenvgname_virt lib%{openvgname} |
97 |
%define libglapiname_virt lib%{glapiname} |
98 |
%define libgbmname_virt lib%{gbmname} |
99 |
%define libwaylandeglname_virt lib%{waylandeglname} |
100 |
%define libxaname_virt lib%{xaname} |
101 |
|
102 |
%define oldlibglname %mklibname MesaGL 1 |
103 |
|
104 |
%define mesasrcdir %{_prefix}/src/Mesa/ |
105 |
%define driver_dir %{_libdir}/dri |
106 |
|
107 |
%define enable_egl 1 |
108 |
%define enable_wayland 1 |
109 |
|
110 |
#FIXME: (for 386/485) unset SSE, MMX and 3dnow flags |
111 |
#FIXME: (for >=i586) disable sse |
112 |
# SSE seems to have problem on some apps (gtulpas) for probing. |
113 |
%define dri_drivers_i386 "i915,i965,nouveau,r200,radeon,swrast" |
114 |
%define dri_drivers_x86_64 %{dri_drivers_i386} |
115 |
%define dri_drivers_ppc "r200,radeon,swrast" |
116 |
%define dri_drivers_ppc64 "" |
117 |
%define dri_drivers_ia64 "i915,i965,mga,r200,radeon,swrast" |
118 |
%define dri_drivers_alpha "r200,radeon,swrast" |
119 |
%define dri_drivers_sparc "ffb,radeon,swrast" |
120 |
%define dri_drivers_mipsel "r200,radeon,swrast" |
121 |
%define dri_drivers_arm "nouveau,r200,radeon,swrast" |
122 |
%define dri_drivers %{expand:%{dri_drivers_%{_arch}}} |
123 |
|
124 |
Name: %{name} |
125 |
Version: %{version} |
126 |
Release: %{release} |
127 |
Summary: OpenGL %{opengl_ver} compatible 3D graphics library |
128 |
Group: System/Libraries |
129 |
|
130 |
BuildRequires: pkgconfig(xfixes) >= 4.0.3 |
131 |
BuildRequires: pkgconfig(xshmfence) |
132 |
BuildRequires: pkgconfig(xt) >= 1.0.5 |
133 |
BuildRequires: pkgconfig(xmu) >= 1.0.3 |
134 |
BuildRequires: pkgconfig(x11) >= 1.3.3 |
135 |
BuildRequires: pkgconfig(xdamage) >= 1.1.1 |
136 |
BuildRequires: libexpat-devel >= 2.0.1 |
137 |
BuildRequires: gccmakedep |
138 |
BuildRequires: x11-proto-devel >= 7.3 |
139 |
BuildRequires: pkgconfig(libdrm) >= 2.4.52 |
140 |
|
141 |
BuildRequires: pkgconfig(xcb-dri3) |
142 |
BuildRequires: pkgconfig(xcb-present) |
143 |
BuildRequires: pkgconfig(xext) >= 1.1.1 |
144 |
BuildRequires: pkgconfig(xxf86vm) >= 1.1.0 |
145 |
BuildRequires: pkgconfig(xi) >= 1.3 |
146 |
BuildRequires: pkgconfig(talloc) |
147 |
BuildRequires: libxml2-python |
148 |
BuildRequires: makedepend |
149 |
BuildRequires: bison flex |
150 |
BuildRequires: libelf-devel |
151 |
BuildRequires: llvm-devel >= 3.4.2-1 |
152 |
BuildRequires: pkgconfig(libudev) |
153 |
BuildRequires: pkgconfig(vdpau) |
154 |
%if %{enable_wayland} |
155 |
BuildRequires: wayland-devel |
156 |
%endif |
157 |
|
158 |
URL: http://www.mesa3d.org |
159 |
%if %{git} |
160 |
Source0: %{name}-%{git}.tar.bz2 |
161 |
# (blino) snapshot of 9.0 branch |
162 |
#Source0: %{name}-%{git_branch}-%{git}.tar.bz2 |
163 |
%else |
164 |
Source0: ftp://ftp.freedesktop.org/pub/mesa/%version/MesaLib-%{fversion}%{vsuffix}.%{src_type} |
165 |
%endif |
166 |
Source3: make-git-snapshot.sh |
167 |
# (tmb) disable as it breaks the build |
168 |
#Patch0: MesaLib-9.2.0-rc1-automake-1.14.patch |
169 |
|
170 |
# Instructions to setup your repository clone |
171 |
# git://git.freedesktop.org/git/mesa/mesa |
172 |
# git checkout mesa_7_5_branch |
173 |
# git branch mdv-cherry-picks |
174 |
# git am ../02??-*.patch |
175 |
# git branch mdv-redhat |
176 |
# git am ../03??-*.patch |
177 |
# git branch mdv-patches |
178 |
# git am ../09??-*.patch |
179 |
# In order to update to the branch via patches, issue this command: |
180 |
# git format-patch --start-number 100 mesa_7_5_1..mesa_7_5_branch | sed 's/^0\([0-9]\+\)-/Patch\1: 0\1-/' |
181 |
|
182 |
# Upstream git |
183 |
|
184 |
# Cherry picks |
185 |
# git format-patch --start-number 200 mesa_7_5_branch..mdv-cherry-picks |
186 |
Patch201: 0201-revert-fix-glxinitializevisualconfigfromtags-handling.patch |
187 |
|
188 |
# (blino) should be pushed to 9.0 branch upstream |
189 |
#Patch202: 0202-radeon-llvm-Cleanup-makefile.patch |
190 |
#Patch203: 0203-radeon-llvm-Remove-R600InstrInfo.td-from-TD_FILES.patch |
191 |
|
192 |
# Patches "liberated" from Fedora: |
193 |
# http://cvs.fedoraproject.org/viewvc/rpms/mesa/devel/ |
194 |
# git format-patch --start-number 300 mdv-cherry-picks..mdv-redhat |
195 |
|
196 |
# Patches from ChromiumOS |
197 |
# http://git.chromium.org/gitweb/?p=chromiumos/overlays/chromiumos-overlay.git;a=tree;f=media-libs/mesa/files;hb=HEAD |
198 |
|
199 |
# Mageia/Mandriva patches |
200 |
# git format-patch --start-number 900 mdv-redhat..mdv-patches |
201 |
# (blino) llvmpipe test programs link fails when ld --as-needed option is used, reported as fdo #52167 |
202 |
#Patch901: 0901-gallium-only-link-static-archives-between-ld-start-e.patch |
203 |
|
204 |
#------------------------------------------------------------------------------ |
205 |
|
206 |
# package mesa |
207 |
License: MIT |
208 |
Requires: %{libglname} = %{version}-%{release} |
209 |
Provides: hackMesa = %{version} |
210 |
Obsoletes: hackMesa <= %{version} |
211 |
Provides: Mesa = %{version} |
212 |
Obsoletes: Mesa < %{version} |
213 |
|
214 |
%package -n %{libglname} |
215 |
Summary: Files for Mesa (GL and GLX libs) |
216 |
Group: System/Libraries |
217 |
Obsoletes: %{oldlibglname} < 6.4 |
218 |
Provides: %{oldlibglname} = %{version}-%{release} |
219 |
Provides: %{libglname_virt} = %{version}-%{release} |
220 |
Requires: %{dridrivers} >= %{version}-%{release} |
221 |
%if %{build_plf} |
222 |
Requires: %mklibname txc-dxtn |
223 |
%endif |
224 |
|
225 |
# (anssi) Forces the upgrade of x11-server-common to happen before |
226 |
# alternatives removal, which allows x11-server-common to grab the symlink. |
227 |
Conflicts: x11-server-common < 1.3.0.0-17 |
228 |
|
229 |
%package -n %{dridrivers} |
230 |
Summary: Mesa DRI drivers |
231 |
Group: System/Libraries |
232 |
# do not require exact release to avoid conflicts when having |
233 |
# x86_64 dri drivers from tainted and i586 dri drivers from core |
234 |
Requires: mesa = %{version} |
235 |
Conflicts: %{_lib}MesaGL1 < 7.7-5 |
236 |
Obsoletes: %{_lib}dri-drivers-experimental < 7.11.2-4 |
237 |
Provides: %{_lib}dri-drivers-experimental = %{version}-%{release} |
238 |
|
239 |
%package -n %{libglname}-devel |
240 |
Summary: Development files for Mesa (OpenGL compatible 3D lib) |
241 |
Group: Development/C |
242 |
Requires: %{libglname} = %{version}-%{release} |
243 |
Provides: lib%{glname}-devel = %{version}-%{release} |
244 |
Provides: %{glname}-devel = %{version}-%{release} |
245 |
Provides: GL-devel |
246 |
Obsoletes: %{oldlibglname}-devel < 6.4 |
247 |
Provides: %{oldlibglname}-devel = %{version}-%{release} |
248 |
Provides: libMesaGL-devel = %{version}-%{release} |
249 |
Provides: MesaGL-devel = %{version}-%{release} |
250 |
Provides: libgl-devel |
251 |
|
252 |
%if %{enable_egl} |
253 |
%package -n %{libeglname} |
254 |
Summary: Files for Mesa (EGL libs) |
255 |
Group: System/Libraries |
256 |
Provides: %{libeglname_virt} = %{version}-%{release} |
257 |
|
258 |
%package -n %{libeglname}-devel |
259 |
Summary: Development files for Mesa (EGL libs) |
260 |
Group: Development/C |
261 |
Requires: %{libeglname} = %{version}-%{release} |
262 |
Provides: EGL-devel |
263 |
Provides: lib%{eglname}-devel |
264 |
Provides: %{eglname}-devel |
265 |
Provides: libegl-devel |
266 |
%endif |
267 |
|
268 |
%package -n %{libosmesaname} |
269 |
Summary: Mesa offscreen rendering library |
270 |
Group: System/Libraries |
271 |
|
272 |
%package -n %{osmesadevel} |
273 |
Summary: Development files for libosmesa |
274 |
Group: Development/C |
275 |
Requires: %{libosmesaname} = %{version}-%{release} |
276 |
Provides: osmesa-devel = %{version}-%{release} |
277 |
Conflicts: MesaGL-devel < 8.1.0-0.git20120727.3 |
278 |
|
279 |
%package -n %{libglapiname} |
280 |
Summary: Files for mesa (glapi libs) |
281 |
Group: System/Libraries |
282 |
Provides: %{libglapiname_virt} = %{version}-%{release} |
283 |
|
284 |
%package -n %{libglapiname}-devel |
285 |
Summary: Development files for glapi libs |
286 |
Group: Development/C |
287 |
Requires: %{libglapiname_virt} = %{version}-%{release} |
288 |
Provides: lib%{glapiname}-devel |
289 |
Provides: %{libglapiname}-devel |
290 |
|
291 |
%package -n %{libglesv1name} |
292 |
Summary: Files for Mesa (glesv1 libs) |
293 |
Group: System/Libraries |
294 |
Provides: %{libglesv1name_virt} = %{version}-%{release} |
295 |
|
296 |
%package -n %{libglesv1name}-devel |
297 |
Summary: Development files for glesv1 libs |
298 |
Group: Development/C |
299 |
Requires: %{libglesv1name} = %{version}-%{release} |
300 |
Provides: lib%{glesv1name}-devel |
301 |
Provides: %{glesv1name}-devel |
302 |
Provides: libglesv1-devel |
303 |
|
304 |
%package -n %{libglesv2name} |
305 |
Summary: Files for Mesa (glesv2 libs) |
306 |
Group: System/Libraries |
307 |
Provides: %{libglesv2name_virt} = %{version}-%{release} |
308 |
|
309 |
%package -n %{libglesv2name}-devel |
310 |
Summary: Development files for glesv2 libs |
311 |
Group: Development/C |
312 |
Requires: %{libglesv2name} = %{version}-%{release} |
313 |
Requires: %{libeglname}-devel = %{version}-%{release} |
314 |
Provides: lib%{glesv2name}-devel |
315 |
Provides: %{glesv2name}-devel |
316 |
Provides: libglesv2-devel |
317 |
|
318 |
%package -n %{libopenvgname} |
319 |
Summary: Files for MESA (OpenVG libs) |
320 |
Group: System/Libraries |
321 |
Provides: %{libopenvgname_virt} = %{version}-%{release} |
322 |
|
323 |
%package -n %{libopenvgname}-devel |
324 |
Summary: Development files vor OpenVG libs |
325 |
Group: Development/C |
326 |
Requires: %{libopenvgname} = %{version}-%{release} |
327 |
Provides: lib%{openvgname}-devel |
328 |
Provides: %{openvgname}-devel |
329 |
Provides: libopenvg-devel |
330 |
|
331 |
%if %{enable_wayland} |
332 |
%package -n %{libgbmname} |
333 |
Summary: Files for Mesa (gbm libs) |
334 |
Group: System/Libraries |
335 |
Provides: %{libgbmname_virt} = %{version}-%{release} |
336 |
|
337 |
%package -n %{libgbmname}-devel |
338 |
Summary: Development files for Mesa (gbm libs) |
339 |
Group: Development/C |
340 |
Requires: %{libgbmname} = %{version}-%{release} |
341 |
Provides: lib%{gbmname}-devel |
342 |
Provides: %{gbmname}-devel |
343 |
|
344 |
%package -n %{libwaylandeglname} |
345 |
Summary: Files for Mesa (Wayland EGL libs) |
346 |
Group: System/Libraries |
347 |
Provides: %{libwaylandeglname_virt} = %{version}-%{release} |
348 |
|
349 |
%package -n %{libwaylandeglname}-devel |
350 |
Summary: Development files for Mesa (Wayland EGL libs) |
351 |
Group: Development/C |
352 |
Requires: %{libwaylandeglname} = %{version}-%{release} |
353 |
Provides: lib%{waylandeglname}-devel |
354 |
Provides: %{waylandeglname}-devel |
355 |
%endif |
356 |
|
357 |
%package -n %{_lib}vdpau-driver-nouveau |
358 |
Summary: VDPAU plugin for nouveau driver |
359 |
Group: System/Libraries |
360 |
# temporary: |
361 |
%rename vdpau-driver-nouveau |
362 |
|
363 |
%package -n %{_lib}vdpau-driver-r600 |
364 |
Summary: VDPAU plugin for r600 driver |
365 |
Group: System/Libraries |
366 |
# temporary: |
367 |
%rename vdpau-driver-r600 |
368 |
|
369 |
%package -n %{_lib}vdpau-driver-radeonsi |
370 |
Summary: VDPAU plugin for radeonsi driver |
371 |
Group: System/Libraries |
372 |
# temporary: |
373 |
%rename vdpau-driver-radeonsi |
374 |
|
375 |
%package -n %{libxaname} |
376 |
Summary: Files for Mesa XA state tracker |
377 |
Group: System/Libraries |
378 |
Provides: %{libxaname_virt} = %{version}-%{release} |
379 |
|
380 |
%package -n %{libxaname}-devel |
381 |
Summary: Development files for XA libs |
382 |
Group: Development/C |
383 |
Requires: %{libxaname_virt} = %{version}-%{release} |
384 |
Provides: lib%{xaname}-devel |
385 |
Provides: %{libxaname}-devel |
386 |
|
387 |
%package common-devel |
388 |
Summary: Meta package for mesa devel |
389 |
Group: Development/C |
390 |
Provides: Mesa-common-devel = %{version}-%{release} |
391 |
Provides: hackMesa-common-devel = %{version} |
392 |
Obsoletes: Mesa-common-devel < %{version} |
393 |
Obsoletes: hackMesa-common-devel < %{version} |
394 |
Requires: %{libglname}-devel = %{version} |
395 |
Requires: mesaglu-devel |
396 |
Requires: freeglut-devel |
397 |
Requires: %{libeglname}-devel = %{version} |
398 |
Requires: %{libglesv1name}-devel = %{version} |
399 |
Requires: %{libglesv2name}-devel = %{version} |
400 |
|
401 |
#------------------------------------------------------------------------------ |
402 |
|
403 |
%description |
404 |
Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library. |
405 |
%if %{build_plf} |
406 |
|
407 |
This package is in the "tainted" section because it enables some |
408 |
OpenGL extentions that are covered by software patents. |
409 |
%endif |
410 |
|
411 |
%description common-devel |
412 |
Mesa common metapackage devel |
413 |
|
414 |
%if %{enable_egl} |
415 |
%description -n %{libeglname} |
416 |
Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library. |
417 |
EGL parts. |
418 |
|
419 |
%description -n %{libeglname}-devel |
420 |
Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library. |
421 |
EGL development parts. |
422 |
%endif |
423 |
|
424 |
%description -n %{libglname} |
425 |
Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library. |
426 |
GL and GLX parts. |
427 |
|
428 |
%if %{build_plf} |
429 |
This package is in the "tainted" section because it enables some |
430 |
OpenGL extentions that are covered by software patents. |
431 |
%endif |
432 |
|
433 |
%description -n %{dridrivers} |
434 |
Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library. |
435 |
DRI drivers. |
436 |
|
437 |
%description -n %{libglname}-devel |
438 |
Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library. |
439 |
|
440 |
This package contains the headers needed to compile Mesa programs. |
441 |
|
442 |
%description -n %{libglesv1name} |
443 |
OpenGL ES is a low-level, lightweight API for advanced embedded graphics using |
444 |
well-defined subset profiles of OpenGL. |
445 |
|
446 |
This package provides the OpenGL ES library version 1. |
447 |
|
448 |
%description -n %{libosmesaname} |
449 |
Mesa offscreen rendering libraries for rendering OpenGL into |
450 |
application-allocated blocks of memory. |
451 |
|
452 |
%description -n %{osmesadevel} |
453 |
This package contains the headers needed to compile programs against |
454 |
the Mesa offscreen rendering library. |
455 |
|
456 |
%description -n %{libglapiname} |
457 |
This packages provides the glapi shared library used by gallium. |
458 |
|
459 |
%description -n %{libglapiname}-devel |
460 |
This package contains the headers needed to compile programes against glapi shared library. |
461 |
|
462 |
%description -n %{libglesv1name}-devel |
463 |
This package contains the headers needed to compile OpenGL ES 1 programs. |
464 |
|
465 |
%description -n %{libglesv2name} |
466 |
OpenGL ES is a low-level, lightweight API for advanced embedded graphics using |
467 |
well-defined subset profiles of OpenGL. |
468 |
|
469 |
This package provides the OpenGL ES library version 2. |
470 |
|
471 |
%description -n %{libglesv2name}-devel |
472 |
This package contains the headers needed to compile OpenGL ES 2 programs. |
473 |
|
474 |
%description -n %{libopenvgname} |
475 |
OpenVG is a royalty-free, cross-platform API that provides a low-level hardware |
476 |
acceleration interface for vector graphics libraries such as Flash and SVG. |
477 |
|
478 |
%description -n %{libopenvgname}-devel |
479 |
Development files for OpenVG library. |
480 |
|
481 |
%if %{enable_wayland} |
482 |
%description -n %{libgbmname} |
483 |
Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library. |
484 |
GBM (Graphics Buffer Manager) parts. |
485 |
|
486 |
%description -n %{libgbmname}-devel |
487 |
Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library. |
488 |
GBM (Graphics Buffer Manager) development parts. |
489 |
|
490 |
%description -n %{libwaylandeglname} |
491 |
Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library. |
492 |
Wayland EGL platform parts. |
493 |
|
494 |
%description -n %{libwaylandeglname}-devel |
495 |
Mesa is an OpenGL %{opengl_ver} compatible 3D graphics library. |
496 |
Wayland EGL platform development parts. |
497 |
%endif |
498 |
|
499 |
%description -n %{libxaname} |
500 |
This packages provides the xa shared library used by gallium. |
501 |
|
502 |
%description -n %{libxaname}-devel |
503 |
This package contains the headers needed to compile programes against xa shared library. |
504 |
|
505 |
%description -n %{_lib}vdpau-driver-nouveau |
506 |
This packages provides a VPDAU plugin to enable video acceleration |
507 |
with the nouveau driver. |
508 |
|
509 |
%description -n %{_lib}vdpau-driver-r600 |
510 |
This packages provides a VPDAU plugin to enable video acceleration |
511 |
with the r600 driver. |
512 |
|
513 |
%description -n %{_lib}vdpau-driver-radeonsi |
514 |
This packages provides a VPDAU plugin to enable video acceleration |
515 |
with the radeonsi driver. |
516 |
|
517 |
#------------------------------------------------------------------------------ |
518 |
|
519 |
%prep |
520 |
%if %{git} |
521 |
%setup -q -n mesa-%{git} |
522 |
#setup -q -n mesa-%{git_branch}-%{git} |
523 |
%else |
524 |
%setup -q -n Mesa-%{fversion}%{vsuffix} |
525 |
%endif |
526 |
|
527 |
%apply_patches |
528 |
|
529 |
# Duplicate source tree for OSMesa, since building both versions out-of-tree |
530 |
# would break build. - Anssi 12/2012 |
531 |
all=$(ls) |
532 |
mkdir -p build-osmesa |
533 |
cp -al $all build-osmesa |
534 |
|
535 |
%build |
536 |
# (re)generate auto* generated files using our autotools and libtoolize |
537 |
autoreconf -vfi |
538 |
|
539 |
# for bin/test-driver: |
540 |
automake --add-missing |
541 |
|
542 |
# fix build - TODO: should this be fixed in llvm somehow, or maybe the library |
543 |
# symlinks should be moved to %{_libdir}? -Anssi 08/2012 |
544 |
export LDFLAGS="-L%{_libdir}/llvm" |
545 |
|
546 |
%configure2_5x --enable-dri \ |
547 |
--enable-glx \ |
548 |
--with-dri-driverdir=%{driver_dir} \ |
549 |
--with-dri-drivers="%{dri_drivers}" \ |
550 |
%if %{enable_egl} |
551 |
--enable-egl \ |
552 |
%else |
553 |
--disable-egl \ |
554 |
%endif |
555 |
%if %{enable_wayland} |
556 |
--with-egl-platforms=x11,wayland,drm \ |
557 |
--enable-gbm \ |
558 |
--enable-shared-glapi \ |
559 |
%endif |
560 |
--enable-gles1 \ |
561 |
--enable-gles2 \ |
562 |
--enable-openvg \ |
563 |
--enable-gallium-egl \ |
564 |
--disable-xvmc \ |
565 |
--enable-vdpau \ |
566 |
%if %{with_hardware} |
567 |
--with-gallium-drivers=r300,r600,radeonsi,nouveau,svga,swrast \ |
568 |
--enable-gallium-llvm \ |
569 |
--enable-xa \ |
570 |
%else |
571 |
--disable-gallium-llvm \ |
572 |
--with-gallium-drivers=swrast \ |
573 |
%endif |
574 |
%if %{build_plf} |
575 |
--enable-texture-float \ |
576 |
%endif |
577 |
# end of configure options |
578 |
|
579 |
|
580 |
# Build OSMesa separately, since we want to build OSMesa without shared-glapi, |
581 |
# since doing that causes OSMesa to miss the OpenGL symbols. |
582 |
# See e.g. https://bugs.launchpad.net/ubuntu/+source/mesa/+bug/1066599 |
583 |
# -Anssi 12/2012 |
584 |
|
585 |
pushd build-osmesa |
586 |
autoreconf -vfi |
587 |
%configure2_5x \ |
588 |
--enable-osmesa \ |
589 |
--disable-dri \ |
590 |
--disable-glx \ |
591 |
--disable-egl \ |
592 |
--disable-shared-glapi \ |
593 |
--without-gallium-drivers |
594 |
popd |
595 |
|
596 |
%make |
597 |
%make -C build-osmesa || ( %make -C build-osmesa/src/mesa/program libprogram.la && %make -C build-osmesa ) |
598 |
|
599 |
%install |
600 |
%makeinstall_std -C build-osmesa |
601 |
%makeinstall_std |
602 |
|
603 |
# FIXME: strip will likely break the hardlink |
604 |
# (blino) hardlink libGL files in %{_libdir}/mesa |
605 |
# to prevent proprietary driver installers from removing them |
606 |
mkdir -p $RPM_BUILD_ROOT%{_libdir}/mesa |
607 |
pushd $RPM_BUILD_ROOT%{_libdir}/mesa |
608 |
for l in ../libGL.so.*; do cp -a $l .; done |
609 |
popd |
610 |
|
611 |
%ifarch %{x86_64} |
612 |
mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/dri |
613 |
%endif |
614 |
|
615 |
# .so files are not needed by vdpau |
616 |
rm -f %{buildroot}%{_libdir}/vdpau/libvdpau_*.so |
617 |
|
618 |
# .la files are not needed by mesa |
619 |
find %{buildroot} -name '*.la' -exec rm {} \; |
620 |
|
621 |
# use swrastg if built (Anssi 12/2011) |
622 |
[ -e %{buildroot}%{_libdir}/dri/swrastg_dri.so ] && mv %{buildroot}%{_libdir}/dri/swrast{g,}_dri.so |
623 |
|
624 |
#------------------------------------------------------------------------------ |
625 |
|
626 |
%files |
627 |
%defattr(-,root,root) |
628 |
%doc docs/COPYING |
629 |
%config(noreplace) %{_sysconfdir}/drirc |
630 |
|
631 |
%files -n %{dridrivers} |
632 |
%defattr(-,root,root) |
633 |
%doc docs/COPYING |
634 |
%ifnarch ppc64 |
635 |
%dir %{_libdir}/dri |
636 |
# (blino) new mesa 8.1 build system seems to use a static libglsl |
637 |
#%{_libdir}/dri/libglsl.so |
638 |
%{_libdir}/dri/*_dri.so |
639 |
%endif |
640 |
|
641 |
%files -n %{libglname} |
642 |
%defattr(-,root,root) |
643 |
%doc docs/COPYING |
644 |
%{_libdir}/libGL.so.* |
645 |
%dir %{_libdir}/mesa |
646 |
%{_libdir}/mesa/libGL.so.%{glmajor}* |
647 |
|
648 |
%if %{enable_egl} |
649 |
%files -n %{libeglname} |
650 |
%defattr(-,root,root) |
651 |
%doc docs/COPYING |
652 |
%{_libdir}/libEGL.so.%{eglmajor}* |
653 |
%dir %{_libdir}/egl |
654 |
%if !%{enable_wayland} |
655 |
# st_GL, built only when shared glapi is not enabled |
656 |
%{_libdir}/egl/st_GL.so |
657 |
%endif |
658 |
%{_libdir}/egl/egl_gallium.so |
659 |
%endif |
660 |
|
661 |
%files -n %{libosmesaname} |
662 |
%defattr(-,root,root) |
663 |
%{_libdir}/libOSMesa.so.%{osmesamajor}* |
664 |
|
665 |
%files -n %{libglapiname} |
666 |
%defattr(-,root,root) |
667 |
%{_libdir}/libglapi.so.%{glapimajor}* |
668 |
|
669 |
%files -n %{libglesv1name} |
670 |
%defattr(-,root,root) |
671 |
%doc docs/COPYING |
672 |
%{_libdir}/libGLESv1_CM.so.%{glesv1major}* |
673 |
|
674 |
%files -n %{libglesv2name} |
675 |
%defattr(-,root,root) |
676 |
%doc docs/COPYING |
677 |
%{_libdir}/libGLESv2.so.%{glesv2major}* |
678 |
|
679 |
%files -n %{libopenvgname} |
680 |
%defattr(-,root,root) |
681 |
%doc docs/COPYING |
682 |
%{_libdir}/libOpenVG.so.%{openvgmajor}* |
683 |
|
684 |
%if %{enable_wayland} |
685 |
%files -n %{libgbmname} |
686 |
%{_libdir}/libgbm.so.%{gbmmajor} |
687 |
%{_libdir}/libgbm.so.%{gbmmajor}.* |
688 |
%{_libdir}/gbm/gbm_*.so |
689 |
%{_libdir}/gallium-pipe/pipe_*.so |
690 |
|
691 |
%files -n %{libwaylandeglname} |
692 |
%{_libdir}/libwayland-egl.so.%{waylandeglmajor} |
693 |
%{_libdir}/libwayland-egl.so.%{waylandeglmajor}.* |
694 |
%endif |
695 |
|
696 |
%files -n %{libxaname} |
697 |
%defattr(-,root,root) |
698 |
%{_libdir}/libxatracker.so.%{xamajor}* |
699 |
|
700 |
%files -n %{libglname}-devel |
701 |
%defattr(-,root,root) |
702 |
%doc docs/COPYING |
703 |
%dir %{_includedir}/GL |
704 |
%{_includedir}/GL/gl.h |
705 |
%{_includedir}/GL/glext.h |
706 |
%{_includedir}/GL/gl_mangle.h |
707 |
%{_includedir}/GL/wglext.h |
708 |
%{_includedir}/GL/glx.h |
709 |
%{_includedir}/GL/glxext.h |
710 |
%{_includedir}/GL/glx_mangle.h |
711 |
%{_libdir}/libGL.so |
712 |
%{_libdir}/pkgconfig/gl.pc |
713 |
%{_libdir}/pkgconfig/dri.pc |
714 |
|
715 |
#FIXME: check those headers |
716 |
#{_includedir}/GL/vms_x_fix.h |
717 |
%{_includedir}/GL/wmesa.h |
718 |
%dir %{_includedir}/GL/internal |
719 |
%{_includedir}/GL/internal/dri_interface.h |
720 |
|
721 |
%files common-devel |
722 |
%defattr(-,root,root) |
723 |
|
724 |
%if %{enable_egl} |
725 |
%files -n %{libeglname}-devel |
726 |
%defattr(-,root,root) |
727 |
%doc docs/COPYING |
728 |
%{_includedir}/EGL |
729 |
%{_includedir}/KHR |
730 |
%{_libdir}/libEGL.so |
731 |
%{_libdir}/pkgconfig/egl.pc |
732 |
%endif |
733 |
|
734 |
%files -n %{osmesadevel} |
735 |
%defattr(-,root,root) |
736 |
%dir %{_includedir}/GL |
737 |
%{_includedir}/GL/osmesa.h |
738 |
%{_libdir}/libOSMesa.so |
739 |
%{_libdir}/pkgconfig/osmesa.pc |
740 |
|
741 |
%files -n %{libglapiname}-devel |
742 |
%defattr(-,root,root) |
743 |
%{_libdir}/libglapi.so |
744 |
|
745 |
%files -n %{libglesv1name}-devel |
746 |
%defattr(-,root,root) |
747 |
%{_includedir}/GLES |
748 |
%{_libdir}/libGLESv1_CM.so |
749 |
%{_libdir}/pkgconfig/glesv1_cm.pc |
750 |
|
751 |
%files -n %{libglesv2name}-devel |
752 |
%defattr(-,root,root) |
753 |
%{_includedir}/GLES2 |
754 |
%{_includedir}/GLES3 |
755 |
%{_libdir}/libGLESv2.so |
756 |
%{_libdir}/pkgconfig/glesv2.pc |
757 |
|
758 |
%files -n %{libopenvgname}-devel |
759 |
%defattr(-,root,root) |
760 |
%{_includedir}/VG |
761 |
%{_libdir}/libOpenVG.so |
762 |
%{_libdir}/pkgconfig/vg.pc |
763 |
|
764 |
%if %{enable_wayland} |
765 |
%files -n %{libgbmname}-devel |
766 |
%{_includedir}/gbm.h |
767 |
%{_libdir}/libgbm.so |
768 |
%{_libdir}/pkgconfig/gbm.pc |
769 |
|
770 |
%files -n %{libwaylandeglname}-devel |
771 |
%{_libdir}/libwayland-egl.so |
772 |
%{_libdir}/pkgconfig/wayland-egl.pc |
773 |
%endif |
774 |
|
775 |
%files -n %{libxaname}-devel |
776 |
%defattr(-,root,root) |
777 |
%{_libdir}/libxatracker.so |
778 |
%{_includedir}/xa_tracker.h |
779 |
%{_includedir}/xa_composite.h |
780 |
%{_includedir}/xa_context.h |
781 |
%{_libdir}/pkgconfig/xatracker.pc |
782 |
|
783 |
%files -n %{_lib}vdpau-driver-nouveau |
784 |
%{_libdir}/vdpau/libvdpau_nouveau.so.* |
785 |
|
786 |
%files -n %{_lib}vdpau-driver-r600 |
787 |
%{_libdir}/vdpau/libvdpau_r600.so.* |
788 |
|
789 |
%files -n %{_lib}vdpau-driver-radeonsi |
790 |
%{_libdir}/vdpau/libvdpau_radeonsi.so.* |
791 |
|