1 |
%define bootstrap 0 |
2 |
%{?_without_bootstrap: %global bootstrap 0} |
3 |
%{?_with_bootstrap: %global bootstrap 1} |
4 |
|
5 |
%if "%distro_section" == "tainted" |
6 |
%global build_plf 1 |
7 |
%else |
8 |
%global build_plf 0 |
9 |
%endif |
10 |
|
11 |
# (cg) Cheater... |
12 |
%define Werror_cflags %nil |
13 |
|
14 |
# (aco) Needed for the dri drivers |
15 |
%define _disable_ld_no_undefined 1 |
16 |
|
17 |
# freeglut has replaced mesaglut |
18 |
%define with_mesaglut 0 |
19 |
|
20 |
%define git 0 |
21 |
%define with_hardware 1 |
22 |
|
23 |
%define relc 0 |
24 |
%define name mesa |
25 |
%define version 7.11.1 |
26 |
%define rel 1 |
27 |
|
28 |
%define release %mkrel %{rel} |
29 |
%define src_type tar.bz2 |
30 |
%define vsuffix %{expand:} |
31 |
|
32 |
%if %{relc} |
33 |
%define release %mkrel 0.rc%{relc}.%{rel} |
34 |
%define vsuffix -rc%{relc} |
35 |
%define src_type tar.bz2 |
36 |
%endif |
37 |
|
38 |
%if %{git} |
39 |
%if %{relc} |
40 |
%define release %mkrel 0.rc%{relc}.1.git%{git}.%{rel} |
41 |
%else |
42 |
%define release %mkrel 0.git%{git}.%{rel} |
43 |
%endif |
44 |
%endif |
45 |
|
46 |
%define makedepend %{_bindir}/gccmakedep |
47 |
|
48 |
%define eglname mesaegl |
49 |
%define glname mesagl |
50 |
%define gluname mesaglu |
51 |
%define glutname mesaglut |
52 |
%define glwname mesaglw |
53 |
%define glesv1name mesaglesv1 |
54 |
%define glesv2name mesaglesv2 |
55 |
%define openvgname mesaopenvg |
56 |
%define glapiname glapi |
57 |
|
58 |
%define eglmajor 1 |
59 |
%define glmajor 1 |
60 |
%define glumajor 1 |
61 |
%define glutmajor 3 |
62 |
%define glwmajor 1 |
63 |
%define glesv1major 1 |
64 |
%define glesv2major 2 |
65 |
%define openvgmajor 1 |
66 |
%define glapimajor 0 |
67 |
|
68 |
%define libeglname %mklibname %{eglname} %{eglmajor} |
69 |
%define libglname %mklibname %{glname} %{glmajor} |
70 |
%define libgluname %mklibname %{gluname} %{glumajor} |
71 |
%define libglutname %mklibname %{glutname} %{glutmajor} |
72 |
%define libglwname %mklibname %{glwname} %{glwmajor} |
73 |
%define libglesv1name %mklibname %{glesv1name}_ %{glesv1major} |
74 |
%define libglesv2name %mklibname %{glesv2name}_ %{glesv2major} |
75 |
%define libopenvgname %mklibname %{openvgname} %{openvgmajor} |
76 |
%define libglapiname %mklibname %{glapiname} %{glapimajor} |
77 |
|
78 |
%define dridrivers %mklibname dri-drivers |
79 |
|
80 |
# Architecture-independent Virtual provides: |
81 |
%define libeglname_virt lib%{eglname} |
82 |
%define libglname_virt lib%{glname} |
83 |
%define libgluname_virt lib%{gluname} |
84 |
%define libglutname_virt lib%{glutname} |
85 |
%define libglwname_virt lib%{glwname} |
86 |
%define libglesv1name_virt lib%{glesv1name} |
87 |
%define libglesv2name_virt lib%{glesv2name} |
88 |
%define libopenvgname_virt lib%{openvgname} |
89 |
%define libglapiname_virt lib%{glapiname} |
90 |
|
91 |
%define oldlibglname %mklibname MesaGL 1 |
92 |
%define oldlibgluname %mklibname MesaGLU 1 |
93 |
%define oldlibglutname %mklibname Mesaglut 3 |
94 |
|
95 |
%define mesasrcdir %{_prefix}/src/Mesa/ |
96 |
%define driver_dir %{_libdir}/dri |
97 |
|
98 |
%define enable_egl 1 |
99 |
|
100 |
#FIXME: (for 386/485) unset SSE, MMX and 3dnow flags |
101 |
#FIXME: (for >=i586) disable sse |
102 |
# SSE seems to have problem on some apps (gtulpas) for probing. |
103 |
%define dri_drivers_i386 "i810,i915,i965,mga,mach64,nouveau,r128,r200,r300,r600,radeon,savage,sis,unichrome,tdfx,swrast" |
104 |
%define dri_drivers_x86_64 %{dri_drivers_i386} |
105 |
%define dri_drivers_ppc "mach64,r128,r200,r300,radeon,tdfx,swrast" |
106 |
%define dri_drivers_ppc64 "" |
107 |
%define dri_drivers_ia64 "i810,i915,i965,mga,r128,r200,radeon,swrast" |
108 |
%define dri_drivers_alpha "mga,r128,r200,radeon,swrast" |
109 |
%define dri_drivers_sparc "ffb,mach64,mga,radeon,savage,swrast" |
110 |
%define dri_drivers_mipsel "mach64,mga,r128,r200,radeon,savage,tdfx,swrast" |
111 |
%define dri_drivers_arm "swrast" |
112 |
%define dri_drivers %{expand:%{dri_drivers_%{_arch}}} |
113 |
|
114 |
Name: %{name} |
115 |
Version: %{version} |
116 |
Release: %{release} |
117 |
Summary: OpenGL 2.1 compatible 3D graphics library |
118 |
Group: System/Libraries |
119 |
|
120 |
BuildRequires: pkgconfig(xfixes) >= 4.0.3 |
121 |
BuildRequires: pkgconfig(xt) >= 1.0.5 |
122 |
BuildRequires: pkgconfig(xmu) >= 1.0.3 |
123 |
BuildRequires: pkgconfig(x11) >= 1.3.3 |
124 |
BuildRequires: pkgconfig(xdamage) >= 1.1.1 |
125 |
BuildRequires: libexpat-devel >= 2.0.1 |
126 |
BuildRequires: gccmakedep |
127 |
BuildRequires: x11-proto-devel >= 7.3 |
128 |
BuildRequires: pkgconfig(libdrm) >= 2.4.21 |
129 |
|
130 |
BuildRequires: pkgconfig(xext) >= 1.1.1 |
131 |
BuildRequires: pkgconfig(xxf86vm) >= 1.1.0 |
132 |
BuildRequires: pkgconfig(xi) >= 1.3 |
133 |
BuildRequires: pkgconfig(talloc) |
134 |
BuildRequires: libxml2-python |
135 |
BuildRequires: makedepend |
136 |
BuildRequires: bison flex |
137 |
BuildRequires: llvm |
138 |
BuildRequires: pkgconfig(libudev) |
139 |
|
140 |
URL: http://www.mesa3d.org |
141 |
%if %{git} |
142 |
# (cg) Current commit ref: origin/mesa_7_5_branch |
143 |
Source0: %{name}-%{git}.tar.bz2 |
144 |
%else |
145 |
Source0: ftp://ftp.freedesktop.org/pub/mesa/%version/MesaLib-%{version}%{vsuffix}.%{src_type} |
146 |
Source2: ftp://ftp.freedesktop.org/pub/mesa/%version/MesaGLUT-%{version}%{vsuffix}.%{src_type} |
147 |
%endif |
148 |
Source3: make-git-snapshot.sh |
149 |
Source5: mesa-driver-install |
150 |
|
151 |
|
152 |
# Instructions to setup your repository clone |
153 |
# git://git.freedesktop.org/git/mesa/mesa |
154 |
# git checkout mesa_7_5_branch |
155 |
# git branch mdv-cherry-picks |
156 |
# git am ../02??-*.patch |
157 |
# git branch mdv-redhat |
158 |
# git am ../03??-*.patch |
159 |
# git branch mdv-patches |
160 |
# git am ../09??-*.patch |
161 |
|
162 |
# In order to update to the branch via patches, issue this command: |
163 |
# git format-patch --start-number 100 mesa_7_5_1..mesa_7_5_branch | sed 's/^0\([0-9]\+\)-/Patch\1: 0\1-/' |
164 |
|
165 |
# Cherry picks |
166 |
# git format-patch --start-number 200 mesa_7_5_branch..mdv-cherry-picks |
167 |
Patch201: 0201-revert-fix-glxinitializevisualconfigfromtags-handling.patch |
168 |
Patch202: 0202-fix-includes-for-latest-libdrm.patch |
169 |
|
170 |
# Patches "liberated" from Fedora: |
171 |
# http://cvs.fedoraproject.org/viewvc/rpms/mesa/devel/ |
172 |
# git format-patch --start-number 300 mdv-cherry-picks..mdv-redhat |
173 |
Patch300: 0300-RH-mesa-7.1-nukeglthread-debug-v1.1.patch |
174 |
|
175 |
# Mandriva patches |
176 |
# git format-patch --start-number 900 mdv-redhat..mdv-patches |
177 |
Patch902: 0902-remove-unfinished-GLX_ARB_render_texture.patch |
178 |
Patch903: 0903-Fix-NULL-pointer-dereference-in-viaXMesaWindowMoved.patch |
179 |
Patch904: Mesa-7.9-salome.patch |
180 |
|
181 |
Patch2004: mesa_652_mips.patch |
182 |
|
183 |
#------------------------------------------------------------------------------ |
184 |
|
185 |
# package mesa |
186 |
License: MIT |
187 |
Requires: %{libglname} = %{version}-%{release} |
188 |
Provides: hackMesa = %{version} |
189 |
Obsoletes: hackMesa <= %{version} |
190 |
Provides: Mesa = %{version} |
191 |
Obsoletes: Mesa < %{version} |
192 |
|
193 |
%package -n %{libglname} |
194 |
Summary: Files for Mesa (GL and GLX libs) |
195 |
Group: System/Libraries |
196 |
Obsoletes: %{oldlibglname} < 6.4 |
197 |
Provides: %{oldlibglname} = %{version}-%{release} |
198 |
Provides: %{libglname_virt} = %{version}-%{release} |
199 |
Requires: %{dridrivers} >= %{version}-%{release} |
200 |
%if %{build_plf} |
201 |
Requires: %mklibname txc-dxtn |
202 |
%endif |
203 |
|
204 |
# (anssi) Forces the upgrade of x11-server-common to happen before |
205 |
# alternatives removal, which allows x11-server-common to grab the symlink. |
206 |
Conflicts: x11-server-common < 1.3.0.0-17 |
207 |
|
208 |
%package -n %{dridrivers} |
209 |
Summary: Mesa DRI drivers |
210 |
Group: System/Libraries |
211 |
Conflicts: %{_lib}MesaGL1 < 7.7-5 |
212 |
|
213 |
%package -n %{dridrivers}-experimental |
214 |
Summary: Mesa DRI - unstable experimental drivers |
215 |
Group: System/Libraries |
216 |
# for dri driver directory |
217 |
Requires: %{dridrivers} |
218 |
|
219 |
%package -n %{libglname}-devel |
220 |
Summary: Development files for Mesa (OpenGL compatible 3D lib) |
221 |
Group: Development/C |
222 |
Requires: %{libglname} = %{version}-%{release} |
223 |
Provides: lib%{glname}-devel = %{version}-%{release} |
224 |
Provides: %{glname}-devel = %{version}-%{release} |
225 |
Provides: GL-devel |
226 |
Obsoletes: %{oldlibglname}-devel < 6.4 |
227 |
Provides: %{oldlibglname}-devel = %{version}-%{release} |
228 |
Provides: libMesaGL-devel = %{version}-%{release} |
229 |
Provides: MesaGL-devel = %{version}-%{release} |
230 |
Provides: libgl-devel |
231 |
|
232 |
%package -n %{libgluname} |
233 |
Summary: Files for Mesa (GLU libs) |
234 |
Group: System/Libraries |
235 |
Obsoletes: %{oldlibgluname} < 6.4 |
236 |
Provides: %{oldlibgluname} = %{version}-%{release} |
237 |
Provides: %{libgluname_virt} = %{version}-%{release} |
238 |
|
239 |
%package -n %{libgluname}-devel |
240 |
Summary: Development files for GLU libs |
241 |
Group: Development/C |
242 |
Requires: %{libgluname} = %{version}-%{release} |
243 |
Provides: lib%{gluname}-devel = %{version}-%{release} |
244 |
Provides: %{gluname}-devel = %{version}-%{release} |
245 |
Obsoletes: %{oldlibgluname}-devel < 6.4 |
246 |
Provides: %{oldlibgluname}-devel = %{version}-%{release} |
247 |
Provides: libMesaGLU-devel = %{version}-%{release} |
248 |
Provides: MesaGLU-devel = %{version}-%{release} |
249 |
Provides: libglu-devel |
250 |
# pkgconfig files moved from libgl-devel: |
251 |
Conflicts: %{libglname}-devel < 7.10.2-4 |
252 |
|
253 |
%if %{with_mesaglut} |
254 |
%package -n %{libglutname} |
255 |
Summary: Files for Mesa (glut libs) |
256 |
Group: System/Libraries |
257 |
Requires: %{libgluname} = %{version}-%{release} |
258 |
Provides: Mesa-common = %{version}-%{release} hackMesa-common = %{version} |
259 |
Obsoletes: Mesa-common <= %{version} hackMesa-common <= %{version} |
260 |
Obsoletes: %{oldlibglutname} < 6.4 |
261 |
Provides: %{oldlibglutname} = %{version}-%{release} |
262 |
Provides: %{libglutname_virt} = %{version}-%{release} |
263 |
|
264 |
%package -n %{libglutname}-devel |
265 |
Summary: Development files for glut libs |
266 |
Group: Development/C |
267 |
Requires: %{libglutname} = %{version}-%{release} %{libgluname}-devel = %{version}-%{release} |
268 |
# (gc) /usr/lib/pkgconfig/glut.pc depends on /usr/lib/pkgconfig/{x11,xmu,xi}.pc (Requires.private) and pkg-config --list-all |
269 |
# goes wild without these deps |
270 |
Requires: libx11-devel libxmu-devel libxi-devel |
271 |
Provides: lib%{glutname}-devel = %{version}-%{release} |
272 |
Provides: %{glutname}-devel = %{version}-%{release} |
273 |
Obsoletes: %{oldlibglutname}-devel < 6.4 |
274 |
Provides: %{oldlibglutname}-devel = %{version}-%{release} |
275 |
Provides: libMesaGLUT-devel = %{version}-%{release} |
276 |
Provides: MesaGLUT-devel = %{version}-%{release} |
277 |
Provides: libglut-devel |
278 |
# pkgconfig files moved from libgl-devel: |
279 |
Conflicts: %{libglname}-devel < 7.10.2-4 |
280 |
%endif |
281 |
|
282 |
%package -n %{libglwname} |
283 |
Summary: Files for Mesa (glw libs) |
284 |
Group: System/Libraries |
285 |
Provides: Mesa-common = %{version}-%{release} hackMesa-common = %{version} |
286 |
Obsoletes: Mesa-common <= %{version} hackMesa-common <= %{version} |
287 |
Provides: %{libglwname_virt} = %{version}-%{release} |
288 |
|
289 |
%package -n %{libglwname}-devel |
290 |
Summary: Development files for glw libs |
291 |
Group: Development/C |
292 |
Requires: %{libglwname} = %{version}-%{release} |
293 |
Provides: lib%{glwname}-devel = %{version}-%{release} |
294 |
Provides: %{glwname}-devel = %{version}-%{release} |
295 |
Provides: libglw-devel |
296 |
# pkgconfig files moved from libgl-devel: |
297 |
Conflicts: %{libglname}-devel < 7.10.2-4 |
298 |
|
299 |
%if %{enable_egl} |
300 |
%package -n %{libeglname} |
301 |
Summary: Files for Mesa (EGL libs) |
302 |
Group: System/Libraries |
303 |
Provides: %{libeglname_virt} = %{version}-%{release} |
304 |
|
305 |
%package -n %{libeglname}-devel |
306 |
Summary: Development files for Mesa (EGL libs) |
307 |
Group: Development/C |
308 |
Requires: %{libeglname} = %{version}-%{release} |
309 |
Provides: EGL-devel |
310 |
Provides: lib%{eglname}-devel |
311 |
Provides: %{eglname}-devel |
312 |
Provides: libegl-devel |
313 |
%endif |
314 |
|
315 |
%package -n %{libglapiname} |
316 |
Summary: Files for mesa (glapi libs) |
317 |
Group: System/Libraries |
318 |
Provides: %{libglapiname_virt} = %{version}-%{release} |
319 |
|
320 |
%package -n %{libglapiname}-devel |
321 |
Summary: Development files for glapi libs |
322 |
Group: Development/C |
323 |
Requires: %{libglapiname_virt} = %{version}-%{release} |
324 |
Provides: lib%{glapiname}-devel |
325 |
Provides: %{libglapiname}-devel |
326 |
|
327 |
%package -n %{libglesv1name} |
328 |
Summary: Files for Mesa (glesv1 libs) |
329 |
Group: System/Libraries |
330 |
Provides: %{libglesv1name_virt} = %{version}-%{release} |
331 |
|
332 |
%package -n %{libglesv1name}-devel |
333 |
Summary: Development files for glesv1 libs |
334 |
Group: Development/C |
335 |
Requires: %{libglesv1name} = %{version}-%{release} |
336 |
Provides: lib%{glesv1name}-devel |
337 |
Provides: %{glesv1name}-devel |
338 |
Provides: libglesv1-devel |
339 |
|
340 |
%package -n %{libglesv2name} |
341 |
Summary: Files for Mesa (glesv2 libs) |
342 |
Group: System/Libraries |
343 |
Provides: %{libglesv2name_virt} = %{version}-%{release} |
344 |
|
345 |
%package -n %{libglesv2name}-devel |
346 |
Summary: Development files for glesv2 libs |
347 |
Group: Development/C |
348 |
Requires: %{libglesv2name} = %{version}-%{release} |
349 |
Provides: lib%{glesv2name}-devel |
350 |
Provides: %{glesv2name}-devel |
351 |
Provides: libglesv2-devel |
352 |
|
353 |
%package -n %{libopenvgname} |
354 |
Summary: Files for MESA (OpenVG libs) |
355 |
Group: System/Libraries |
356 |
Provides: %{libopenvgname_virt} = %{version}-%{release} |
357 |
|
358 |
%package -n %{libopenvgname}-devel |
359 |
Summary: Development files vor OpenVG libs |
360 |
Group: Development/C |
361 |
Requires: %{libopenvgname} = %{version}-%{release} |
362 |
Provides: lib%{openvgname}-devel |
363 |
Provides: %{openvgname}-devel |
364 |
Provides: libopenvg-devel |
365 |
|
366 |
%package common-devel |
367 |
Summary: Meta package for mesa devel |
368 |
Group: Development/C |
369 |
Provides: Mesa-common-devel = %{version}-%{release} |
370 |
Provides: hackMesa-common-devel = %{version} |
371 |
Obsoletes: Mesa-common-devel < %{version} |
372 |
Obsoletes: hackMesa-common-devel < %{version} |
373 |
Requires: %{libglname}-devel = %{version} |
374 |
Requires: %{libglwname}-devel = %{version} |
375 |
Requires: %{libgluname}-devel = %{version} |
376 |
%if %{with_mesaglut} |
377 |
Requires: %{libglutname}-devel = %{version} |
378 |
%else |
379 |
Requires: freeglut-devel |
380 |
%endif |
381 |
Requires: %{libeglname}-devel = %{version} |
382 |
Requires: %{libglesv1name}-devel = %{version} |
383 |
Requires: %{libglesv2name}-devel = %{version} |
384 |
|
385 |
#------------------------------------------------------------------------------ |
386 |
|
387 |
%description |
388 |
Mesa is an OpenGL 2.1 compatible 3D graphics library. |
389 |
%if %{build_plf} |
390 |
|
391 |
This package is in the "tainted" section because it enables some |
392 |
OpenGL extentions that are covered by software patents. |
393 |
%endif |
394 |
|
395 |
%description common-devel |
396 |
Mesa common metapackage devel |
397 |
|
398 |
%if %{enable_egl} |
399 |
%description -n %{libeglname} |
400 |
Mesa is an OpenGL 2.1 compatible 3D graphics library. |
401 |
EGL parts. |
402 |
|
403 |
%description -n %{libeglname}-devel |
404 |
Mesa is an OpenGL 2.1 compatible 3D graphics library. |
405 |
EGL development parts. |
406 |
%endif |
407 |
|
408 |
%description -n %{libglname} |
409 |
Mesa is an OpenGL 2.1 compatible 3D graphics library. |
410 |
GL and GLX parts. |
411 |
|
412 |
%if %{build_plf} |
413 |
This package is in the "tainted" section because it enables some |
414 |
OpenGL extentions that are covered by software patents. |
415 |
%endif |
416 |
|
417 |
%description -n %{dridrivers} |
418 |
Mesa is an OpenGL 2.1 compatible 3D graphics library. |
419 |
DRI drivers. |
420 |
|
421 |
%description -n %{dridrivers}-experimental |
422 |
Mesa is an OpenGL 2.1 compatible 3D graphics library. |
423 |
Experimental unstable DRI drivers. |
424 |
|
425 |
This package contains experimental DRI drivers for NVIDIA cards, for |
426 |
OpenGL acceleration with nouveau driver. These drivers are not stable |
427 |
and may crash your system. Please do not report bugs encountered with |
428 |
these drivers. |
429 |
|
430 |
%description -n %{libglname}-devel |
431 |
Mesa is an OpenGL 2.1 compatible 3D graphics library. |
432 |
|
433 |
This package contains the headers needed to compile Mesa programs. |
434 |
|
435 |
%description -n %{libgluname} |
436 |
GLU is the OpenGL Utility Library. |
437 |
It provides a number of functions upon the base OpenGL library to provide |
438 |
higher-level drawing routines from the more primitive routines provided by |
439 |
OpenGL. |
440 |
|
441 |
%description -n %{libgluname}-devel |
442 |
This package contains the headers needed to compile programs with GLU. |
443 |
|
444 |
%if %{with_mesaglut} |
445 |
%description -n %{libglutname} |
446 |
GLUT (OpenGL Utility Toolkit) is a addon library for OpenGL programs. It |
447 |
provides them utilities to define and control windows, input from the keyboard |
448 |
and the mouse, drawing some geometric primitives (cubes, spheres, ...). |
449 |
GLUT can even create pop-up windows. |
450 |
|
451 |
%description -n %{libglutname}-devel |
452 |
Mesa is an OpenGL 2.1 compatible 3D graphics library. |
453 |
glut parts. |
454 |
|
455 |
This package contains the headers needed to compile Mesa programs. |
456 |
%endif |
457 |
|
458 |
%description -n %{libglwname} |
459 |
GLw adds Motif bindings to the OpenGL "canvas" (Xt/Motif/OpenGL widget code). |
460 |
|
461 |
%description -n %{libglwname}-devel |
462 |
Mesa is an OpenGL 2.1 compatible 3D graphics library. |
463 |
GLw parts. |
464 |
|
465 |
This package contains the headers needed to compile Mesa programs. |
466 |
|
467 |
%description -n %{libglesv1name} |
468 |
OpenGL ES is a low-level, lightweight API for advanced embedded graphics using |
469 |
well-defined subset profiles of OpenGL. |
470 |
|
471 |
This package provides the OpenGL ES library version 1. |
472 |
|
473 |
%description -n %{libglapiname} |
474 |
This packages provides the glapi shared library used by gallium. |
475 |
|
476 |
%description -n %{libglapiname}-devel |
477 |
This package contains the headers needed to compile programes against glapi shared library. |
478 |
|
479 |
%description -n %{libglesv1name}-devel |
480 |
This package contains the headers needed to compile OpenGL ES 1 programs. |
481 |
|
482 |
%description -n %{libglesv2name} |
483 |
OpenGL ES is a low-level, lightweight API for advanced embedded graphics using |
484 |
well-defined subset profiles of OpenGL. |
485 |
|
486 |
This package provides the OpenGL ES library version 2. |
487 |
|
488 |
%description -n %{libglesv2name}-devel |
489 |
This package contains the headers needed to compile OpenGL ES 2 programs. |
490 |
|
491 |
%description -n %{libopenvgname} |
492 |
OpenVG is a royalty-free, cross-platform API that provides a low-level hardware |
493 |
acceleration interface for vector graphics libraries such as Flash and SVG. |
494 |
|
495 |
%description -n %{libopenvgname}-devel |
496 |
Development files for OpenVG library. |
497 |
|
498 |
#------------------------------------------------------------------------------ |
499 |
|
500 |
%prep |
501 |
%if %{git} |
502 |
%setup -q -n mesa-%{git} |
503 |
%else |
504 |
%setup -q -n Mesa-%{version}%{vsuffix} -b2 |
505 |
%endif |
506 |
|
507 |
%patch201 -p1 |
508 |
#%patch202 -p1 |
509 |
|
510 |
#%patch300 -p1 |
511 |
|
512 |
#%patch902 -p1 |
513 |
#%patch903 -p1 |
514 |
#%patch904 -p1 |
515 |
|
516 |
#%patch2004 -p1 |
517 |
|
518 |
chmod +x %{SOURCE5} |
519 |
|
520 |
# for dri-drivers-experimental |
521 |
cat > README.install.urpmi <<EOF |
522 |
This package contains experimental DRI drivers for NVIDIA cards, for |
523 |
OpenGL acceleration with nouveau driver. These drivers are not stable |
524 |
and may crash your system. Please do not report bugs encountered with |
525 |
these drivers. |
526 |
EOF |
527 |
|
528 |
%build |
529 |
%if %{git} |
530 |
./autogen.sh -v |
531 |
%endif |
532 |
|
533 |
# Required by patch200: |
534 |
autoreconf -vfi |
535 |
%configure2_5x --with-driver=dri \ |
536 |
--with-dri-driverdir=%{driver_dir} \ |
537 |
--with-dri-drivers="%{dri_drivers}" \ |
538 |
--with-state-trackers=dri \ |
539 |
--enable-shared-dricore \ |
540 |
--enable-gallium-nouveau \ |
541 |
%if %{enable_egl} |
542 |
--enable-egl \ |
543 |
%else |
544 |
--disable-egl \ |
545 |
%endif |
546 |
--enable-gles1 \ |
547 |
--enable-gles2 \ |
548 |
--enable-openvg \ |
549 |
--enable-gallium-egl \ |
550 |
%if %{with_hardware} |
551 |
--with-gallium-drivers=r300,r600,nouveau,swrast \ |
552 |
--enable-gallium-llvm \ |
553 |
%else |
554 |
--disable-gallium-llvm \ |
555 |
--with-gallium-drivers=swrast \ |
556 |
%endif |
557 |
%if %{build_plf} |
558 |
--enable-texture-float \ |
559 |
%endif |
560 |
%if %{with_mesaglut} |
561 |
--enable-glut |
562 |
%else |
563 |
--disable-glut |
564 |
%endif |
565 |
|
566 |
%make |
567 |
|
568 |
%install |
569 |
rm -rf %{buildroot} |
570 |
%makeinstall_std |
571 |
|
572 |
# (blino) hardlink libGL files in %{_libdir}/mesa |
573 |
# to prevent proprietary driver installers from removing them |
574 |
mkdir -p $RPM_BUILD_ROOT%{_libdir}/mesa |
575 |
pushd $RPM_BUILD_ROOT%{_libdir}/mesa |
576 |
for l in ../libGL.so.*; do cp -a $l .; done |
577 |
popd |
578 |
|
579 |
%ifarch %{x86_64} |
580 |
mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/dri |
581 |
%endif |
582 |
|
583 |
%if !%{with_mesaglut} |
584 |
rm -f %{buildroot}/%{_includedir}/GL/glut.h |
585 |
rm -f %{buildroot}/%{_includedir}/GL/glutf90.h |
586 |
%endif |
587 |
|
588 |
%clean |
589 |
rm -fr $RPM_BUILD_ROOT |
590 |
|
591 |
#------------------------------------------------------------------------------ |
592 |
|
593 |
%files |
594 |
%defattr(-,root,root) |
595 |
%doc docs/COPYING docs/README.* |
596 |
|
597 |
%files -n %{dridrivers} |
598 |
%defattr(-,root,root) |
599 |
%doc docs/COPYING |
600 |
%ifnarch ppc64 |
601 |
%dir %{_libdir}/dri |
602 |
%{_libdir}/dri/libdricore.so |
603 |
%{_libdir}/dri/libglsl.so |
604 |
%{_libdir}/dri/*_dri.so |
605 |
%exclude %{_libdir}/dri/nouveau_dri.so |
606 |
%ifnarch %arm %mips |
607 |
%exclude %{_libdir}/dri/nouveau_vieux_dri.so |
608 |
%endif |
609 |
%endif |
610 |
|
611 |
%files -n %{dridrivers}-experimental |
612 |
%defattr(-,root,root) |
613 |
%doc docs/COPYING |
614 |
%doc README.install.urpmi |
615 |
%{_libdir}/dri/nouveau_dri.so |
616 |
%ifnarch %arm %mips |
617 |
%{_libdir}/dri/nouveau_vieux_dri.so |
618 |
%endif |
619 |
|
620 |
%files -n %{libglname} |
621 |
%defattr(-,root,root) |
622 |
%doc docs/COPYING |
623 |
%{_libdir}/libGL.so.* |
624 |
%dir %{_libdir}/mesa |
625 |
%{_libdir}/mesa/libGL.so.%{glmajor}* |
626 |
|
627 |
%files -n %{libgluname} |
628 |
%defattr(-,root,root) |
629 |
%doc docs/COPYING |
630 |
%{_libdir}/libGLU.so.%{glumajor}* |
631 |
|
632 |
%if %{with_mesaglut} |
633 |
%files -n %{libglutname} |
634 |
%defattr(-,root,root) |
635 |
%doc docs/COPYING |
636 |
%{_libdir}/libglut.so.%{glutmajor}* |
637 |
%endif |
638 |
|
639 |
%files -n %{libglwname} |
640 |
%defattr(-,root,root) |
641 |
%doc docs/COPYING |
642 |
%{_libdir}/libGLw.so.%{glwmajor}* |
643 |
|
644 |
%if %{enable_egl} |
645 |
%files -n %{libeglname} |
646 |
%defattr(-,root,root) |
647 |
%doc docs/COPYING |
648 |
%{_libdir}/libEGL.so.%{eglmajor}* |
649 |
%dir %{_libdir}/egl |
650 |
%{_libdir}/egl/st_GL.so |
651 |
%{_libdir}/egl/egl_gallium.so |
652 |
%endif |
653 |
|
654 |
%files -n %{libglapiname} |
655 |
%defattr(-,root,root) |
656 |
%{_libdir}/libglapi.so.%{glapimajor}* |
657 |
|
658 |
%files -n %{libglesv1name} |
659 |
%defattr(-,root,root) |
660 |
%doc docs/COPYING |
661 |
%{_libdir}/libGLESv1_CM.so.%{glesv1major}* |
662 |
|
663 |
%files -n %{libglesv2name} |
664 |
%defattr(-,root,root) |
665 |
%doc docs/COPYING |
666 |
%{_libdir}/libGLESv2.so.%{glesv2major}* |
667 |
|
668 |
%files -n %{libopenvgname} |
669 |
%defattr(-,root,root) |
670 |
%doc docs/COPYING |
671 |
%{_libdir}/libOpenVG.so.%{openvgmajor}* |
672 |
|
673 |
|
674 |
%files -n %{libglname}-devel |
675 |
%defattr(-,root,root) |
676 |
%doc docs/COPYING |
677 |
%{_includedir}/GL/gl.h |
678 |
%{_includedir}/GL/glext.h |
679 |
%{_includedir}/GL/gl_mangle.h |
680 |
%{_includedir}/GL/osmesa.h |
681 |
%{_includedir}/GL/wglext.h |
682 |
%{_includedir}/GL/glx.h |
683 |
%{_includedir}/GL/glxext.h |
684 |
%{_includedir}/GL/glx_mangle.h |
685 |
%{_libdir}/libGL.so |
686 |
%{_libdir}/pkgconfig/gl.pc |
687 |
%{_libdir}/pkgconfig/dri.pc |
688 |
|
689 |
#FIXME: check those headers |
690 |
%{_includedir}/GL/glfbdev.h |
691 |
%{_includedir}/GL/vms_x_fix.h |
692 |
%{_includedir}/GL/wmesa.h |
693 |
%dir %{_includedir}/GL/internal |
694 |
%{_includedir}/GL/internal/dri_interface.h |
695 |
|
696 |
%files -n %{libgluname}-devel |
697 |
%defattr(-,root,root) |
698 |
%doc docs/COPYING |
699 |
%{_includedir}/GL/glu.h |
700 |
%{_includedir}/GL/glu_mangle.h |
701 |
%{_includedir}/GL/mesa_wgl.h |
702 |
%{_libdir}/libGLU.so |
703 |
%{_libdir}/pkgconfig/glu.pc |
704 |
|
705 |
%if %{with_mesaglut} |
706 |
%files -n %{libglutname}-devel |
707 |
%defattr(-,root,root) |
708 |
%doc docs/COPYING |
709 |
%{_includedir}/GL/glut.h |
710 |
%{_includedir}/GL/glutf90.h |
711 |
%{_libdir}/libglut.so |
712 |
%{_libdir}/pkgconfig/glut.pc |
713 |
%endif |
714 |
|
715 |
%files common-devel |
716 |
%defattr(-,root,root) |
717 |
|
718 |
%files -n %{libglwname}-devel |
719 |
%defattr(-,root,root) |
720 |
%doc docs/COPYING |
721 |
%{_includedir}/GL/GLwDrawA.h |
722 |
%{_includedir}/GL/GLwDrawAP.h |
723 |
%{_includedir}/GL/GLwMDrawA.h |
724 |
%{_includedir}/GL/GLwMDrawAP.h |
725 |
%{_libdir}/libGLw.so |
726 |
%{_libdir}/pkgconfig/glw.pc |
727 |
|
728 |
%if %{enable_egl} |
729 |
%files -n %{libeglname}-devel |
730 |
%defattr(-,root,root) |
731 |
%doc docs/COPYING |
732 |
%{_includedir}/EGL |
733 |
%{_includedir}/KHR |
734 |
%{_libdir}/libEGL.so |
735 |
%{_libdir}/pkgconfig/egl.pc |
736 |
%endif |
737 |
|
738 |
%files -n %{libglapiname}-devel |
739 |
%defattr(-,root,root) |
740 |
%{_libdir}/libglapi.so |
741 |
|
742 |
%files -n %{libglesv1name}-devel |
743 |
%defattr(-,root,root) |
744 |
%{_includedir}/GLES |
745 |
%{_libdir}/libGLESv1_CM.so |
746 |
%{_libdir}/pkgconfig/glesv1_cm.pc |
747 |
|
748 |
%files -n %{libglesv2name}-devel |
749 |
%defattr(-,root,root) |
750 |
%{_includedir}/GLES2 |
751 |
%{_libdir}/libGLESv2.so |
752 |
%{_libdir}/pkgconfig/glesv2.pc |
753 |
|
754 |
%files -n %{libopenvgname}-devel |
755 |
%defattr(-,root,root) |
756 |
%{_includedir}/VG |
757 |
%{_libdir}/libOpenVG.so |
758 |
%{_libdir}/pkgconfig/vg.pc |