1 |
%define bootstrap 0 |
2 |
%{?_without_bootstrap: %global bootstrap 0} |
3 |
%{?_with_bootstrap: %global bootstrap 1} |
4 |
|
5 |
%if "%distro_section" == "tainted" |
6 |
%global build_plf 1 |
7 |
%else |
8 |
%global build_plf 0 |
9 |
%endif |
10 |
|
11 |
# (cg) Cheater... |
12 |
%define Werror_cflags %nil |
13 |
|
14 |
# (aco) Needed for the dri drivers |
15 |
%define _disable_ld_no_undefined 1 |
16 |
|
17 |
|
18 |
%define git 20120802 |
19 |
%define with_hardware 1 |
20 |
|
21 |
%define relc 0 |
22 |
%define name mesa |
23 |
%define version 8.1.0 |
24 |
%define rel 1 |
25 |
|
26 |
%define release %mkrel %{rel} |
27 |
%define src_type tar.bz2 |
28 |
#define vsuffix %{expand:} |
29 |
%define vsuffix %nil |
30 |
|
31 |
%if %{relc} |
32 |
%define release %mkrel 0.rc%{relc}.%{rel} |
33 |
%define vsuffix -rc%{relc} |
34 |
%define src_type tar.bz2 |
35 |
%endif |
36 |
|
37 |
%if %{git} |
38 |
%if %{relc} |
39 |
%define release %mkrel 0.rc%{relc}.1.git%{git}.%{rel} |
40 |
%else |
41 |
%define release %mkrel 0.git%{git}.%{rel} |
42 |
%endif |
43 |
%endif |
44 |
|
45 |
%define makedepend %{_bindir}/gccmakedep |
46 |
|
47 |
%define dricorename dricore |
48 |
%define eglname mesaegl |
49 |
%define glname mesagl |
50 |
%define gluname mesaglu |
51 |
%define glwname mesaglw |
52 |
%define glesv1name mesaglesv1 |
53 |
%define glesv2name mesaglesv2 |
54 |
%define openvgname mesaopenvg |
55 |
%define glapiname glapi |
56 |
%define gbmname gbm |
57 |
%define waylandeglname wayland-egl |
58 |
|
59 |
%define dricoremajor 1 |
60 |
%define eglmajor 1 |
61 |
%define glmajor 1 |
62 |
%define glumajor 1 |
63 |
%define glwmajor 1 |
64 |
%define glesv1major 1 |
65 |
%define glesv2major 2 |
66 |
%define openvgmajor 1 |
67 |
%define glapimajor 0 |
68 |
%define gbmmajor 1 |
69 |
%define waylandeglmajor 1 |
70 |
%define osmesamajor 8 |
71 |
|
72 |
%define libdricorename %mklibname %{dricorename} %{dricoremajor} |
73 |
%define libeglname %mklibname %{eglname} %{eglmajor} |
74 |
%define libglname %mklibname %{glname} %{glmajor} |
75 |
%define libgluname %mklibname %{gluname} %{glumajor} |
76 |
%define libglwname %mklibname %{glwname} %{glwmajor} |
77 |
%define libglesv1name %mklibname %{glesv1name}_ %{glesv1major} |
78 |
%define libglesv2name %mklibname %{glesv2name}_ %{glesv2major} |
79 |
%define libopenvgname %mklibname %{openvgname} %{openvgmajor} |
80 |
%define libglapiname %mklibname %{glapiname} %{glapimajor} |
81 |
%define libgbmname %mklibname %{gbmname} %{gbmmajor} |
82 |
%define libwaylandeglname %mklibname %{waylandeglname} %{waylandeglmajor} |
83 |
%define libosmesaname %mklibname osmesa %{osmesamajor} |
84 |
|
85 |
%define dridrivers %mklibname dri-drivers |
86 |
|
87 |
%define osmesadevel %mklibname osmesa -d |
88 |
|
89 |
# Architecture-independent Virtual provides: |
90 |
%define libdricorename_virt lib%{dricorename} |
91 |
%define libeglname_virt lib%{eglname} |
92 |
%define libglname_virt lib%{glname} |
93 |
%define libgluname_virt lib%{gluname} |
94 |
%define libglwname_virt lib%{glwname} |
95 |
%define libglesv1name_virt lib%{glesv1name} |
96 |
%define libglesv2name_virt lib%{glesv2name} |
97 |
%define libopenvgname_virt lib%{openvgname} |
98 |
%define libglapiname_virt lib%{glapiname} |
99 |
%define libgbmname_virt lib%{gbmname} |
100 |
%define libwaylandeglname_virt lib%{waylandeglname} |
101 |
|
102 |
%define oldlibglname %mklibname MesaGL 1 |
103 |
%define oldlibgluname %mklibname MesaGLU 1 |
104 |
|
105 |
%define mesasrcdir %{_prefix}/src/Mesa/ |
106 |
%define driver_dir %{_libdir}/dri |
107 |
|
108 |
%define enable_egl 1 |
109 |
%define enable_wayland 1 |
110 |
|
111 |
#FIXME: (for 386/485) unset SSE, MMX and 3dnow flags |
112 |
#FIXME: (for >=i586) disable sse |
113 |
# SSE seems to have problem on some apps (gtulpas) for probing. |
114 |
%define dri_drivers_i386 "i915,i965,nouveau,r200,radeon,swrast" |
115 |
%define dri_drivers_x86_64 %{dri_drivers_i386} |
116 |
%define dri_drivers_ppc "r200,radeon,swrast" |
117 |
%define dri_drivers_ppc64 "" |
118 |
%define dri_drivers_ia64 "i915,i965,mga,r200,radeon,swrast" |
119 |
%define dri_drivers_alpha "r200,radeon,swrast" |
120 |
%define dri_drivers_sparc "ffb,radeon,swrast" |
121 |
%define dri_drivers_mipsel "r200,radeon,swrast" |
122 |
%define dri_drivers_arm "swrast" |
123 |
%define dri_drivers %{expand:%{dri_drivers_%{_arch}}} |
124 |
|
125 |
Name: %{name} |
126 |
Version: %{version} |
127 |
Release: %{release} |
128 |
Summary: OpenGL 2.1 compatible 3D graphics library |
129 |
Group: System/Libraries |
130 |
|
131 |
BuildRequires: pkgconfig(xfixes) >= 4.0.3 |
132 |
BuildRequires: pkgconfig(xt) >= 1.0.5 |
133 |
BuildRequires: pkgconfig(xmu) >= 1.0.3 |
134 |
BuildRequires: pkgconfig(x11) >= 1.3.3 |
135 |
BuildRequires: pkgconfig(xdamage) >= 1.1.1 |
136 |
BuildRequires: libexpat-devel >= 2.0.1 |
137 |
BuildRequires: gccmakedep |
138 |
BuildRequires: x11-proto-devel >= 7.3 |
139 |
BuildRequires: pkgconfig(libdrm) >= 2.4.21 |
140 |
|
141 |
BuildRequires: pkgconfig(xext) >= 1.1.1 |
142 |
BuildRequires: pkgconfig(xxf86vm) >= 1.1.0 |
143 |
BuildRequires: pkgconfig(xi) >= 1.3 |
144 |
BuildRequires: pkgconfig(talloc) |
145 |
BuildRequires: libxml2-python |
146 |
BuildRequires: makedepend |
147 |
BuildRequires: bison flex |
148 |
BuildRequires: llvm-devel |
149 |
BuildRequires: pkgconfig(libudev) |
150 |
BuildRequires: pkgconfig(vdpau) |
151 |
%if %{enable_wayland} |
152 |
BuildRequires: wayland-devel |
153 |
%endif |
154 |
|
155 |
URL: http://www.mesa3d.org |
156 |
%if %{git} |
157 |
# (cg) Current commit ref: origin/mesa_7_5_branch |
158 |
Source0: %{name}-%{git}.tar.bz2 |
159 |
%else |
160 |
Source0: ftp://ftp.freedesktop.org/pub/mesa/%version/MesaLib-%{version}%{vsuffix}.%{src_type} |
161 |
%endif |
162 |
Source3: make-git-snapshot.sh |
163 |
|
164 |
# Instructions to setup your repository clone |
165 |
# git://git.freedesktop.org/git/mesa/mesa |
166 |
# git checkout mesa_7_5_branch |
167 |
# git branch mdv-cherry-picks |
168 |
# git am ../02??-*.patch |
169 |
# git branch mdv-redhat |
170 |
# git am ../03??-*.patch |
171 |
# git branch mdv-patches |
172 |
# git am ../09??-*.patch |
173 |
|
174 |
# Fix parallel make (Anssi 08/2012) - "*.td" is not evaluated properly on fresh |
175 |
# build with no .td files created yet (TODO: check if upstream has fix already, |
176 |
# and provide one if not - upstream git was down at the time of writing): |
177 |
Patch001: mesa-radeon-parallel-make.patch |
178 |
|
179 |
# In order to update to the branch via patches, issue this command: |
180 |
# git format-patch --start-number 100 mesa_7_5_1..mesa_7_5_branch | sed 's/^0\([0-9]\+\)-/Patch\1: 0\1-/' |
181 |
|
182 |
# Cherry picks |
183 |
# git format-patch --start-number 200 mesa_7_5_branch..mdv-cherry-picks |
184 |
Patch201: 0201-revert-fix-glxinitializevisualconfigfromtags-handling.patch |
185 |
|
186 |
# Patches "liberated" from Fedora: |
187 |
# http://cvs.fedoraproject.org/viewvc/rpms/mesa/devel/ |
188 |
# git format-patch --start-number 300 mdv-cherry-picks..mdv-redhat |
189 |
|
190 |
# Mageia/Mandriva patches |
191 |
# git format-patch --start-number 900 mdv-redhat..mdv-patches |
192 |
# (blino) llvmpipe test programs link fails when ld --as-needed option is used, reported as fdo #52167 |
193 |
Patch901: 0901-llvmpipe-ldl.patch |
194 |
|
195 |
|
196 |
#------------------------------------------------------------------------------ |
197 |
|
198 |
# package mesa |
199 |
License: MIT |
200 |
Requires: %{libglname} = %{version}-%{release} |
201 |
Provides: hackMesa = %{version} |
202 |
Obsoletes: hackMesa <= %{version} |
203 |
Provides: Mesa = %{version} |
204 |
Obsoletes: Mesa < %{version} |
205 |
|
206 |
%package -n %{libdricorename} |
207 |
Summary: Shared library for DRI drivers |
208 |
Group: System/Libraries |
209 |
Provides: %{libdricorename_virt} = %{version}-%{release} |
210 |
|
211 |
%package -n %{libdricorename}-devel |
212 |
Summary: Development files for DRI core |
213 |
Group: Development/C |
214 |
Requires: %{libdricorename} = %{version}-%{release} |
215 |
Provides: lib%{dricorename}-devel = %{version}-%{release} |
216 |
Provides: %{dricorename}-devel = %{version}-%{release} |
217 |
|
218 |
%package -n %{libglname} |
219 |
Summary: Files for Mesa (GL and GLX libs) |
220 |
Group: System/Libraries |
221 |
Obsoletes: %{oldlibglname} < 6.4 |
222 |
Provides: %{oldlibglname} = %{version}-%{release} |
223 |
Provides: %{libglname_virt} = %{version}-%{release} |
224 |
Requires: %{dridrivers} >= %{version}-%{release} |
225 |
%if %{build_plf} |
226 |
Requires: %mklibname txc-dxtn |
227 |
%endif |
228 |
|
229 |
# (anssi) Forces the upgrade of x11-server-common to happen before |
230 |
# alternatives removal, which allows x11-server-common to grab the symlink. |
231 |
Conflicts: x11-server-common < 1.3.0.0-17 |
232 |
|
233 |
%package -n %{dridrivers} |
234 |
Summary: Mesa DRI drivers |
235 |
Group: System/Libraries |
236 |
# do not require exact release to avoid conflicts when having |
237 |
# x86_64 dri drivers from tainted and i586 dri drivers from core |
238 |
Requires: mesa = %{version} |
239 |
Conflicts: %{_lib}MesaGL1 < 7.7-5 |
240 |
Obsoletes: %{_lib}dri-drivers-experimental < 7.11.2-4 |
241 |
Provides: %{_lib}dri-drivers-experimental = %{version}-%{release} |
242 |
|
243 |
%package -n %{libglname}-devel |
244 |
Summary: Development files for Mesa (OpenGL compatible 3D lib) |
245 |
Group: Development/C |
246 |
Requires: %{libglname} = %{version}-%{release} |
247 |
Provides: lib%{glname}-devel = %{version}-%{release} |
248 |
Provides: %{glname}-devel = %{version}-%{release} |
249 |
Provides: GL-devel |
250 |
Obsoletes: %{oldlibglname}-devel < 6.4 |
251 |
Provides: %{oldlibglname}-devel = %{version}-%{release} |
252 |
Provides: libMesaGL-devel = %{version}-%{release} |
253 |
Provides: MesaGL-devel = %{version}-%{release} |
254 |
Provides: libgl-devel |
255 |
|
256 |
%package -n %{libgluname} |
257 |
Summary: Files for Mesa (GLU libs) |
258 |
Group: System/Libraries |
259 |
Obsoletes: %{oldlibgluname} < 6.4 |
260 |
Provides: %{oldlibgluname} = %{version}-%{release} |
261 |
Provides: %{libgluname_virt} = %{version}-%{release} |
262 |
|
263 |
%package -n %{libgluname}-devel |
264 |
Summary: Development files for GLU libs |
265 |
Group: Development/C |
266 |
Requires: %{libgluname} = %{version}-%{release} |
267 |
Provides: lib%{gluname}-devel = %{version}-%{release} |
268 |
Provides: %{gluname}-devel = %{version}-%{release} |
269 |
Obsoletes: %{oldlibgluname}-devel < 6.4 |
270 |
Provides: %{oldlibgluname}-devel = %{version}-%{release} |
271 |
Provides: libMesaGLU-devel = %{version}-%{release} |
272 |
Provides: MesaGLU-devel = %{version}-%{release} |
273 |
Provides: libglu-devel |
274 |
# pkgconfig files moved from libgl-devel: |
275 |
Conflicts: %{libglname}-devel < 7.10.2-4 |
276 |
|
277 |
%if %{enable_egl} |
278 |
%package -n %{libeglname} |
279 |
Summary: Files for Mesa (EGL libs) |
280 |
Group: System/Libraries |
281 |
Provides: %{libeglname_virt} = %{version}-%{release} |
282 |
|
283 |
%package -n %{libeglname}-devel |
284 |
Summary: Development files for Mesa (EGL libs) |
285 |
Group: Development/C |
286 |
Requires: %{libeglname} = %{version}-%{release} |
287 |
Provides: EGL-devel |
288 |
Provides: lib%{eglname}-devel |
289 |
Provides: %{eglname}-devel |
290 |
Provides: libegl-devel |
291 |
%endif |
292 |
|
293 |
%package -n %{libosmesaname} |
294 |
Summary: Mesa offscreen rendering library |
295 |
Group: System/Libraries |
296 |
|
297 |
%package -n %{osmesadevel} |
298 |
Summary: Development files for libosmesa |
299 |
Group: Development/C |
300 |
Requires: %{libosmesaname} = %{version}-%{release} |
301 |
Provides: osmesa-devel = %{version}-%{release} |
302 |
Conflicts: MesaGL-devel < 8.1.0-0.git20120727.3 |
303 |
|
304 |
%package -n %{libglapiname} |
305 |
Summary: Files for mesa (glapi libs) |
306 |
Group: System/Libraries |
307 |
Provides: %{libglapiname_virt} = %{version}-%{release} |
308 |
|
309 |
%package -n %{libglapiname}-devel |
310 |
Summary: Development files for glapi libs |
311 |
Group: Development/C |
312 |
Requires: %{libglapiname_virt} = %{version}-%{release} |
313 |
Provides: lib%{glapiname}-devel |
314 |
Provides: %{libglapiname}-devel |
315 |
|
316 |
%package -n %{libglesv1name} |
317 |
Summary: Files for Mesa (glesv1 libs) |
318 |
Group: System/Libraries |
319 |
Provides: %{libglesv1name_virt} = %{version}-%{release} |
320 |
|
321 |
%package -n %{libglesv1name}-devel |
322 |
Summary: Development files for glesv1 libs |
323 |
Group: Development/C |
324 |
Requires: %{libglesv1name} = %{version}-%{release} |
325 |
Provides: lib%{glesv1name}-devel |
326 |
Provides: %{glesv1name}-devel |
327 |
Provides: libglesv1-devel |
328 |
|
329 |
%package -n %{libglesv2name} |
330 |
Summary: Files for Mesa (glesv2 libs) |
331 |
Group: System/Libraries |
332 |
Provides: %{libglesv2name_virt} = %{version}-%{release} |
333 |
|
334 |
%package -n %{libglesv2name}-devel |
335 |
Summary: Development files for glesv2 libs |
336 |
Group: Development/C |
337 |
Requires: %{libglesv2name} = %{version}-%{release} |
338 |
Requires: %{libeglname}-devel = %{version}-%{release} |
339 |
Provides: lib%{glesv2name}-devel |
340 |
Provides: %{glesv2name}-devel |
341 |
Provides: libglesv2-devel |
342 |
|
343 |
%package -n %{libopenvgname} |
344 |
Summary: Files for MESA (OpenVG libs) |
345 |
Group: System/Libraries |
346 |
Provides: %{libopenvgname_virt} = %{version}-%{release} |
347 |
|
348 |
%package -n %{libopenvgname}-devel |
349 |
Summary: Development files vor OpenVG libs |
350 |
Group: Development/C |
351 |
Requires: %{libopenvgname} = %{version}-%{release} |
352 |
Provides: lib%{openvgname}-devel |
353 |
Provides: %{openvgname}-devel |
354 |
Provides: libopenvg-devel |
355 |
|
356 |
%if %{enable_wayland} |
357 |
%package -n %{libgbmname} |
358 |
Summary: Files for Mesa (gbm libs) |
359 |
Group: System/Libraries |
360 |
Provides: %{libgbmname_virt} = %{version}-%{release} |
361 |
|
362 |
%package -n %{libgbmname}-devel |
363 |
Summary: Development files for Mesa (gbm libs) |
364 |
Group: Development/C |
365 |
Requires: %{libgbmname} = %{version}-%{release} |
366 |
Provides: lib%{gbmname}-devel |
367 |
Provides: %{gbmname}-devel |
368 |
|
369 |
%package -n %{libwaylandeglname} |
370 |
Summary: Files for Mesa (Wayland EGL libs) |
371 |
Group: System/Libraries |
372 |
Provides: %{libwaylandeglname_virt} = %{version}-%{release} |
373 |
|
374 |
%package -n %{libwaylandeglname}-devel |
375 |
Summary: Development files for Mesa (Wayland EGL libs) |
376 |
Group: Development/C |
377 |
Requires: %{libwaylandeglname} = %{version}-%{release} |
378 |
Provides: lib%{waylandeglname}-devel |
379 |
Provides: %{waylandeglname}-devel |
380 |
%endif |
381 |
|
382 |
%package -n vdpau-driver-nouveau |
383 |
Summary: VDPAU plugin for nouveau driver |
384 |
Group: System/Libraries |
385 |
|
386 |
%package -n vdpau-driver-r300 |
387 |
Summary: VDPAU plugin for r300 driver |
388 |
Group: System/Libraries |
389 |
|
390 |
%package -n vdpau-driver-r600 |
391 |
Summary: VDPAU plugin for r600 driver |
392 |
Group: System/Libraries |
393 |
|
394 |
%package -n vdpau-driver-softpipe |
395 |
Summary: VDPAU plugin for softpipe driver |
396 |
Group: System/Libraries |
397 |
|
398 |
%package common-devel |
399 |
Summary: Meta package for mesa devel |
400 |
Group: Development/C |
401 |
Provides: Mesa-common-devel = %{version}-%{release} |
402 |
Provides: hackMesa-common-devel = %{version} |
403 |
Obsoletes: Mesa-common-devel < %{version} |
404 |
Obsoletes: hackMesa-common-devel < %{version} |
405 |
Requires: %{libglname}-devel = %{version} |
406 |
Requires: %{libgluname}-devel = %{version} |
407 |
Requires: freeglut-devel |
408 |
Requires: %{libeglname}-devel = %{version} |
409 |
Requires: %{libglesv1name}-devel = %{version} |
410 |
Requires: %{libglesv2name}-devel = %{version} |
411 |
|
412 |
#------------------------------------------------------------------------------ |
413 |
|
414 |
%description |
415 |
Mesa is an OpenGL 2.1 compatible 3D graphics library. |
416 |
%if %{build_plf} |
417 |
|
418 |
This package is in the "tainted" section because it enables some |
419 |
OpenGL extentions that are covered by software patents. |
420 |
%endif |
421 |
|
422 |
%description common-devel |
423 |
Mesa common metapackage devel |
424 |
|
425 |
%if %{enable_egl} |
426 |
%description -n %{libeglname} |
427 |
Mesa is an OpenGL 2.1 compatible 3D graphics library. |
428 |
EGL parts. |
429 |
|
430 |
%description -n %{libeglname}-devel |
431 |
Mesa is an OpenGL 2.1 compatible 3D graphics library. |
432 |
EGL development parts. |
433 |
%endif |
434 |
|
435 |
%description -n %{libdricorename} |
436 |
Mesa is an OpenGL 2.1 compatible 3D graphics library. |
437 |
DRI core part. |
438 |
|
439 |
%description -n %{libglname} |
440 |
Mesa is an OpenGL 2.1 compatible 3D graphics library. |
441 |
GL and GLX parts. |
442 |
|
443 |
%if %{build_plf} |
444 |
This package is in the "tainted" section because it enables some |
445 |
OpenGL extentions that are covered by software patents. |
446 |
%endif |
447 |
|
448 |
%description -n %{dridrivers} |
449 |
Mesa is an OpenGL 2.1 compatible 3D graphics library. |
450 |
DRI drivers. |
451 |
|
452 |
%description -n %{libdricorename}-devel |
453 |
Mesa is an OpenGL 2.1 compatible 3D graphics library. |
454 |
|
455 |
This package contains the headers needed to compile DRI drivers. |
456 |
|
457 |
%description -n %{libglname}-devel |
458 |
Mesa is an OpenGL 2.1 compatible 3D graphics library. |
459 |
|
460 |
This package contains the headers needed to compile Mesa programs. |
461 |
|
462 |
%description -n %{libgluname} |
463 |
GLU is the OpenGL Utility Library. |
464 |
It provides a number of functions upon the base OpenGL library to provide |
465 |
higher-level drawing routines from the more primitive routines provided by |
466 |
OpenGL. |
467 |
|
468 |
%description -n %{libgluname}-devel |
469 |
This package contains the headers needed to compile programs with GLU. |
470 |
|
471 |
%description -n %{libglesv1name} |
472 |
OpenGL ES is a low-level, lightweight API for advanced embedded graphics using |
473 |
well-defined subset profiles of OpenGL. |
474 |
|
475 |
This package provides the OpenGL ES library version 1. |
476 |
|
477 |
%description -n %{libosmesaname} |
478 |
Mesa offscreen rendering libraries for rendering OpenGL into |
479 |
application-allocated blocks of memory. |
480 |
|
481 |
%description -n %{osmesadevel} |
482 |
This package contains the headers needed to compile programs against |
483 |
the Mesa offscreen rendering library. |
484 |
|
485 |
%description -n %{libglapiname} |
486 |
This packages provides the glapi shared library used by gallium. |
487 |
|
488 |
%description -n %{libglapiname}-devel |
489 |
This package contains the headers needed to compile programes against glapi shared library. |
490 |
|
491 |
%description -n %{libglesv1name}-devel |
492 |
This package contains the headers needed to compile OpenGL ES 1 programs. |
493 |
|
494 |
%description -n %{libglesv2name} |
495 |
OpenGL ES is a low-level, lightweight API for advanced embedded graphics using |
496 |
well-defined subset profiles of OpenGL. |
497 |
|
498 |
This package provides the OpenGL ES library version 2. |
499 |
|
500 |
%description -n %{libglesv2name}-devel |
501 |
This package contains the headers needed to compile OpenGL ES 2 programs. |
502 |
|
503 |
%description -n %{libopenvgname} |
504 |
OpenVG is a royalty-free, cross-platform API that provides a low-level hardware |
505 |
acceleration interface for vector graphics libraries such as Flash and SVG. |
506 |
|
507 |
%description -n %{libopenvgname}-devel |
508 |
Development files for OpenVG library. |
509 |
|
510 |
%if %{enable_wayland} |
511 |
%description -n %{libgbmname} |
512 |
Mesa is an OpenGL 2.1 compatible 3D graphics library. |
513 |
GBM (Graphics Buffer Manager) parts. |
514 |
|
515 |
%description -n %{libgbmname}-devel |
516 |
Mesa is an OpenGL 2.1 compatible 3D graphics library. |
517 |
GBM (Graphics Buffer Manager) development parts. |
518 |
|
519 |
%description -n %{libwaylandeglname} |
520 |
Mesa is an OpenGL 2.1 compatible 3D graphics library. |
521 |
Wayland EGL platform parts. |
522 |
|
523 |
%description -n %{libwaylandeglname}-devel |
524 |
Mesa is an OpenGL 2.1 compatible 3D graphics library. |
525 |
Wayland EGL platform development parts. |
526 |
%endif |
527 |
|
528 |
%description -n vdpau-driver-nouveau |
529 |
This packages provides a VPDAU plugin to enable video acceleration |
530 |
with the nouveau driver. |
531 |
|
532 |
%description -n vdpau-driver-r300 |
533 |
This packages provides a VPDAU plugin to enable video acceleration |
534 |
with the r300 driver. |
535 |
|
536 |
%description -n vdpau-driver-r600 |
537 |
This packages provides a VPDAU plugin to enable video acceleration |
538 |
with the r600 driver. |
539 |
|
540 |
%description -n vdpau-driver-softpipe |
541 |
This packages provides a VPDAU plugin to enable video acceleration |
542 |
with the softpipe driver. |
543 |
|
544 |
#------------------------------------------------------------------------------ |
545 |
|
546 |
%prep |
547 |
%if %{git} |
548 |
%setup -q -n mesa-%{git} |
549 |
%else |
550 |
%setup -q -n Mesa-%{version}%{vsuffix} |
551 |
%endif |
552 |
|
553 |
%patch001 -p1 |
554 |
%patch201 -p1 |
555 |
%patch901 -p1 |
556 |
|
557 |
%build |
558 |
autoreconf -vfi |
559 |
|
560 |
# fix build - TODO: should this be fixed in llvm somehow, or maybe the library |
561 |
# symlinks should be moved to %{_libdir}? -Anssi 08/2012 |
562 |
export LDFLAGS="-L%{_libdir}/llvm" |
563 |
|
564 |
%configure2_5x --enable-dri \ |
565 |
--enable-glx \ |
566 |
--with-dri-driverdir=%{driver_dir} \ |
567 |
--with-dri-drivers="%{dri_drivers}" \ |
568 |
--enable-shared-dricore \ |
569 |
%if %{enable_egl} |
570 |
--enable-egl \ |
571 |
%else |
572 |
--disable-egl \ |
573 |
%endif |
574 |
%if %{enable_wayland} |
575 |
--with-egl-platforms=x11,wayland,drm \ |
576 |
--enable-gbm \ |
577 |
--enable-shared-glapi \ |
578 |
%endif |
579 |
--enable-gles1 \ |
580 |
--enable-gles2 \ |
581 |
--enable-openvg \ |
582 |
--enable-gallium-egl \ |
583 |
--enable-gallium-g3dvl \ |
584 |
--enable-osmesa \ |
585 |
--disable-xvmc \ |
586 |
--enable-vdpau \ |
587 |
--disable-va \ |
588 |
%if %{with_hardware} |
589 |
--with-gallium-drivers=r300,r600,nouveau,swrast \ |
590 |
--enable-gallium-llvm \ |
591 |
%else |
592 |
--disable-gallium-llvm \ |
593 |
--with-gallium-drivers=swrast \ |
594 |
%endif |
595 |
%if %{build_plf} |
596 |
--enable-texture-float \ |
597 |
%endif |
598 |
# end of configure options |
599 |
|
600 |
%make |
601 |
|
602 |
%install |
603 |
%makeinstall_std |
604 |
|
605 |
# FIXME: strip will likely break the hardlink |
606 |
# (blino) hardlink libGL files in %{_libdir}/mesa |
607 |
# to prevent proprietary driver installers from removing them |
608 |
mkdir -p $RPM_BUILD_ROOT%{_libdir}/mesa |
609 |
pushd $RPM_BUILD_ROOT%{_libdir}/mesa |
610 |
for l in ../libGL.so.*; do cp -a $l .; done |
611 |
popd |
612 |
|
613 |
%ifarch %{x86_64} |
614 |
mkdir -p $RPM_BUILD_ROOT%{_prefix}/lib/dri |
615 |
%endif |
616 |
|
617 |
rm -f %{buildroot}/%{_includedir}/GL/glut.h |
618 |
rm -f %{buildroot}/%{_includedir}/GL/glutf90.h |
619 |
|
620 |
# .so files are not needed by vdpau |
621 |
rm -f %{buildroot}%{_libdir}/vdpau/libvdpau_*.so |
622 |
|
623 |
# .la files are not needed by mesa |
624 |
find %{buildroot} -name '*.la' -exec rm {} \; |
625 |
|
626 |
# use swrastg if built (Anssi 12/2011) |
627 |
[ -e %{buildroot}%{_libdir}/dri/swrastg_dri.so ] && mv %{buildroot}%{_libdir}/dri/swrast{g,}_dri.so |
628 |
|
629 |
#------------------------------------------------------------------------------ |
630 |
|
631 |
%files |
632 |
%defattr(-,root,root) |
633 |
%doc docs/COPYING |
634 |
%config(noreplace) %{_sysconfdir}/drirc |
635 |
|
636 |
%files -n %{libdricorename} |
637 |
%{_libdir}/libdricore%{version}.so.%{dricoremajor} |
638 |
%{_libdir}/libdricore%{version}.so.%{dricoremajor}.* |
639 |
|
640 |
%files -n %{libdricorename}-devel |
641 |
%{_libdir}/libdricore%{version}.so |
642 |
|
643 |
%files -n %{dridrivers} |
644 |
%defattr(-,root,root) |
645 |
%doc docs/COPYING |
646 |
%ifnarch ppc64 |
647 |
%dir %{_libdir}/dri |
648 |
# (blino) new mesa 8.1 build system seems to use a static libglsl |
649 |
#%{_libdir}/dri/libglsl.so |
650 |
%{_libdir}/dri/*_dri.so |
651 |
%endif |
652 |
|
653 |
%files -n %{libglname} |
654 |
%defattr(-,root,root) |
655 |
%doc docs/COPYING |
656 |
%{_libdir}/libGL.so.* |
657 |
%dir %{_libdir}/mesa |
658 |
%{_libdir}/mesa/libGL.so.%{glmajor}* |
659 |
|
660 |
%files -n %{libgluname} |
661 |
%defattr(-,root,root) |
662 |
%doc docs/COPYING |
663 |
%{_libdir}/libGLU.so.%{glumajor}* |
664 |
|
665 |
%if %{enable_egl} |
666 |
%files -n %{libeglname} |
667 |
%defattr(-,root,root) |
668 |
%doc docs/COPYING |
669 |
%{_libdir}/libEGL.so.%{eglmajor}* |
670 |
%dir %{_libdir}/egl |
671 |
%if !%{enable_wayland} |
672 |
# st_GL, built only when shared glapi is not enabled |
673 |
%{_libdir}/egl/st_GL.so |
674 |
%endif |
675 |
%{_libdir}/egl/egl_gallium.so |
676 |
%endif |
677 |
|
678 |
%files -n %{libosmesaname} |
679 |
%defattr(-,root,root) |
680 |
%{_libdir}/libOSMesa.so.%{osmesamajor}* |
681 |
|
682 |
%files -n %{libglapiname} |
683 |
%defattr(-,root,root) |
684 |
%{_libdir}/libglapi.so.%{glapimajor}* |
685 |
|
686 |
%files -n %{libglesv1name} |
687 |
%defattr(-,root,root) |
688 |
%doc docs/COPYING |
689 |
%{_libdir}/libGLESv1_CM.so.%{glesv1major}* |
690 |
|
691 |
%files -n %{libglesv2name} |
692 |
%defattr(-,root,root) |
693 |
%doc docs/COPYING |
694 |
%{_libdir}/libGLESv2.so.%{glesv2major}* |
695 |
|
696 |
%files -n %{libopenvgname} |
697 |
%defattr(-,root,root) |
698 |
%doc docs/COPYING |
699 |
%{_libdir}/libOpenVG.so.%{openvgmajor}* |
700 |
|
701 |
%if %{enable_wayland} |
702 |
%files -n %{libgbmname} |
703 |
%{_libdir}/libgbm.so.%{gbmmajor} |
704 |
%{_libdir}/libgbm.so.%{gbmmajor}.* |
705 |
%{_libdir}/gbm/gbm_*.so |
706 |
%{_libdir}/gbm/pipe_*.so |
707 |
|
708 |
%files -n %{libwaylandeglname} |
709 |
%{_libdir}/libwayland-egl.so.%{waylandeglmajor} |
710 |
%{_libdir}/libwayland-egl.so.%{waylandeglmajor}.* |
711 |
%endif |
712 |
|
713 |
|
714 |
%files -n %{libglname}-devel |
715 |
%defattr(-,root,root) |
716 |
%doc docs/COPYING |
717 |
%dir %{_includedir}/GL |
718 |
%{_includedir}/GL/gl.h |
719 |
%{_includedir}/GL/glext.h |
720 |
%{_includedir}/GL/gl_mangle.h |
721 |
%{_includedir}/GL/wglext.h |
722 |
%{_includedir}/GL/glx.h |
723 |
%{_includedir}/GL/glxext.h |
724 |
%{_includedir}/GL/glx_mangle.h |
725 |
%{_libdir}/libGL.so |
726 |
%{_libdir}/pkgconfig/gl.pc |
727 |
%{_libdir}/pkgconfig/dri.pc |
728 |
|
729 |
#FIXME: check those headers |
730 |
%{_includedir}/GL/vms_x_fix.h |
731 |
%{_includedir}/GL/wmesa.h |
732 |
%dir %{_includedir}/GL/internal |
733 |
%{_includedir}/GL/internal/dri_interface.h |
734 |
|
735 |
%files -n %{libgluname}-devel |
736 |
%defattr(-,root,root) |
737 |
%doc docs/COPYING |
738 |
%dir %{_includedir}/GL |
739 |
%{_includedir}/GL/glu.h |
740 |
%{_includedir}/GL/glu_mangle.h |
741 |
%{_libdir}/libGLU.so |
742 |
%{_libdir}/pkgconfig/glu.pc |
743 |
|
744 |
%files common-devel |
745 |
%defattr(-,root,root) |
746 |
|
747 |
%if %{enable_egl} |
748 |
%files -n %{libeglname}-devel |
749 |
%defattr(-,root,root) |
750 |
%doc docs/COPYING |
751 |
%{_includedir}/EGL |
752 |
%{_includedir}/KHR |
753 |
%{_libdir}/libEGL.so |
754 |
%{_libdir}/pkgconfig/egl.pc |
755 |
%endif |
756 |
|
757 |
%files -n %{osmesadevel} |
758 |
%defattr(-,root,root) |
759 |
%dir %{_includedir}/GL |
760 |
%{_includedir}/GL/osmesa.h |
761 |
%{_libdir}/libOSMesa.so |
762 |
%{_libdir}/pkgconfig/osmesa.pc |
763 |
|
764 |
%files -n %{libglapiname}-devel |
765 |
%defattr(-,root,root) |
766 |
%{_libdir}/libglapi.so |
767 |
|
768 |
%files -n %{libglesv1name}-devel |
769 |
%defattr(-,root,root) |
770 |
%{_includedir}/GLES |
771 |
%{_libdir}/libGLESv1_CM.so |
772 |
%{_libdir}/pkgconfig/glesv1_cm.pc |
773 |
|
774 |
%files -n %{libglesv2name}-devel |
775 |
%defattr(-,root,root) |
776 |
%{_includedir}/GLES2 |
777 |
%{_libdir}/libGLESv2.so |
778 |
%{_libdir}/pkgconfig/glesv2.pc |
779 |
|
780 |
%files -n %{libopenvgname}-devel |
781 |
%defattr(-,root,root) |
782 |
%{_includedir}/VG |
783 |
%{_libdir}/libOpenVG.so |
784 |
%{_libdir}/pkgconfig/vg.pc |
785 |
|
786 |
%if %{enable_wayland} |
787 |
%files -n %{libgbmname}-devel |
788 |
%{_includedir}/gbm.h |
789 |
%{_libdir}/libgbm.so |
790 |
%{_libdir}/pkgconfig/gbm.pc |
791 |
|
792 |
%files -n %{libwaylandeglname}-devel |
793 |
%{_libdir}/libwayland-egl.so |
794 |
%{_libdir}/pkgconfig/wayland-egl.pc |
795 |
%endif |
796 |
|
797 |
%files -n vdpau-driver-nouveau |
798 |
%{_libdir}/vdpau/libvdpau_nouveau.so.* |
799 |
|
800 |
%files -n vdpau-driver-r300 |
801 |
%{_libdir}/vdpau/libvdpau_r300.so.* |
802 |
|
803 |
%files -n vdpau-driver-r600 |
804 |
%{_libdir}/vdpau/libvdpau_r600.so.* |
805 |
|
806 |
%files -n vdpau-driver-softpipe |
807 |
%{_libdir}/vdpau/libvdpau_softpipe.so.* |