1 |
%define name monodevelop-java |
2 |
%define version 2.4 |
3 |
%define release 1 |
4 |
|
5 |
|
6 |
Name: %{name} |
7 |
Version: %{version} |
8 |
Release: %mkrel %{release} |
9 |
Summary: MonoDevelop java Addin |
10 |
License: GPLv2+ |
11 |
Group: Development/Tools |
12 |
Source: http://ftp.novell.com/pub/mono/sources/%{name}/%{name}-%{version}.tar.bz2 |
13 |
URL: http://www.monodevelop.com |
14 |
BuildRoot: %(mktemp -ud %{_tmppath}/%{name}-%{version}-%{release}-XXXXX) |
15 |
BuildArch: noarch |
16 |
BuildRequires: mono-devel >= 2.6 |
17 |
BuildRequires: mono-addins-devel |
18 |
BuildRequires: monodevelop-devel >= 2.4 |
19 |
BuildRequires: gtk-sharp2-devel |
20 |
Requires: monodevelop >= 2.4 |
21 |
#ExclusiveArch: %ix86 |
22 |
#ExclusiveArch: x86_64 |
23 |
#ExclusiveArch: ia64 |
24 |
#ExclusiveArch: armv4l |
25 |
#ExclusiveArch: sparcv9 |
26 |
#ExclusiveArch: alpha |
27 |
#ExclusiveArch: s390 |
28 |
#ExclusiveArch: s390x |
29 |
|
30 |
%description |
31 |
Java Addin for MonoDevelop. |
32 |
|
33 |
%package devel |
34 |
Summary: Development files for MonoDevelop java Addin |
35 |
Group: Development/Libraries |
36 |
Requires: %{name} = %{version}-%{release} |
37 |
Requires: pkgconfig |
38 |
|
39 |
%description devel |
40 |
Mono Java Addin for MonoDevelop. Development package. |
41 |
|
42 |
The %{name}-devel package contains development files for %{name}. |
43 |
|
44 |
%prep |
45 |
%setup -q |
46 |
#sed -i -e 's!@prefix@/lib/!%{_libdir}/!g' monodevelop-java.pc.in |
47 |
#sed -i -e 's!@prefix@/lib/!%{_libdir}/!g' Makefile.include |
48 |
#sed -i -e 's!$(prefix)/lib/!%{_libdir}/!g' JavaBinding.make |
49 |
#sed -i -e 's!$(prefix)/lib/!%{_libdir}/!g' po/Makefile |
50 |
|
51 |
%build |
52 |
./configure --prefix=%{_prefix} |
53 |
make |
54 |
|
55 |
%install |
56 |
rm -rf %{buildroot} |
57 |
make install DESTDIR=%{buildroot} |
58 |
mkdir -p %{buildroot}%{_datadir}/locale |
59 |
mv %{buildroot}%{_libdir}/monodevelop/AddIns/JavaBinding/locale/* %{buildroot}%{_datadir}/locale/ |
60 |
%find_lang %{name} |
61 |
|
62 |
%clean |
63 |
rm -rf %{buildroot} |
64 |
|
65 |
%files -f %{name}.lang |
66 |
%defattr(-,root,root,-) |
67 |
%{_libdir}/monodevelop/AddIns/JavaBinding |
68 |
|
69 |
%files devel |
70 |
%defattr(-,root,root,-) |
71 |
%{_libdir}/pkgconfig/monodevelop-java.pc |
72 |
|