/[packages]/cauldron/nailgun/current/SPECS/nailgun.spec
ViewVC logotype

Contents of /cauldron/nailgun/current/SPECS/nailgun.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 105306 - (show annotations) (download)
Sun Jun 12 18:12:01 2011 UTC (12 years, 10 months ago) by gil
File size: 3325 byte(s)
imported package nailgun
1 Name: nailgun
2 Version: 0.7.1
3 Release: %mkrel 0
4 Summary: Insanely Fast Java
5 Group: Development/Java
6 License: ASL
7 Url: 0.7.1
8 Source0: http://sourceforge.net/projects/nailgun/files/nailgun/%{version}/nailgun-src-%{version}.zip
9 Patch0: nailgun-0.7.1-build_xml.patch
10 BuildRequires: ant
11 BuildRequires: bcel
12 BuildRequires: gnu-getopt
13 BuildRequires: jakarta-oro
14 BuildRequires: jcoverage
15 BuildRequires: junit
16 BuildRequires: jpackage-utils
17 BuildRequires: liblog4j-java
18 Requires: jpackage-utils
19 BuildArch: noarch
20 BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}-buildroot
21
22
23 %description
24 NailGun is a client, protocol, and server for running Java programs from the
25 command line without incurring the JVM startup overhead. Programs run in the
26 server (implemented in java), triggered by the client (written in C), which
27 handles all I/O.
28
29 %package javadoc
30 Group: Development/Java
31 Summary: Javadoc for %{name}
32
33 %description javadoc
34 NailGun is a client, protocol, and server for running Java programs from the
35 command line without incurring the JVM startup overhead. Programs run in the
36 server (implemented in java), triggered by the client (written in C), which
37 handles all I/O.
38
39 This package contains javadoc for %{name}
40
41 %package examples
42 Group: Development/Java
43 Summary: %{name} examples
44
45 %description examples
46 NailGun is a client, protocol, and server for running Java programs from the
47 command line without incurring the JVM startup overhead. Programs run in the
48 server (implemented in java), triggered by the client (written in C), which
49 handles all I/O.
50
51 This package contains %{name} examples.
52
53 %prep
54
55 %setup -q -n nailgun-%{version}
56
57 for j in $(find . -name "*.jar"); do
58 mv $j $j.no
59 done
60 for j in $(find . -name "*.class"); do
61 rm -f $j
62 done
63
64 %patch0 -p0
65
66
67 pushd tools/lib
68 ln -sf $(build-classpath gnu-getopt) java-getopt-1.0.10.jar
69 ln -sf $(build-classpath oro) jakarta-oro-2.0.8.jar
70 ln -sf $(build-classpath jcoverage) jcoverage.jar
71 ln -sf $(build-classpath log4j) log4j-1.2.8.jar
72 ln -sf $(build-classpath junit) junit.jar
73 ln -sf $(build-classpath bcel) bcel-5.1.jar
74 popd
75 mkdir -p build/ant/prod
76
77 %build
78
79 export CLASSPATH=$(build-classpath bcel gnu-getopt jcoverage junit log4j oro)
80 ant jar docs
81
82 %install
83 [ %{buildroot} != / ] && rm -rf %{buildroot}
84
85 #kdir -p %{buildroot}%{_bindir}
86 #nstall -pm 755 ng %{buildroot}%{_bindir}/
87
88 mkdir -p %{buildroot}%{_javadir}
89 install -pm 644 dist/nailgun-%{version}.jar \
90 %{buildroot}%{_javadir}
91
92 install -pm 644 dist/nailgun-examples-%{version}.jar \
93 %{buildroot}%{_javadir}
94
95 (
96 cd %{buildroot}%{_javadir}
97 for jar in *-%{version}*; do
98 ln -sf ${jar} ${jar/-%{version}/}
99 done
100 )
101
102 mkdir -p %{buildroot}%{_javadocdir}/nailgun-%{version}
103 cp -pr docs/api/* %{buildroot}%{_javadocdir}/nailgun-%{version}
104 ln -s nailgun-%{version} %{buildroot}%{_javadocdir}/nailgun
105
106 %clean
107 [ %{buildroot} != / ] && rm -rf %{buildroot}
108
109 %files
110 %defattr(-,root,root)
111 %{_javadir}/nailgun-%{version}.jar
112 %{_javadir}/nailgun.jar
113 %doc LICENSE.txt README.txt
114
115 %files examples
116 %defattr(-,root,root)
117 %{_javadir}/nailgun-examples-%{version}.jar
118 %{_javadir}/nailgun-examples.jar
119 %doc docs/*.txt
120
121 %files javadoc
122 %defattr(-,root,root)
123 %{_javadocdir}/nailgun-%{version}
124 %{_javadocdir}/nailgun
125

  ViewVC Help
Powered by ViewVC 1.1.30