/[packages]/cauldron/nfs-utils/current/SPECS/nfs-utils.spec
ViewVC logotype

Contents of /cauldron/nfs-utils/current/SPECS/nfs-utils.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1964276 - (show annotations) (download)
Sat Jul 29 10:03:54 2023 UTC (8 months, 3 weeks ago) by wally
File size: 7927 byte(s)
- own /etc/nfsmount.conf.d/
1 %define major 0
2 %define libname %mklibname nfsidmap %{major}
3 %define devname %mklibname nfsidmap -d
4
5 Name: nfs-utils
6 Epoch: 1
7
8 # group all 32bit related archs
9 %global all_32bit_archs i386 i486 i586 i686 athlon ppc sparcv9
10
11 Version: 2.6.3
12 Release: %mkrel 1
13 Summary: The utilities for Linux NFS server
14 Group: Networking/Other
15 License: MIT and GPLv2 and GPLv2+ and BSD
16 URL: https://linux-nfs.org/
17 Source0: https://www.kernel.org/pub/linux/utils/nfs-utils/%{version}/%{name}-%{version}.tar.xz
18 Source1: id_resolver.conf
19 Source2: lockd.conf
20 Source3: 24-nfs-server.conf
21 Source4: 10-nfsv4.conf
22
23 Patch100: nfs-utils-1.2.1-statdpath-man.patch
24 Patch101: nfs-utils-1.2.1-exp-subtree-warn-off.patch
25 Patch102: nfs-utils-1.2.5-idmap-errmsg.patch
26 Patch103: nfs-utils-2.3.1-systemd-gssproxy-restart.patch
27 Patch104: nfs-utils-2.3.3-man-tcpwrappers.patch
28 Patch105: nfs-utils-2.3.3-nfsconf-usegssproxy.patch
29 Patch106: nfs-utils-2.4.2-systemd-svcgssd.patch
30
31 Requires(pre): rpm-helper
32 Requires(post): rpm-helper
33 Requires(preun): rpm-helper
34 Requires(postun): rpm-helper
35 Requires: rpcbind
36 Requires: keyutils
37 Requires: gssproxy
38 Recommends: quota-rpc
39 BuildRequires: pkgconfig(libevent)
40 BuildRequires: pkgconfig(libcap)
41 BuildRequires: pkgconfig(uuid)
42 BuildRequires: pkgconfig(libtirpc)
43 BuildRequires: pkgconfig(blkid)
44 BuildRequires: keyutils-devel
45 BuildRequires: pkgconfig(krb5) >= 1.3
46 BuildRequires: pkgconfig(librpcsecgss) >= 0.12
47 BuildRequires: pkgconfig(libxml-2.0)
48 BuildRequires: pkgconfig(devmapper)
49 BuildRequires: pkgconfig(sqlite3)
50 BuildRequires: pkgconfig(mount)
51 BuildRequires: pkgconfig(python3)
52 BuildRequires: rpcgen
53 Obsoletes: nfs-utils-clients
54 Provides: nfs-utils-clients
55
56 %description
57 This package provides various programs needed for NFS support on server.
58
59 %package -n %{libname}
60 Summary: NFSv4 User and Group ID Mapping Library
61 License: BSD
62 BuildRequires: openldap-devel
63 Requires: openldap
64
65 %description -n %{libname}
66 Library that handles mapping between names and ids for NFSv4.
67
68 %package -n %{devname}
69 Summary: Development files for the libnfsidmap library
70 Requires: %{libname} = %{epoch}:%{version}-%{release}
71
72 %description -n %{devname}
73 This package includes header files and libraries necessary for
74 developing programs which use the libnfsidmap library.
75
76 %prep
77 %autosetup -p1
78
79 # Remove .orig files
80 find . -name "*.orig" | xargs rm -f
81
82 # Change shebangs
83 find -name \*.py -exec sed -r -i '1s|^#!\s*/usr/bin.*python.*|#!%{__python3}|' {} \;
84
85 %build
86 %serverbuild
87 sh -x autogen.sh
88 %global _statdpath /var/lib/nfs/statd
89 %configure \
90 CFLAGS="%{build_cflags} -D_FILE_OFFSET_BITS=64" \
91 LDFLAGS="%{build_ldflags}" \
92 --enable-mountconfig \
93 --enable-ipv6 \
94 --with-statdpath=%{_statdpath} \
95 --enable-libmount-mount \
96 --with-systemd \
97 --without-tcp-wrappers \
98 --with-pluginpath=%{_libdir}/libnfsidmap \
99 --enable-junction
100
101 %make_build all
102
103 %install
104 %global _pkgdir %{_prefix}/lib/systemd
105
106 install -d %{buildroot}%{_sbindir}
107 install -d %{buildroot}%{_libexecdir}/nfs-utils/
108 install -d %{buildroot}%{_pkgdir}/system
109 install -d %{buildroot}%{_pkgdir}/system-generators
110 install -d %{buildroot}%{_mandir}/man8
111 install -d %{buildroot}%{_sysconfdir}/request-key.d
112 install -d %{buildroot}%{_sysconfdir}/modprobe.d
113 install -d %{buildroot}%{_sysconfdir}/gssproxy
114
115 %make_install
116
117 install -s -m 755 tools/rpcdebug/rpcdebug %{buildroot}%{_sbindir}
118 install -m 644 utils/mount/nfsmount.conf %{buildroot}%{_sysconfdir}
119 install -m 644 nfs.conf %{buildroot}%{_sysconfdir}
120 install -m 644 support/nfsidmap/idmapd.conf %{buildroot}%{_sysconfdir}
121 install -m 644 %{SOURCE1} %{buildroot}%{_sysconfdir}/request-key.d
122
123 install -d %{buildroot}/run/sysconfig
124 install -m 644 %{SOURCE2} %{buildroot}%{_sysconfdir}/modprobe.d/lockd.conf
125 install -m 644 %{SOURCE3} %{buildroot}%{_sysconfdir}/gssproxy
126
127 rm -rf %{buildroot}%{_libdir}/*.{a,la}
128 rm -rf %{buildroot}%{_libdir}/libnfsidmap/*.{a,la}
129
130 install -d %{buildroot}%{_sharedstatedir}/nfs/rpc_pipefs
131
132 touch %{buildroot}%{_sharedstatedir}/nfs/rmtab
133 mv %{buildroot}%{_sbindir}/rpc.statd %{buildroot}/sbin
134
135 install -d %{buildroot}%{_sharedstatedir}/nfs/statd/sm
136 install -d %{buildroot}%{_sharedstatedir}/nfs/statd/sm.bak
137 install -d %{buildroot}%{_sharedstatedir}/nfs/v4recovery
138 install -d %{buildroot}%{_sysconfdir}/exports.d
139
140 install -d %{buildroot}%{_sysconfdir}/nfsmount.conf.d
141 install -m 644 %{SOURCE4} %{buildroot}%{_sysconfdir}/nfsmount.conf.d
142
143 install -d %{buildroot}%{_udevrulesdir}
144
145 %pre
146 %_pre_useradd rpcuser %{_localstatedir}/lib/nfs /bin/false
147
148 %post
149 %_post_unit nfs-client.target
150
151 %preun
152 %_preun_unit nfs-client.target nfs-server.service nfs-blkmap.service nfs-secure.service nfs-secure-server.service
153
154 %postun
155 %_postun_userdel rpcuser
156
157 %files
158 %doc README NEWS COPYING
159 %dir %{_localstatedir}/lib/nfs
160 %dir %{_localstatedir}/lib/nfs/v4recovery
161 %dir %{_localstatedir}/lib/nfs/rpc_pipefs
162 %dir %{_libexecdir}/nfs-utils
163 %dir %attr(700,rpcuser,rpcuser) %{_localstatedir}/lib/nfs/statd
164 %dir %attr(700,rpcuser,rpcuser) %{_localstatedir}/lib/nfs/statd/sm
165 %dir %attr(700,rpcuser,rpcuser) %{_localstatedir}/lib/nfs/statd/sm.bak
166 %ghost %attr(644,rpcuser,rpcuser) %{_localstatedir}/lib/nfs/statd/state
167 %dir %{_sysconfdir}/exports.d
168 %dir %{_sysconfdir}/nfsmount.conf.d
169 %config(noreplace) %{_localstatedir}/lib/nfs/etab
170 %config(noreplace) %{_localstatedir}/lib/nfs/rmtab
171 %config(noreplace) %{_sysconfdir}/request-key.d/id_resolver.conf
172 %config(noreplace) %{_sysconfdir}/modprobe.d/lockd.conf
173 %config(noreplace) %{_sysconfdir}/nfsmount.conf
174 %config(noreplace) %{_sysconfdir}/nfs.conf
175 %config(noreplace) %{_sysconfdir}/gssproxy/24-nfs-server.conf
176 %config(noreplace) /usr/lib/udev/rules.d/60-nfs.rules
177 %config(noreplace) %{_sysconfdir}/nfsmount.conf.d/10-nfsv4.conf
178 %{_unitdir}/*
179 %{_prefix}/lib/systemd/system-generators/*
180 %{_sbindir}/exportfs
181 %{_sbindir}/nfsstat
182 %{_sbindir}/rpcdebug
183 %{_sbindir}/rpcctl
184 %{_sbindir}/rpc.mountd
185 %{_sbindir}/rpc.nfsd
186 %{_sbindir}/showmount
187 %{_sbindir}/rpc.idmapd
188 %{_sbindir}/rpc.gssd
189 %{_sbindir}/sm-notify
190 %{_sbindir}/start-statd
191 %{_sbindir}/mountstats
192 %{_sbindir}/nfsiostat
193 %{_sbindir}/nfsidmap
194 %{_sbindir}/blkmapd
195 %{_sbindir}/nfsconf
196 %{_sbindir}/nfsref
197 %{_sbindir}/nfsdcld
198 %{_sbindir}/nfsdclddb
199 %{_sbindir}/nfsdclnts
200 %{_sbindir}/fsidd
201 %{_libexecdir}/nfsrahead
202 %{_udevrulesdir}/99-nfs.rules
203 %attr(4755,root,root) /sbin/mount.nfs
204 /sbin/rpc.statd
205 /sbin/nfsdcltrack
206 /sbin/mount.nfs4
207 /sbin/umount.nfs
208 /sbin/umount.nfs4
209 %{_mandir}/man5/exports.5*
210 %{_mandir}/man5/nfs.5*
211 %{_mandir}/man5/nfs.conf.5*
212 %{_mandir}/man5/nfsrahead.5.*
213 %{_mandir}/man5/nfsmount.conf.5*
214 %{_mandir}/man7/nfsd.7*
215 %{_mandir}/man7/nfs.systemd.7*
216 %{_mandir}/man8/exportfs.8*
217 %{_mandir}/man8/mountd.8*
218 %{_mandir}/man8/nfsd.8*
219 %{_mandir}/man8/rpc.mountd.8*
220 %{_mandir}/man8/rpc.nfsd.8*
221 %{_mandir}/man8/mount.nfs.8*
222 %{_mandir}/man8/nfsconf.8*
223 %{_mandir}/man8/nfsref.8*
224 %{_mandir}/man8/rpc.sm-notify.8*
225 %{_mandir}/man8/sm-notify.8*
226 %{_mandir}/man8/umount.nfs.8*
227 %{_mandir}/man8/rpc.statd.8*
228 %{_mandir}/man8/statd.8*
229 %{_mandir}/man8/showmount.8*
230 %{_mandir}/man8/nfsstat.8*
231 %{_mandir}/man8/rpcdebug.8*
232 %{_mandir}/man8/mountstats.8*
233 %{_mandir}/man8/nfsiostat.8*
234 %{_mandir}/man8/nfsidmap.8*
235 %{_mandir}/man8/blkmapd.8*
236 %{_mandir}/man8/rpc.gssd.8*
237 %{_mandir}/man8/rpc.idmapd.8*
238 %{_mandir}/man8/gssd.8*
239 %{_mandir}/man8/idmapd.8*
240 %{_mandir}/man8/nfsdcltrack.8*
241 %{_mandir}/man8/nfsdcld.8*
242 %{_mandir}/man8/nfsdclddb.8*
243 %{_mandir}/man8/nfsdclnts.8*
244 %{_mandir}/man8/rpcctl.8*
245
246
247 %files -n %{libname}
248 %doc support/nfsidmap/AUTHORS support/nfsidmap/README support/nfsidmap/COPYING
249 %config(noreplace) %{_sysconfdir}/idmapd.conf
250 %{_libdir}/libnfsidmap.so.*
251 %{_libdir}/libnfsidmap/*.so
252 %{_mandir}/man3/nfs4_uid_to_name.*
253 %{_mandir}/man5/idmapd.conf.*
254
255 %files -n %{devname}
256 %{_libdir}/pkgconfig/libnfsidmap.pc
257 %{_includedir}/nfsidmap.h
258 %{_includedir}/nfsidmap_plugin.h
259 %{_libdir}/libnfsidmap.so
260

  ViewVC Help
Powered by ViewVC 1.1.30