/[packages]/cauldron/obm-satellite/current/SPECS/obm-satellite.spec
ViewVC logotype

Annotation of /cauldron/obm-satellite/current/SPECS/obm-satellite.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 398268 - (hide annotations) (download)
Wed Feb 13 21:14:56 2013 UTC (11 years, 2 months ago) by neoclust
File size: 5213 byte(s)
imported package obm-satellite
1 neoclust 398268 %define obm_version 2.4.2.1
2     Name: obm-satellite
3     Version: %{obm_version}
4     Release: %mkrel 1
5     Summary: Integration of OBM with Cyrus and Postfix
6     Group: Development/Other
7     License: AGPLv3
8     URL: http://www.obm.org
9     # http://git.obm.org/obm
10     # satelitte
11     Source0: %{name}-%{version}.tar.gz
12     Source1: obm-satellite.sh
13     Source2: cyrusPartition
14     BuildARch: noarch
15     Requires: obm-config
16     Requires: perl-ObmSatellite = %{version}-%{release}
17     Requires(post): chkconfig
18     Requires(preun):chkconfig
19     Requires(preun):initscripts
20     Requires: obm-cert
21    
22    
23     %description
24     This package contains a daemon which manages Cyrus partitions and Postfix maps
25     for OBM. This package needs to be installed on each server containing
26     obm-postfix or obm-cyrus.
27    
28     OBM is a global groupware, messaging and CRM application. It is intended to
29     be an Exchange Or Notes/Domino Mail replacement, but can also be used as a
30     simple contact database. OBM also features integration with PDAs, smart phones,
31     Mozilla Thunderbird/Lightning and Microsoft Outlook via specific connectors.
32    
33    
34    
35     %package -n perl-ObmSatellite
36     Summary: Library for the integration of OBM with Cyrus and Postfix
37     Group: Development/Libraries
38     License: AGPLv3
39    
40     BuildArch: noarch
41     BuildRequires: perl(ExtUtils::MakeMaker)
42     # FIXME: Should they be removed ( added automatically by rpm ?)
43     Requires: perl(Net::LDAP)
44     Requires: perl(Net::CIDR)
45     Requires: perl(Net::Server)
46     Requires: perl(Class::Singleton)
47     Requires: perl(Digest::SHA)
48     Requires: perl(Time::HiRes)
49     Requires: perl(Config::IniFiles)
50    
51     %description -n perl-ObmSatellite
52     This package contains the library used by obm-satellite to interact with Cyrus
53     and Postfix.
54    
55     OBM is a global groupware, messaging and CRM application. It is intended to
56     be an Exchange Or Notes/Domino Mail replacement, but can also be used as a
57     simple contact database. OBM also features integration with PDAs, smart phones,
58     Mozilla Thunderbird/Lightning and Microsoft Outlook via specific connectors.
59    
60    
61    
62     %prep
63     %setup -q -n %{name}-%{version}
64    
65     %build
66     cd libperl-ObmSatellite
67     # Pass perl_vendorlib explicitly, this allows us to redefine it when we're not
68     # building on RedHat/CentOS
69     perl Makefile.PL INSTALLDIRS=vendor INSTALLVENDORLIB=%{perl_vendorlib}
70     cd -
71    
72     %install
73     #ALL
74     rm -rf $RPM_BUILD_ROOT
75    
76     #libperl stuff
77     cd libperl-ObmSatellite
78     make install PERL_INSTALL_ROOT=$RPM_BUILD_ROOT
79     cd -
80    
81     #Remove unneeded stuff
82     find $RPM_BUILD_ROOT -type f -name .packlist -exec rm -f {} ';'
83    
84     #obm-satellite
85     mkdir -p $RPM_BUILD_ROOT%{_bindir}
86     mkdir -p $RPM_BUILD_ROOT%{_sbindir}
87     mkdir -p $RPM_BUILD_ROOT%{_datadir}/obm-satellite
88     mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/init.d
89     mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/obm-satellite
90     mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/obm-satellite/mods-available
91     mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/obm-satellite/mods-enabled
92     mkdir -p $RPM_BUILD_ROOT%{_localstatedir}/log/obm-satellite
93     install -p -m 755 obmSatellite.pl $RPM_BUILD_ROOT%{_datadir}/obm-satellite
94     install -p -m 755 init-obmSatellite.sample $RPM_BUILD_ROOT%{_sysconfdir}/init.d/obmSatellite
95     install -p -m 600 obmSatellite.ini.sample $RPM_BUILD_ROOT%{_sysconfdir}/obm-satellite/obmSatellite.ini
96     install -p -m 755 %{SOURCE1} $RPM_BUILD_ROOT%{_bindir}/obm-satellite
97     install -p -m 755 osdismod $RPM_BUILD_ROOT%{_sbindir}/
98     install -p -m 755 osenmod $RPM_BUILD_ROOT%{_sbindir}/
99     mkdir -p $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d
100     install -p -m 640 doc/conf/logrotate.obm-satellite.sample $RPM_BUILD_ROOT%{_sysconfdir}/logrotate.d/obm-satellite
101    
102    
103     #postfix configuration file
104     install -p -m 755 mods-available/postfixSmtpInMaps $RPM_BUILD_ROOT%{_sysconfdir}/obm-satellite/mods-available
105     install -p -m 755 mods-available/postfixAccess $RPM_BUILD_ROOT%{_sysconfdir}/obm-satellite/mods-available
106     #Cyrus configuration file
107     install -p -m 755 %{SOURCE2} $RPM_BUILD_ROOT%{_sysconfdir}/obm-satellite/mods-available
108     #backupEntity configuration file
109     install -p -m 755 mods-available/backupEntity $RPM_BUILD_ROOT%{_sysconfdir}/obm-satellite/mods-available
110    
111     %clean
112     rm -rf $RPM_BUILD_ROOT
113    
114     %post -n obm-satellite
115     %_post_service obmSatellite
116    
117     %preun -n obm-satellite
118     %_preun_service obmSatellite
119    
120     %post -n perl-ObmSatellite
121     perl -MXML::SAX -e "XML::SAX->add_parser(q(XML::SAX::PurePerl))->save_parsers()"
122    
123     %files -n perl-ObmSatellite
124     %defattr(-,root,root,-)
125     %{perl_vendorlib}/ObmSatellite
126     %{_mandir}/man3/ObmSatellite*
127    
128     %files -n obm-satellite
129     %defattr(-,root,root,-)
130     %{_bindir}/obm-satellite
131     %{_sbindir}/osdismod
132     %{_sbindir}/osenmod
133     %{_datadir}/obm-satellite
134     %{_localstatedir}/log/obm-satellite
135     %config(noreplace) %{_sysconfdir}/obm-satellite/obmSatellite.ini
136     %config(noreplace) %{_sysconfdir}/obm-satellite/mods-available/postfixSmtpInMaps
137     %config(noreplace) %{_sysconfdir}/obm-satellite/mods-available/postfixAccess
138     %config(noreplace) %{_sysconfdir}/obm-satellite/mods-available/cyrusPartition
139     %config(noreplace) %{_sysconfdir}/obm-satellite/mods-available/backupEntity
140     %{_sysconfdir}/obm-satellite/mods-enabled
141     %{_sysconfdir}/init.d/obmSatellite
142     %config(noreplace) %{_sysconfdir}/logrotate.d/obm-satellite
143    

  ViewVC Help
Powered by ViewVC 1.1.30