/[packages]/cauldron/ocaml-dose3/current/SPECS/ocaml-dose3.spec
ViewVC logotype

Contents of /cauldron/ocaml-dose3/current/SPECS/ocaml-dose3.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 338248 - (show annotations) (download)
Thu Jan 3 16:30:06 2013 UTC (11 years, 3 months ago) by malo
File size: 4247 byte(s)
SILENT: add missing BR to camlp4-devel
1 %define oname dose3
2 %define name ocaml-%{oname}
3 %define version 3.1.3
4 %define release %mkrel 1
5
6 Summary: Framework for managing distribution packages and their dependencies
7 Name: %{name}
8 Version: %{version}
9 Release: %{release}
10 Source0: http://gforge.inria.fr/frs/download.php/31681/%{oname}-%{version}.tar.gz
11 Patch0: dose3-3.0.2-fix-ocamlbuild-for-pack-in-ocaml-4.0.patch
12 License: LGPLv2 with linking exception
13 Group: Development/OCaml
14 Url: http://www.mancoosi.org/software/
15
16 BuildRequires: ocaml-compiler
17 BuildRequires: ocaml-findlib
18 BuildRequires: ocaml-extlib-devel
19 BuildRequires: ocaml-pcre-devel
20 BuildRequires: camlp4-devel
21 # BuildRequires: ocaml-sqlite-devel ocaml-json-static
22 BuildRequires: ocaml-camlbz2-devel
23 BuildRequires: ocaml-camlzip-devel
24 BuildRequires: ocaml-expat-devel
25 BuildRequires: ocaml-benchmark-devel
26 BuildRequires: ocaml-ocamlgraph-devel
27 BuildRequires: ocaml-curl-devel
28 BuildRequires: ocaml-xml-light-devel
29 BuildRequires: ocaml-ounit-devel
30 BuildRequires: librpm-devel
31 BuildRequires: ocaml-cudf-devel
32 BuildRequires: curl-devel
33 Requires: ocaml-extlib
34 Requires: ocaml-pcre
35 Requires: ocaml-camlbz2-devel
36 Requires: ocaml-camlzip-devel
37 Requires: ocaml-expat
38 Requires: ocaml-curl
39 Requires: ocaml-ounit
40 Requires: ocaml-ocamlgraph
41 Requires: ocaml-cudf
42 Requires: librpm-devel
43
44
45 %description
46 Dose3 is a framework made of several OCaml libraries for
47 managing distribution packages and their dependencies.
48
49 Though not tied to any particular distribution, dose3 constitutes a pool of
50 libraries which enable analyzing packages coming from various
51 distributions.
52
53 Besides basic functionalities for querying and setting package properties,
54 dose3 also implements algorithms for solving more complex problems
55 (monitoring package evolutions, correct and complete dependency resolution,
56 repository-wide uninstallability checks).
57
58 %package devel
59 Summary: Development files for %{name}
60 Group: Development/OCaml
61 Requires: %{name} = %{version}-%{release}
62
63 %description devel
64 The %{name}-devel package contains libraries and signature files for
65 developing applications that use %{name}.
66 Requires: ocaml-extlib-devel
67 Requires: ocaml-pcre-devel
68 Requires: ocaml-expat-devel
69 Requires: ocaml-curl-devel
70 Requires: ocaml-ounit-devel
71 Requires: ocaml-ocamlgraph-devel
72 Requires: ocaml-cudf-devel
73
74
75 %prep
76 %setup -q -n %{oname}-%{version}
77 %patch0 -p1
78
79 %build
80 ./configure --libdir=%{_libdir} \
81 --with-xml \
82 --with-curl \
83 --with-ocamlgraph \
84 --with-zip \
85 --with-oUnit \
86 --with-bz2 \
87 --with-rpm4
88 # --with-sqlite \
89 make
90
91 %check
92 # Tests fail for some reason
93 # make test
94
95 %install
96 make install LIBDIR=%{buildroot}/%{_libdir}/ocaml BINDIR=%{buildroot}/%{_bindir}
97 rm -f %{buildroot}/%{_libdir}/ocaml/dose3/*.{cm,}o
98 rm -f %{buildroot}/%{_libdir}/ocaml/dose3/*.ml{.depends,}
99 cd doc/manpages
100 for man in *.?; do
101 install -m644 $man -D %{buildroot}%{_mandir}/man1/$man
102 done
103 cd ../..
104 cp META %{buildroot}%{_libdir}/ocaml/dose3
105
106 # Fix dangling links
107 rm -f %{buildroot}%{_bindir}/rpmcheck
108 rm -f %{buildroot}%{_bindir}/debcheck
109 rm -f %{buildroot}%{_bindir}/eclipsecheck
110 ln -s %{_bindir}/distcheck %{buildroot}%{_bindir}/rpmcheck
111 ln -s %{_bindir}/distcheck %{buildroot}%{_bindir}/debcheck
112 ln -s %{_bindir}/distcheck %{buildroot}%{_bindir}/eclipsecheck
113
114 %files
115 %dir %{_libdir}/ocaml/dose3
116 %doc COPYING
117 %{_bindir}/apt-cudf
118 %{_bindir}/ceve
119 %{_bindir}/challenged
120 %{_bindir}/debcheck
121 %{_bindir}/dominators-graph
122 %{_bindir}/rpmcheck
123 %{_bindir}/outdated
124 %{_bindir}/eclipsecheck
125 %{_bindir}/deb-buildcheck
126 %{_bindir}/distcheck
127 %{_bindir}/smallworld
128 %{_bindir}/strong-deps
129 %{_mandir}/man1/apt-cudf.1*
130 %{_mandir}/man1/apt-cudf-get.8*
131 %{_mandir}/man1/apt-cudf.conf.5*
132 %{_mandir}/man1/ceve.1*
133 %{_mandir}/man1/buildcheck.1*
134 %{_mandir}/man1/distcheck.1*
135 %{_mandir}/man1/outdated.1*
136 %{_mandir}/man1/challenged.1*
137 %{_mandir}/man1/strongdeps.1*
138 %{_mandir}/man1/smallworld.1*
139 %{_libdir}/ocaml/dose3/META
140 %{_libdir}/ocaml/dose3/*.cma
141 %{_libdir}/ocaml/dose3/*.cmi
142 %{_libdir}/ocaml/dose3/*.cmxs
143 %{_libdir}/ocaml/stublibs/*.so*
144
145 %files devel
146 %doc README.architecture TODO
147 %{_libdir}/ocaml/dose3/*.a
148 %{_libdir}/ocaml/dose3/*.cmxa
149 %{_libdir}/ocaml/dose3/*.mli

  ViewVC Help
Powered by ViewVC 1.1.30