1 |
blue_prawn |
406791 |
Name: ocaml-markdown |
2 |
|
|
Version: 0.1.0 |
3 |
umeabot |
523828 |
Release: %mkrel 2 |
4 |
blue_prawn |
406791 |
Summary: Markdown processor written in OCaml |
5 |
|
|
License: MIT |
6 |
|
|
Group: Development/OCaml |
7 |
|
|
URL: https://forge.ocamlcore.org/projects/ocaml-markdown/ |
8 |
|
|
Source0: http://download.ocamlcore.org/ocaml-markdown/ocaml-markdown/%{version}/ocaml-markdown-%{version}.tar.gz |
9 |
|
|
Patch0: ocaml-markdown-0.1.0-ocsigen.xhtml-to-tyxml.patch |
10 |
|
|
BuildRequires: ocaml-findlib |
11 |
|
|
BuildRequires: ocaml-extlib-devel |
12 |
|
|
BuildRequires: ocaml-sexplib-devel |
13 |
|
|
BuildRequires: ocaml-ounit-devel |
14 |
|
|
BuildRequires: ocaml-tyxml-devel |
15 |
|
|
Requires: ocaml-extlib |
16 |
|
|
Requires: ocaml-sexplib |
17 |
|
|
Requires: ocaml-tyxml |
18 |
|
|
|
19 |
|
|
%description |
20 |
|
|
Markdown processor written in OCaml. |
21 |
|
|
|
22 |
|
|
%package devel |
23 |
|
|
Summary: Development files for %{name} |
24 |
|
|
Group: Development/OCaml |
25 |
|
|
Requires: %{name} = %{version}-%{release} |
26 |
|
|
Requires: ocaml-extlib-devel |
27 |
|
|
Requires: ocaml-sexplib-devel |
28 |
|
|
Requires: ocaml-tyxml-devel |
29 |
|
|
|
30 |
|
|
%description devel |
31 |
|
|
The %{name}-devel package contains libraries for developing applications |
32 |
|
|
that use %{name}. |
33 |
|
|
|
34 |
|
|
%prep |
35 |
|
|
%setup -q |
36 |
|
|
%patch0 -p1 |
37 |
|
|
|
38 |
|
|
%build |
39 |
|
|
./configure --prefix %{prefix} |
40 |
|
|
make |
41 |
|
|
|
42 |
|
|
%check |
43 |
|
|
make test |
44 |
|
|
|
45 |
|
|
%install |
46 |
|
|
rm -rf %{buildroot} |
47 |
|
|
export DESTDIR=%{buildroot} |
48 |
|
|
export OCAMLFIND_DESTDIR=%{buildroot}/%{_libdir}/ocaml |
49 |
|
|
mkdir -p $OCAMLFIND_DESTDIR/markdown |
50 |
|
|
make install |
51 |
|
|
|
52 |
|
|
%files |
53 |
|
|
%doc README.txt AUTHORS.txt |
54 |
|
|
%dir %{_libdir}/ocaml/markdown |
55 |
|
|
%{_libdir}/ocaml/markdown/META |
56 |
|
|
%{_libdir}/ocaml/markdown/*.cmi |
57 |
|
|
%{_libdir}/ocaml/markdown/*.cma |
58 |
|
|
%{_libdir}/ocaml/markdown/*.cmxs |
59 |
|
|
|
60 |
|
|
%files devel |
61 |
|
|
%doc test/ |
62 |
|
|
%{_libdir}/ocaml/markdown/*.a |
63 |
|
|
%{_libdir}/ocaml/markdown/*.cmxa |
64 |
|
|
%{_libdir}/ocaml/markdown/*.cmx |
65 |
|
|
%{_libdir}/ocaml/markdown/Markdown.ml |
66 |
|
|
%{_libdir}/ocaml/markdown/MarkdownHTML.ml |