1 |
Name: ocaml-rdf |
2 |
Version: 0.6.0 |
3 |
Release: %mkrel 3 |
4 |
Summary: Handling RDF graphs |
5 |
License: LGPL |
6 |
Group: Development/OCaml |
7 |
URL: http://zoggy.github.io/ocaml-rdf/ |
8 |
Source0: http://zoggy.github.io/ocaml-rdf/ocaml-rdf-%{version}.tar.gz |
9 |
BuildRequires: ocaml-findlib |
10 |
BuildRequires: ocaml-ocamlnet-devel |
11 |
BuildRequires: ocaml-mysql-devel |
12 |
BuildRequires: ocaml-xmlm-devel |
13 |
BuildRequires: ocaml-postgresql-devel |
14 |
BuildRequires: camlp4 |
15 |
BuildRequires: menhir |
16 |
BuildRequires: ocaml-ulex-devel |
17 |
BuildRequires: ocaml-cryptokit-devel |
18 |
Requires: ocaml-ocamlnet |
19 |
Requires: ocaml-mysql |
20 |
Requires: ocaml-xmlm |
21 |
Requires: ocaml-postgresql |
22 |
Requires: ocaml-ulex |
23 |
Requires: ocaml-cryptokit |
24 |
|
25 |
%description |
26 |
OCaml-RDF is an OCaml library to manipulate RDF graphs. |
27 |
|
28 |
Implemented features: |
29 |
* Two storages available: in memory or in a MySQL database, |
30 |
* Ability to define your own storages, |
31 |
* Transactions, |
32 |
* Importing from and exporting to RDF/XML format. |
33 |
|
34 |
%package devel |
35 |
Summary: Development files for %{name} |
36 |
Group: Development/OCaml |
37 |
Requires: %{name} = %{version}-%{release} |
38 |
Requires: ocaml-ocamlnet-devel |
39 |
Requires: ocaml-mysql-devel |
40 |
Requires: ocaml-xmlm-devel |
41 |
Requires: ocaml-postgresql-devel |
42 |
Requires: ocaml-ulex-devel |
43 |
Requires: ocaml-cryptokit-devel |
44 |
|
45 |
%description devel |
46 |
The %{name}-devel package contains libraries and signature files for |
47 |
developing applications that use %{name}. |
48 |
|
49 |
%prep |
50 |
%setup -q |
51 |
|
52 |
%build |
53 |
./configure --prefix %{_prefix} |
54 |
make all |
55 |
make doc |
56 |
mv src/ocamldoc apidoc |
57 |
|
58 |
%install |
59 |
rm -rf %{buildroot} |
60 |
export DESTDIR=%{buildroot} |
61 |
export OCAMLFIND_DESTDIR=%{buildroot}/%{_libdir}/ocaml |
62 |
mkdir -p $OCAMLFIND_DESTDIR/rdf |
63 |
|
64 |
make install |
65 |
|
66 |
%files |
67 |
%doc README LICENSE |
68 |
%dir %{_libdir}/ocaml/rdf |
69 |
%{_libdir}/ocaml/rdf/META |
70 |
%{_libdir}/ocaml/rdf/*.cmi |
71 |
%{_libdir}/ocaml/rdf/*.cma |
72 |
%{_libdir}/ocaml/rdf/*.cmxs |
73 |
|
74 |
%files devel |
75 |
%doc apidoc/ |
76 |
%{_libdir}/ocaml/rdf/*.a |
77 |
%{_libdir}/ocaml/rdf/*.cmxa |
78 |
%{_libdir}/ocaml/rdf/*.cmx |