1 |
blue_prawn |
411477 |
Name: ocaml-rope |
2 |
|
|
Version: 0.5 |
3 |
|
|
Release: %mkrel 1 |
4 |
|
|
Summary: Ropes ("heavyweight strings") |
5 |
|
|
License: LGPL-2.1 with OCaml linking exception |
6 |
|
|
Group: Development/OCaml |
7 |
|
|
URL: http://rope.forge.ocamlcore.org/ |
8 |
|
|
Source0: http://download.ocamlcore.org/rope/rope/%{version}/rope-%{version}.tar.gz |
9 |
|
|
BuildRequires: ocaml-findlib |
10 |
|
|
|
11 |
|
|
%description |
12 |
|
|
Ropes are a scalable string implementation: they are designed for efficient |
13 |
|
|
operation that involve the string as a whole such as concatenation and |
14 |
|
|
substring. This library implements ropes for OCaml (it is rich enough to |
15 |
|
|
replace strings). |
16 |
|
|
|
17 |
|
|
%package devel |
18 |
|
|
Summary: Development files for %{name} |
19 |
|
|
Group: Development/OCaml |
20 |
|
|
Requires: %{name} = %{version}-%{release} |
21 |
|
|
|
22 |
|
|
%description devel |
23 |
|
|
This package contains the development modules you need to use %{name} in |
24 |
|
|
your programs. |
25 |
|
|
|
26 |
|
|
%prep |
27 |
|
|
%setup -q -n rope-%{version} |
28 |
|
|
|
29 |
|
|
%build |
30 |
|
|
ocaml setup.ml -configure \ |
31 |
|
|
--prefix %{_prefix} \ |
32 |
|
|
--libdir %{_libdir} \ |
33 |
|
|
--libexecdir %{_libexecdir} \ |
34 |
|
|
--exec-prefix %{_exec_prefix} \ |
35 |
|
|
--bindir %{_bindir} \ |
36 |
|
|
--sbindir %{_sbindir} \ |
37 |
|
|
--mandir %{_mandir} \ |
38 |
|
|
--datadir %{_datadir} \ |
39 |
|
|
--localstatedir %{_localstatedir} \ |
40 |
|
|
--docdir %{_docdir}/%{name}-devel/ \ |
41 |
|
|
--destdir %{buildroot} |
42 |
|
|
|
43 |
|
|
make |
44 |
|
|
make doc |
45 |
|
|
|
46 |
|
|
%install |
47 |
|
|
rm -rf %{buildroot} |
48 |
|
|
export DESTDIR=%{buildroot} |
49 |
|
|
export OCAMLFIND_DESTDIR=%{buildroot}/%{_libdir}/ocaml |
50 |
|
|
mkdir -p $OCAMLFIND_DESTDIR/rope |
51 |
|
|
make install |
52 |
|
|
|
53 |
|
|
%files |
54 |
|
|
%doc README.txt LICENSE AUTHORS.txt |
55 |
|
|
%dir %{_libdir}/ocaml/rope |
56 |
|
|
%{_libdir}/ocaml/rope/META |
57 |
|
|
%{_libdir}/ocaml/rope/*.cmi |
58 |
|
|
%{_libdir}/ocaml/rope/*.cma |
59 |
|
|
%{_libdir}/ocaml/rope/*.cmxs |
60 |
|
|
|
61 |
|
|
%files devel |
62 |
|
|
%doc bench/ |
63 |
|
|
%{_docdir}/%{name}-devel |
64 |
|
|
%{_libdir}/ocaml/rope/*.a |
65 |
|
|
%{_libdir}/ocaml/rope/*.cmxa |
66 |
|
|
%{_libdir}/ocaml/rope/*.cmx |
67 |
|
|
%{_libdir}/ocaml/rope/*.mli |