1 |
blue_prawn |
411477 |
Name: ocaml-rope |
2 |
|
|
Version: 0.5 |
3 |
|
|
Release: %mkrel 1 |
4 |
|
|
Summary: Ropes ("heavyweight strings") |
5 |
|
|
License: LGPL-2.1 with OCaml linking exception |
6 |
|
|
Group: Development/OCaml |
7 |
|
|
URL: http://rope.forge.ocamlcore.org/ |
8 |
|
|
Source0: http://download.ocamlcore.org/rope/rope/%{version}/rope-%{version}.tar.gz |
9 |
|
|
BuildRequires: ocaml-findlib |
10 |
blue_prawn |
412000 |
BuildRequires: ocaml-benchmark |
11 |
blue_prawn |
411477 |
|
12 |
|
|
%description |
13 |
|
|
Ropes are a scalable string implementation: they are designed for efficient |
14 |
|
|
operation that involve the string as a whole such as concatenation and |
15 |
|
|
substring. This library implements ropes for OCaml (it is rich enough to |
16 |
|
|
replace strings). |
17 |
|
|
|
18 |
|
|
%package devel |
19 |
|
|
Summary: Development files for %{name} |
20 |
|
|
Group: Development/OCaml |
21 |
|
|
Requires: %{name} = %{version}-%{release} |
22 |
|
|
|
23 |
|
|
%description devel |
24 |
|
|
This package contains the development modules you need to use %{name} in |
25 |
|
|
your programs. |
26 |
|
|
|
27 |
|
|
%prep |
28 |
|
|
%setup -q -n rope-%{version} |
29 |
|
|
|
30 |
|
|
%build |
31 |
|
|
ocaml setup.ml -configure \ |
32 |
|
|
--prefix %{_prefix} \ |
33 |
|
|
--libdir %{_libdir} \ |
34 |
|
|
--libexecdir %{_libexecdir} \ |
35 |
|
|
--exec-prefix %{_exec_prefix} \ |
36 |
|
|
--bindir %{_bindir} \ |
37 |
|
|
--sbindir %{_sbindir} \ |
38 |
|
|
--mandir %{_mandir} \ |
39 |
|
|
--datadir %{_datadir} \ |
40 |
|
|
--localstatedir %{_localstatedir} \ |
41 |
|
|
--docdir %{_docdir}/%{name}-devel/ \ |
42 |
|
|
--destdir %{buildroot} |
43 |
|
|
|
44 |
|
|
make |
45 |
|
|
make doc |
46 |
|
|
|
47 |
|
|
%install |
48 |
|
|
rm -rf %{buildroot} |
49 |
|
|
export DESTDIR=%{buildroot} |
50 |
|
|
export OCAMLFIND_DESTDIR=%{buildroot}/%{_libdir}/ocaml |
51 |
|
|
mkdir -p $OCAMLFIND_DESTDIR/rope |
52 |
|
|
make install |
53 |
|
|
|
54 |
|
|
%files |
55 |
|
|
%doc README.txt LICENSE AUTHORS.txt |
56 |
|
|
%dir %{_libdir}/ocaml/rope |
57 |
|
|
%{_libdir}/ocaml/rope/META |
58 |
|
|
%{_libdir}/ocaml/rope/*.cmi |
59 |
|
|
%{_libdir}/ocaml/rope/*.cma |
60 |
|
|
%{_libdir}/ocaml/rope/*.cmxs |
61 |
|
|
|
62 |
|
|
%files devel |
63 |
|
|
%doc bench/ |
64 |
|
|
%{_docdir}/%{name}-devel |
65 |
|
|
%{_libdir}/ocaml/rope/*.a |
66 |
|
|
%{_libdir}/ocaml/rope/*.cmxa |
67 |
|
|
%{_libdir}/ocaml/rope/*.cmx |
68 |
|
|
%{_libdir}/ocaml/rope/*.mli |