1 |
jquelin |
10266 |
%define upstream_name Coro |
2 |
|
|
%define upstream_version 5.25 |
3 |
jquelin |
36947 |
|
4 |
|
|
%define _requires_exceptions perl(Exporter::)\\|perl(Coro::Socket::) |
5 |
jquelin |
10266 |
#define _without_check 1 |
6 |
|
|
|
7 |
|
|
Name: perl-%{upstream_name} |
8 |
|
|
Version: %perl_convert_version %upstream_version |
9 |
|
|
Release: %mkrel 1 |
10 |
|
|
Epoch: 2 |
11 |
|
|
|
12 |
|
|
Summary: Coroutine process abstraction |
13 |
|
|
License: GPL+ or Artistic |
14 |
|
|
Group: Development/Perl |
15 |
|
|
Url: http://search.cpan.org/dist/%{upstream_name} |
16 |
|
|
Source0: http://search.cpan.org/CPAN/authors/id/M/ML/MLEHMANN/%{upstream_name}-%{upstream_version}.tar.gz |
17 |
|
|
|
18 |
|
|
BuildRequires: perl-AnyEvent >= 1:4.05 |
19 |
|
|
BuildRequires: perl-common-sense |
20 |
jquelin |
37010 |
BuildRequires: perl-devel |
21 |
jquelin |
36947 |
BuildRequires: perl-EV >= 2.0 |
22 |
jquelin |
37010 |
BuildRequires: perl-Guard |
23 |
|
|
BuildRequires: perl-IO-AIO |
24 |
jquelin |
10266 |
|
25 |
|
|
%description |
26 |
|
|
This module collection manages coroutines. Coroutines are similar to |
27 |
|
|
threads but don't run in parallel. |
28 |
|
|
|
29 |
|
|
|
30 |
|
|
%package AnyEvent |
31 |
|
|
Summary: Use Coro within an AnyEvent environment |
32 |
|
|
Group: Development/Perl |
33 |
|
|
|
34 |
|
|
%description AnyEvent |
35 |
|
|
This module integrates coroutines into any event loop supported by |
36 |
|
|
AnyEvent, combining event-based programming with coroutine-based |
37 |
|
|
programming in a natural way. |
38 |
|
|
|
39 |
|
|
%package BDB |
40 |
|
|
Summary: Truly asynchronous bdb access |
41 |
|
|
Group: Development/Perl |
42 |
|
|
|
43 |
|
|
%description BDB |
44 |
|
|
This module implements a thin wrapper around the BDB module. |
45 |
|
|
|
46 |
|
|
Each BDB request that could block and doesn't get passed a callback |
47 |
|
|
will normally block all coroutines. after loading this module, this |
48 |
|
|
will no longer be the case. |
49 |
|
|
|
50 |
jquelin |
36947 |
%package EV |
51 |
|
|
Summary: Use Coro within an EV environment |
52 |
|
|
Group: Development/Perl |
53 |
jquelin |
10266 |
|
54 |
jquelin |
36947 |
%description EV |
55 |
|
|
This module integrates coroutines into any event loop supported by EV, |
56 |
|
|
combining event-based programming with coroutine-based programming in a |
57 |
|
|
natural way. |
58 |
|
|
|
59 |
|
|
|
60 |
jquelin |
10266 |
%prep |
61 |
|
|
%setup -q -n %{upstream_name}-%{upstream_version} |
62 |
jquelin |
37010 |
# remove failing test - http://rt.cpan.org/Ticket/Display.html?id=32475 |
63 |
|
|
rm EV/t/01_unblock.t |
64 |
jquelin |
10266 |
|
65 |
|
|
%build |
66 |
|
|
echo -e "n\nu\n" | %{__perl} Makefile.PL INSTALLDIRS=vendor |
67 |
|
|
%make |
68 |
|
|
|
69 |
|
|
%check |
70 |
|
|
%{!?_without_check:make test} |
71 |
|
|
|
72 |
|
|
%install |
73 |
|
|
rm -rf $RPM_BUILD_ROOT |
74 |
|
|
%makeinstall_std |
75 |
|
|
|
76 |
|
|
|
77 |
|
|
%clean |
78 |
|
|
rm -rf $RPM_BUILD_ROOT |
79 |
|
|
|
80 |
|
|
%files |
81 |
|
|
%defattr(-,root,root) |
82 |
jquelin |
33648 |
%doc README.linux-glibc README Changes META.yml |
83 |
jquelin |
10266 |
%dir %{perl_vendorarch}/Coro |
84 |
|
|
%{perl_vendorarch}/Coro/AIO.pm |
85 |
|
|
%{perl_vendorarch}/Coro/Channel.pm |
86 |
|
|
%{perl_vendorarch}/Coro/CoroAPI.h |
87 |
|
|
%{perl_vendorarch}/Coro/Debug.pm |
88 |
|
|
%{perl_vendorarch}/Coro/Event.pm |
89 |
|
|
%{perl_vendorarch}/Coro/Handle.pm |
90 |
|
|
%{perl_vendorarch}/Coro/Intro.pod |
91 |
|
|
%{perl_vendorarch}/Coro/LWP.pm |
92 |
|
|
%{perl_vendorarch}/Coro/MakeMaker.pm |
93 |
|
|
%{perl_vendorarch}/Coro/RWLock.pm |
94 |
|
|
%{perl_vendorarch}/Coro/Select.pm |
95 |
|
|
%{perl_vendorarch}/Coro/Semaphore.pm |
96 |
|
|
%{perl_vendorarch}/Coro/SemaphoreSet.pm |
97 |
|
|
%{perl_vendorarch}/Coro/Signal.pm |
98 |
|
|
%{perl_vendorarch}/Coro/Socket.pm |
99 |
|
|
%{perl_vendorarch}/Coro/Specific.pm |
100 |
|
|
%{perl_vendorarch}/Coro/State.pm |
101 |
|
|
%{perl_vendorarch}/Coro/Storable.pm |
102 |
|
|
%{perl_vendorarch}/Coro/Timer.pm |
103 |
|
|
%{perl_vendorarch}/Coro/Util.pm |
104 |
|
|
%{perl_vendorarch}/Coro.pm |
105 |
|
|
%{perl_vendorarch}/auto |
106 |
|
|
%_mandir/man3/Coro.3pm* |
107 |
|
|
%_mandir/man3/Coro::AIO.3pm* |
108 |
|
|
%_mandir/man3/Coro::Channel.3pm* |
109 |
|
|
%_mandir/man3/Coro::Debug.3pm* |
110 |
|
|
%_mandir/man3/Coro::Event.3pm* |
111 |
|
|
%_mandir/man3/Coro::Handle.3pm* |
112 |
|
|
%_mandir/man3/Coro::Intro.3pm* |
113 |
|
|
%_mandir/man3/Coro::LWP.3pm* |
114 |
|
|
%_mandir/man3/Coro::MakeMaker.3pm* |
115 |
|
|
%_mandir/man3/Coro::RWLock.3pm* |
116 |
|
|
%_mandir/man3/Coro::Select.3pm* |
117 |
|
|
%_mandir/man3/Coro::Semaphore.3pm* |
118 |
|
|
%_mandir/man3/Coro::SemaphoreSet.3pm* |
119 |
|
|
%_mandir/man3/Coro::Signal.3pm* |
120 |
|
|
%_mandir/man3/Coro::Socket.3pm* |
121 |
|
|
%_mandir/man3/Coro::Specific.3pm* |
122 |
|
|
%_mandir/man3/Coro::State.3pm* |
123 |
|
|
%_mandir/man3/Coro::Storable.3pm* |
124 |
|
|
%_mandir/man3/Coro::Timer.3pm* |
125 |
|
|
%_mandir/man3/Coro::Util.3pm* |
126 |
|
|
|
127 |
|
|
%files BDB |
128 |
|
|
%defattr(-,root,root) |
129 |
|
|
%{perl_vendorarch}/Coro/BDB.pm |
130 |
|
|
%{_mandir}/man3/Coro::BDB* |
131 |
|
|
|
132 |
jquelin |
36947 |
%files AnyEvent |
133 |
|
|
%defattr(-,root,root) |
134 |
|
|
%{perl_vendorarch}/Coro/AnyEvent.pm |
135 |
|
|
%{_mandir}/man3/Coro::AnyEvent* |
136 |
|
|
|
137 |
|
|
%files EV |
138 |
|
|
%defattr(-,root,root) |
139 |
|
|
%{perl_vendorarch}/Coro/EV.pm |
140 |
|
|
%{_mandir}/man3/Coro::EV* |