1 |
%define upstream_name Coro |
2 |
%define upstream_version 5.25 |
3 |
|
4 |
%define _requires_exceptions perl(Exporter::)\\|perl(Coro::Socket::) |
5 |
#define _without_check 1 |
6 |
|
7 |
Name: perl-%{upstream_name} |
8 |
Version: %perl_convert_version %upstream_version |
9 |
Release: %mkrel 1 |
10 |
Epoch: 2 |
11 |
|
12 |
Summary: Coroutine process abstraction |
13 |
License: GPL+ or Artistic |
14 |
Group: Development/Perl |
15 |
Url: http://search.cpan.org/dist/%{upstream_name} |
16 |
Source0: http://search.cpan.org/CPAN/authors/id/M/ML/MLEHMANN/%{upstream_name}-%{upstream_version}.tar.gz |
17 |
|
18 |
BuildRequires: perl-devel |
19 |
BuildRequires: perl-IO-AIO |
20 |
BuildRequires: perl-AnyEvent >= 1:4.05 |
21 |
BuildRequires: perl-Guard |
22 |
BuildRequires: perl-common-sense |
23 |
|
24 |
#gw the test EV/t/01_unblock fails in 4.37: |
25 |
# http://rt.cpan.org/Ticket/Display.html?id=32475 |
26 |
BuildRequires: perl-EV >= 2.0 |
27 |
|
28 |
%description |
29 |
This module collection manages coroutines. Coroutines are similar to |
30 |
threads but don't run in parallel. |
31 |
|
32 |
|
33 |
%package AnyEvent |
34 |
Summary: Use Coro within an AnyEvent environment |
35 |
Group: Development/Perl |
36 |
|
37 |
%description AnyEvent |
38 |
This module integrates coroutines into any event loop supported by |
39 |
AnyEvent, combining event-based programming with coroutine-based |
40 |
programming in a natural way. |
41 |
|
42 |
%package BDB |
43 |
Summary: Truly asynchronous bdb access |
44 |
Group: Development/Perl |
45 |
|
46 |
%description BDB |
47 |
This module implements a thin wrapper around the BDB module. |
48 |
|
49 |
Each BDB request that could block and doesn't get passed a callback |
50 |
will normally block all coroutines. after loading this module, this |
51 |
will no longer be the case. |
52 |
|
53 |
%package EV |
54 |
Summary: Use Coro within an EV environment |
55 |
Group: Development/Perl |
56 |
|
57 |
%description EV |
58 |
This module integrates coroutines into any event loop supported by EV, |
59 |
combining event-based programming with coroutine-based programming in a |
60 |
natural way. |
61 |
|
62 |
|
63 |
%prep |
64 |
%setup -q -n %{upstream_name}-%{upstream_version} |
65 |
|
66 |
%build |
67 |
echo -e "n\nu\n" | %{__perl} Makefile.PL INSTALLDIRS=vendor |
68 |
%make |
69 |
|
70 |
%check |
71 |
%{!?_without_check:make test} |
72 |
|
73 |
%install |
74 |
rm -rf $RPM_BUILD_ROOT |
75 |
%makeinstall_std |
76 |
|
77 |
|
78 |
%clean |
79 |
rm -rf $RPM_BUILD_ROOT |
80 |
|
81 |
%files |
82 |
%defattr(-,root,root) |
83 |
%doc README.linux-glibc README Changes META.yml |
84 |
%dir %{perl_vendorarch}/Coro |
85 |
%{perl_vendorarch}/Coro/AIO.pm |
86 |
%{perl_vendorarch}/Coro/Channel.pm |
87 |
%{perl_vendorarch}/Coro/CoroAPI.h |
88 |
%{perl_vendorarch}/Coro/Debug.pm |
89 |
%{perl_vendorarch}/Coro/Event.pm |
90 |
%{perl_vendorarch}/Coro/Handle.pm |
91 |
%{perl_vendorarch}/Coro/Intro.pod |
92 |
%{perl_vendorarch}/Coro/LWP.pm |
93 |
%{perl_vendorarch}/Coro/MakeMaker.pm |
94 |
%{perl_vendorarch}/Coro/RWLock.pm |
95 |
%{perl_vendorarch}/Coro/Select.pm |
96 |
%{perl_vendorarch}/Coro/Semaphore.pm |
97 |
%{perl_vendorarch}/Coro/SemaphoreSet.pm |
98 |
%{perl_vendorarch}/Coro/Signal.pm |
99 |
%{perl_vendorarch}/Coro/Socket.pm |
100 |
%{perl_vendorarch}/Coro/Specific.pm |
101 |
%{perl_vendorarch}/Coro/State.pm |
102 |
%{perl_vendorarch}/Coro/Storable.pm |
103 |
%{perl_vendorarch}/Coro/Timer.pm |
104 |
%{perl_vendorarch}/Coro/Util.pm |
105 |
%{perl_vendorarch}/Coro.pm |
106 |
%{perl_vendorarch}/auto |
107 |
%_mandir/man3/Coro.3pm* |
108 |
%_mandir/man3/Coro::AIO.3pm* |
109 |
%_mandir/man3/Coro::Channel.3pm* |
110 |
%_mandir/man3/Coro::Debug.3pm* |
111 |
%_mandir/man3/Coro::Event.3pm* |
112 |
%_mandir/man3/Coro::Handle.3pm* |
113 |
%_mandir/man3/Coro::Intro.3pm* |
114 |
%_mandir/man3/Coro::LWP.3pm* |
115 |
%_mandir/man3/Coro::MakeMaker.3pm* |
116 |
%_mandir/man3/Coro::RWLock.3pm* |
117 |
%_mandir/man3/Coro::Select.3pm* |
118 |
%_mandir/man3/Coro::Semaphore.3pm* |
119 |
%_mandir/man3/Coro::SemaphoreSet.3pm* |
120 |
%_mandir/man3/Coro::Signal.3pm* |
121 |
%_mandir/man3/Coro::Socket.3pm* |
122 |
%_mandir/man3/Coro::Specific.3pm* |
123 |
%_mandir/man3/Coro::State.3pm* |
124 |
%_mandir/man3/Coro::Storable.3pm* |
125 |
%_mandir/man3/Coro::Timer.3pm* |
126 |
%_mandir/man3/Coro::Util.3pm* |
127 |
|
128 |
%files BDB |
129 |
%defattr(-,root,root) |
130 |
%{perl_vendorarch}/Coro/BDB.pm |
131 |
%{_mandir}/man3/Coro::BDB* |
132 |
|
133 |
%files AnyEvent |
134 |
%defattr(-,root,root) |
135 |
%{perl_vendorarch}/Coro/AnyEvent.pm |
136 |
%{_mandir}/man3/Coro::AnyEvent* |
137 |
|
138 |
%files EV |
139 |
%defattr(-,root,root) |
140 |
%{perl_vendorarch}/Coro/EV.pm |
141 |
%{_mandir}/man3/Coro::EV* |