/[packages]/cauldron/perl-DBIx-Error/current/SPECS/perl-DBIx-Error.spec
ViewVC logotype

Annotation of /cauldron/perl-DBIx-Error/current/SPECS/perl-DBIx-Error.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 400876 - (hide annotations) (download)
Fri Mar 1 15:14:15 2013 UTC (11 years, 11 months ago) by mcb30
File size: 1655 byte(s)
imported package perl-DBIx-Error
1 mcb30 400876 %define upstream_name DBIx-Error
2     %define upstream_version 1.0
3    
4     Name: perl-%{upstream_name}
5     Version: %perl_convert_version %{upstream_version}
6     Release: %mkrel 1
7    
8     Summary: Structured exceptions for DBI
9     License: GPL+ or Artistic
10     Group: Development/Perl
11     Url: http://search.cpan.org/dist/%{upstream_name}
12     Source0: http://www.cpan.org/modules/by-module/DBIx/%{upstream_name}-%{upstream_version}.tar.gz
13    
14     BuildRequires: perl(Test::More)
15     BuildRequires: perl(Test::Exception)
16     BuildRequires: perl(Test::Moose)
17     BuildRequires: perl(DBI)
18     BuildRequires: perl(DBD::SQLite)
19     BuildRequires: perl(DBIx::Class)
20     BuildRequires: perl(FindBin)
21     BuildRequires: perl(File::Spec::Functions)
22     BuildRequires: perl(Moose)
23     BuildRequires: perl(MooseX::StrictConstructor)
24     BuildRequires: perl(namespace::autoclean)
25     BuildRequires: perl(Throwable::Error)
26     BuildArch: noarch
27    
28     %description
29     "DBIx::Error" provides structured exceptions for "DBI" errors. Each
30     five-character "SQLSTATE" is mapped to a Perl exception class,
31     allowing exceptions to be caught using code such as
32    
33     try {
34     ...
35     } catch ( DBIx::Error::NotNullViolation $err ) {
36     ...
37     } catch ( DBIx::Error::UniqueViolation $err ) {
38     ...
39     }
40    
41     The exception stringifies to produce the full "DBI" error message
42     (including a stack trace). The original DBI error attributes ("err",
43     "errstr" and "state") are also provided for inspection.
44    
45     %prep
46     %setup -q -n %{upstream_name}-%{upstream_version}
47    
48     %build
49     %{__perl} Makefile.PL INSTALLDIRS=vendor
50    
51     %make
52    
53     %check
54     %make test
55    
56     %install
57     %makeinstall_std
58    
59     %files
60     %doc CHANGES META.yml MYMETA.json MYMETA.yml README
61     %{_mandir}/man3/*
62     %perl_vendorlib/*

  ViewVC Help
Powered by ViewVC 1.1.30