/[packages]/cauldron/perl-Data-Dumper/current/SPECS/perl-Data-Dumper.spec
ViewVC logotype

Contents of /cauldron/perl-Data-Dumper/current/SPECS/perl-Data-Dumper.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 790011 - (show annotations) (download)
Sat Oct 18 23:27:13 2014 UTC (9 years, 6 months ago) by umeabot
File size: 1598 byte(s)
Rebuild to potentially add missing dependencies
1 %define upstream_name Data-Dumper
2 %define upstream_version 2.154
3
4 %{?perl_default_filter}
5
6 Name: perl-%{upstream_name}
7 Version: %perl_convert_version %{upstream_version}
8 Release: %mkrel 3
9
10 Summary: Convert data structure into perl code
11 License: GPL+ or Artistic
12 Group: Development/Perl
13 Url: http://search.cpan.org/dist/%{upstream_name}
14 Source0: http://www.cpan.org/modules/by-module/Data/%{upstream_name}-%{upstream_version}.tar.gz
15
16 BuildRequires: perl(ExtUtils::MakeMaker)
17 BuildRequires: perl(Test::More) >= 0.980.0
18 BuildRequires: perl-devel
19 %description
20 Given a list of scalars or reference variables, writes out their contents
21 in perl syntax. The references can also be objects. The content of each
22 variable is output in a single Perl statement. Handles self-referential
23 structures correctly.
24
25 The return value can be 'eval'ed to get back an identical copy of the
26 original reference structure.
27
28 Any references that are the same as one of those passed in will be named
29 '$VAR'_n_ (where _n_ is a numeric suffix), and other duplicate references
30 to substructures within '$VAR'_n_ will be appropriately labeled using arrow
31 notation. You can specify names for individual values to be dumped if you
32 use the 'Dump()' method, or you can change the default '$VAR' prefix to
33 something else. See '$Data::Dumper::Varname' and '$Data::Dumper::Terse'
34 below.
35
36 %prep
37 %setup -q -n %{upstream_name}-%{upstream_version}
38
39 %build
40 %{__perl} Makefile.PL INSTALLDIRS=vendor
41 %make
42
43 %check
44 %make test
45
46 %install
47 %makeinstall_std
48
49 %files
50 %doc Changes META.yml MYMETA.yml
51 %perl_vendorlib/*

  ViewVC Help
Powered by ViewVC 1.1.30