1 |
%define upstream_name Dist-Zilla-Plugin-DynamicPrereqs |
2 |
%define upstream_version 0.039 |
3 |
|
4 |
%{?perl_default_filter} |
5 |
|
6 |
Name: perl-%{upstream_name} |
7 |
Version: %perl_convert_version %{upstream_version} |
8 |
Release: %mkrel 2 |
9 |
|
10 |
Summary: Specify dynamic (user-side) prerequisites for your distribution |
11 |
License: GPLv1+ or Artistic |
12 |
Group: Development/Perl |
13 |
Url: https://metacpan.org/release/%{upstream_name} |
14 |
Source0: https://cpan.metacpan.org/modules/by-module/Dist/%{upstream_name}-%{upstream_version}.tar.gz |
15 |
|
16 |
BuildRequires: perl(Capture::Tiny) |
17 |
BuildRequires: perl(Dist::Zilla::Plugin::MakeMaker) >= 5.22.0 |
18 |
BuildRequires: perl(Dist::Zilla::Role::AfterBuild) |
19 |
BuildRequires: perl(Dist::Zilla::Role::FileGatherer) |
20 |
BuildRequires: perl(Dist::Zilla::Role::FileMunger) |
21 |
BuildRequires: perl(Dist::Zilla::Role::MetaProvider) |
22 |
BuildRequires: perl(Dist::Zilla::Role::ModuleMetadata) |
23 |
BuildRequires: perl(Dist::Zilla::Role::PrereqSource) |
24 |
BuildRequires: perl(Dist::Zilla::Role::TextTemplate) |
25 |
BuildRequires: perl(ExtUtils::MakeMaker) >= 6.640.0 |
26 |
BuildRequires: perl(File::ShareDir) |
27 |
BuildRequires: perl(File::ShareDir::Install) >= 0.60.0 |
28 |
BuildRequires: perl(File::Spec) |
29 |
BuildRequires: perl(File::pushd) |
30 |
BuildRequires: perl(List::Util) >= 1.450.0 |
31 |
BuildRequires: perl(Module::CoreList) >= 3.60.0 |
32 |
BuildRequires: perl(Module::Runtime) |
33 |
BuildRequires: perl(Moose) |
34 |
BuildRequires: perl(PadWalker) |
35 |
BuildRequires: perl(Path::Tiny) |
36 |
BuildRequires: perl(Term::ANSIColor) >= 3.0.0 |
37 |
BuildRequires: perl(Test::DZil) |
38 |
BuildRequires: perl(Test::Deep) |
39 |
BuildRequires: perl(Test::Deep::JSON) |
40 |
BuildRequires: perl(Test::Fatal) |
41 |
BuildRequires: perl(Test::File::ShareDir) |
42 |
BuildRequires: perl(Test::More) >= 0.880.0 |
43 |
BuildRequires: perl(Test::Needs) |
44 |
BuildRequires: perl(Try::Tiny) |
45 |
BuildRequires: perl(if) |
46 |
BuildRequires: perl(lib) |
47 |
BuildRequires: perl(namespace::autoclean) |
48 |
BuildRequires: perl(strict) |
49 |
BuildRequires: perl(warnings) |
50 |
BuildArch: noarch |
51 |
|
52 |
%description |
53 |
This is a the Dist::Zilla manpage plugin that inserts code into your |
54 |
_Makefile.PL_ to indicate dynamic (installer-side) prerequisites. |
55 |
|
56 |
Code is inserted immediately after the declarations for |
57 |
'%WriteMakefileArgs' and '%FallbackPrereqs', before they are conditionally |
58 |
modified (when an older the ExtUtils::MakeMaker manpage is installed). This |
59 |
gives you an opportunity to add to the 'WriteMakefile' arguments: |
60 |
'PREREQ_PM', 'BUILD_REQUIRES', and 'TEST_REQUIRES', and therefore modify |
61 |
the prerequisites in the user's _MYMETA.yml_ and _MYMETA.json_ based on |
62 |
conditions found on the user's system. |
63 |
|
64 |
The 'dynamic_config' field in CPAN::Meta::Spec/dynamic_config is already |
65 |
set for you. |
66 |
|
67 |
%prep |
68 |
%setup -q -n %{upstream_name}-%{upstream_version} |
69 |
|
70 |
%build |
71 |
%{__perl} Makefile.PL INSTALLDIRS=vendor |
72 |
|
73 |
%make_build |
74 |
|
75 |
%check |
76 |
%__make test |
77 |
|
78 |
%install |
79 |
%make_install |
80 |
|
81 |
%files |
82 |
%doc CONTRIBUTING Changes INSTALL LICENCE META.json META.yml MYMETA.yml README |
83 |
%{_mandir}/man3/* |
84 |
%perl_vendorlib/* |