1 |
%define upstream_name Dist-Zilla-Plugin-ReadmeMarkdownFromPod |
2 |
%define upstream_version 0.141140 |
3 |
|
4 |
Name: perl-%{upstream_name} |
5 |
Version: %perl_convert_version %{upstream_version} |
6 |
Release: %mkrel 3 |
7 |
|
8 |
Summary: Automatically convert POD to a README.mkdn for Dist::Zilla |
9 |
License: GPL+ or Artistic |
10 |
Group: Development/Perl |
11 |
Url: http://search.cpan.org/dist/%{upstream_name} |
12 |
Source0: http://www.cpan.org/modules/by-module/Dist/%{upstream_name}-%{upstream_version}.tar.gz |
13 |
|
14 |
BuildRequires: perl(Carp) |
15 |
BuildRequires: perl(Dist::Zilla::Plugin::ReadmeAnyFromPod) >= 0.120.120 |
16 |
BuildRequires: perl(ExtUtils::MakeMaker) >= 6.300.0 |
17 |
BuildRequires: perl(File::Spec) |
18 |
BuildRequires: perl(IO::Handle) |
19 |
BuildRequires: perl(IPC::Open3) |
20 |
BuildRequires: perl(Moose) |
21 |
BuildRequires: perl(Scalar::Util) |
22 |
BuildRequires: perl(Test::DZil) |
23 |
BuildRequires: perl(Test::More) >= 0.940.0 |
24 |
BuildRequires: perl(Test::Most) |
25 |
BuildRequires: perl(autodie) |
26 |
BuildRequires: perl(strict) |
27 |
BuildRequires: perl(warnings) |
28 |
BuildArch: noarch |
29 |
|
30 |
%description |
31 |
Generate a README.mkdn from 'main_module' by the Pod::Markdown manpage |
32 |
|
33 |
The code is mostly a copy-paste of the Dist::Zilla::Plugin::ReadmeFromPod |
34 |
manpage |
35 |
|
36 |
%prep |
37 |
%setup -q -n %{upstream_name}-%{upstream_version} |
38 |
|
39 |
%build |
40 |
%{__perl} Makefile.PL INSTALLDIRS=vendor |
41 |
|
42 |
%make |
43 |
|
44 |
%check |
45 |
%make test |
46 |
|
47 |
%install |
48 |
%makeinstall_std |
49 |
|
50 |
%files |
51 |
%doc Changes INSTALL LICENSE META.yml MYMETA.yml README |
52 |
%{_mandir}/man3/* |
53 |
%perl_vendorlib/* |