/[packages]/cauldron/perl-Dist-Zilla-PluginBundle-RTHOMPSON/current/SPECS/perl-Dist-Zilla-PluginBundle-RTHOMPSON.spec
ViewVC logotype

Diff of /cauldron/perl-Dist-Zilla-PluginBundle-RTHOMPSON/current/SPECS/perl-Dist-Zilla-PluginBundle-RTHOMPSON.spec

Parent Directory Parent Directory | Revision Log Revision Log | View Patch Patch

revision 106927 by jquelin, Thu Mar 17 09:05:16 2011 UTC revision 106928 by jquelin, Wed Jun 15 11:29:07 2011 UTC
# Line 1  Line 1 
1  %define upstream_name    Dist-Zilla-PluginBundle-RTHOMPSON  %define upstream_name    Dist-Zilla-PluginBundle-RTHOMPSON
2  %define upstream_version 0.103532  %define upstream_version 0.111290
3    
4  Name:       perl-%{upstream_name}  Name:       perl-%{upstream_name}
5  Version:    %perl_convert_version %{upstream_version}  Version:    %perl_convert_version %{upstream_version}
# Line 12  Url:        http://search.cpan.org/dist/ Line 12  Url:        http://search.cpan.org/dist/
12  Source0:    http://www.cpan.org/modules/by-module/Dist/%{upstream_name}-%{upstream_version}.tar.gz  Source0:    http://www.cpan.org/modules/by-module/Dist/%{upstream_name}-%{upstream_version}.tar.gz
13    
14  BuildRequires: perl(Carp)  BuildRequires: perl(Carp)
15    BuildRequires: perl(Dist::Zilla::Plugin::ArchiveRelease)
16    BuildRequires: perl(Dist::Zilla::Plugin::AutoPrereqs)
17    BuildRequires: perl(Dist::Zilla::Plugin::AutoVersion)
18    BuildRequires: perl(Dist::Zilla::Plugin::CheckChangesHasContent)
19    BuildRequires: perl(Dist::Zilla::Plugin::CheckPrereqsIndexed)
20    BuildRequires: perl(Dist::Zilla::Plugin::CompileTests)
21    BuildRequires: perl(Dist::Zilla::Plugin::ConfirmRelease)
22    BuildRequires: perl(Dist::Zilla::Plugin::CopyFilesFromBuild)
23    BuildRequires: perl(Dist::Zilla::Plugin::CriticTests)
24    BuildRequires: perl(Dist::Zilla::Plugin::ExecDir)
25    BuildRequires: perl(Dist::Zilla::Plugin::ExtraTests)
26    BuildRequires: perl(Dist::Zilla::Plugin::GatherDir)
27    BuildRequires: perl(Dist::Zilla::Plugin::Git::Check)
28    BuildRequires: perl(Dist::Zilla::Plugin::Git::Commit)
29    BuildRequires: perl(Dist::Zilla::Plugin::Git::Tag)
30    BuildRequires: perl(Dist::Zilla::Plugin::GithubMeta)
31    BuildRequires: perl(Dist::Zilla::Plugin::HasVersionTests)
32    BuildRequires: perl(Dist::Zilla::Plugin::InstallGuide)
33    BuildRequires: perl(Dist::Zilla::Plugin::KwaliteeTests)
34    BuildRequires: perl(Dist::Zilla::Plugin::License)
35    BuildRequires: perl(Dist::Zilla::Plugin::MakeMaker)
36    BuildRequires: perl(Dist::Zilla::Plugin::Manifest)
37    BuildRequires: perl(Dist::Zilla::Plugin::ManifestSkip)
38    BuildRequires: perl(Dist::Zilla::Plugin::MetaYAML)
39    BuildRequires: perl(Dist::Zilla::Plugin::MinimumPerl)
40    BuildRequires: perl(Dist::Zilla::Plugin::NextRelease)
41    BuildRequires: perl(Dist::Zilla::Plugin::PkgVersion)
42    BuildRequires: perl(Dist::Zilla::Plugin::PodCoverageTests)
43    BuildRequires: perl(Dist::Zilla::Plugin::PodSyntaxTests)
44    BuildRequires: perl(Dist::Zilla::Plugin::PodWeaver)
45    BuildRequires: perl(Dist::Zilla::Plugin::PortabilityTests)
46    BuildRequires: perl(Dist::Zilla::Plugin::Prereqs)
47    BuildRequires: perl(Dist::Zilla::Plugin::PruneCruft)
48    BuildRequires: perl(Dist::Zilla::Plugin::PruneFiles)
49    BuildRequires: perl(Dist::Zilla::Plugin::ReadmeAnyFromPod)
50    BuildRequires: perl(Dist::Zilla::Plugin::ReportVersions)
51    BuildRequires: perl(Dist::Zilla::Plugin::ShareDir)
52    BuildRequires: perl(Dist::Zilla::Plugin::StaticVersion)
53    BuildRequires: perl(Dist::Zilla::Plugin::SynopsisTests)
54    BuildRequires: perl(Dist::Zilla::Plugin::TestRelease)
55    BuildRequires: perl(Dist::Zilla::Plugin::UnusedVarsTests)
56    BuildRequires: perl(Dist::Zilla::Plugin::UploadToCPAN)
57  BuildRequires: perl(Dist::Zilla::Role::PluginBundle::Easy)  BuildRequires: perl(Dist::Zilla::Role::PluginBundle::Easy)
58    BuildRequires: perl(ExtUtils::MakeMaker) >= 6.300.0
59  BuildRequires: perl(File::Find)  BuildRequires: perl(File::Find)
60  BuildRequires: perl(File::Temp)  BuildRequires: perl(File::Temp)
61  BuildRequires: perl(Moose)  BuildRequires: perl(Moose)
62  BuildRequires: perl(MooseX::Has::Sugar)  BuildRequires: perl(MooseX::Has::Sugar)
63    BuildRequires: perl(Pod::Weaver::Section::Installation)
64    BuildRequires: perl(Pod::Weaver::Section::WarrantyDisclaimer)
65  BuildRequires: perl(Scalar::Util)  BuildRequires: perl(Scalar::Util)
66  BuildRequires: perl(Test::More)  BuildRequires: perl(Test::More) >= 0.940.0
67  BuildRequires: perl(utf8)  BuildRequires: perl(utf8)
68  BuildArch: noarch  BuildArch:  noarch
69    
70  %description  %description
71  This plugin bundle, in its default configuration, is equivalent to:  This plugin bundle, in its default configuration, is equivalent to:
# Line 98  rm -rf %buildroot Line 143  rm -rf %buildroot
143    
144  %files  %files
145  %defattr(-,root,root)  %defattr(-,root,root)
146  %doc README Changes LICENSE META.yml  %doc Changes INSTALL LICENSE META.yml README
147  %{_mandir}/man3/*  %{_mandir}/man3/*
148  %perl_vendorlib/*  %perl_vendorlib/*
   
   

Legend:
Removed from v.106927  
changed lines
  Added in v.106928

  ViewVC Help
Powered by ViewVC 1.1.28