1 |
%define upstream_name ExtUtils-MakeMaker |
2 |
%define upstream_version 6.62 |
3 |
|
4 |
Name: perl-%{upstream_name} |
5 |
Version: %perl_convert_version %{upstream_version} |
6 |
Release: %mkrel 1 |
7 |
|
8 |
Summary: Writes Makefiles for extensions |
9 |
License: GPL+ or Artistic |
10 |
Group: Development/Perl |
11 |
Url: http://search.cpan.org/dist/%{upstream_name} |
12 |
Source0: http://www.cpan.org/modules/by-module/ExtUtils/%{upstream_name}-%{upstream_version}.tar.gz |
13 |
Patch0: ExtUtils-MakeMaker-6.59-prevent-bundled-copies.patch |
14 |
|
15 |
BuildRequires: perl(Data::Dumper) |
16 |
BuildRequires: perl(DirHandle) |
17 |
BuildRequires: perl(File::Basename) |
18 |
BuildRequires: perl(File::Spec) >= 0.800.0 |
19 |
BuildRequires: perl(Pod::Man) |
20 |
BuildRequires: perl-devel |
21 |
BuildArch: noarch |
22 |
|
23 |
%description |
24 |
Include all the modules bundled with MakeMaker in @INC so |
25 |
ExtUtils::MakeMaker will load. |
26 |
|
27 |
This is for bootstrapping the process of deciding how much of the bundles |
28 |
we need. |
29 |
|
30 |
copy_bundles() copies the contents of each bundle, if necessary, into inc/ |
31 |
as a flattened module directory that MakeMaker can install. |
32 |
|
33 |
%prep |
34 |
%setup -q -n %{upstream_name}-%{upstream_version} |
35 |
%patch0 -b .nobundled |
36 |
|
37 |
%build |
38 |
%{__perl} Makefile.PL INSTALLDIRS=vendor |
39 |
%make |
40 |
|
41 |
%check |
42 |
make test |
43 |
|
44 |
%install |
45 |
%makeinstall_std |
46 |
mv %{buildroot}/%{_bindir}/instmodsh %{buildroot}/%{_bindir}/instmodsh.%{upstream_version} |
47 |
mv %{buildroot}/%{_mandir}/man1/instmodsh.1 %{buildroot}/%{_mandir}/man1/instmodsh.%{upstream_version}.1 |
48 |
|
49 |
%files |
50 |
%doc Changes INSTALL META.json META.yml NOTES PATCHING README SIGNATURE TODO |
51 |
%{_mandir}/man3/* |
52 |
%perl_vendorlib/* |
53 |
%{_bindir}/* |
54 |
%{_mandir}/man1/* |