/[packages]/cauldron/perl-JQuery/current/SPECS/perl-JQuery.spec
ViewVC logotype

Contents of /cauldron/perl-JQuery/current/SPECS/perl-JQuery.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1778078 - (show annotations) (download)
Wed Feb 16 16:58:27 2022 UTC (2 years, 1 month ago) by danf
File size: 1848 byte(s)
SILENT: Switch to https URLs
1 %define upstream_name JQuery
2 %define upstream_version 1.06
3
4 Name: perl-%{upstream_name}
5 Version: %perl_convert_version %{upstream_version}
6 Release: %mkrel 3
7
8 Summary: JQuery Interface
9 License: GPL+ or Artistic
10 Group: Development/Perl
11 Url: https://metacpan.org/dist/%{upstream_name}
12 Source0: https://www.cpan.org/modules/by-module//%{upstream_name}-%{upstream_version}.tar.gz
13
14 BuildRequires: perl(CGI::Application)
15 BuildRequires: perl(CGI::Carp)
16 BuildRequires: perl(CGI::Util)
17 BuildRequires: perl(CSS)
18 BuildRequires: perl(HTML::Table)
19 BuildRequires: perl(IO::String)
20 BuildRequires: perl(Module::Build)
21 BuildRequires: perl(Test::More)
22 BuildRequires: perl(XML::Writer)
23 BuildRequires: perl(Module::Build)
24 BuildArch: noarch
25
26
27 %description
28 JQuery is a frontend for the jQuery language. I use *JQuery* to refer to
29 the Perl part or the package, and *jQuery* to reference the javascript part
30 or the package.
31
32 A quote from the http://jquery.com manpage: jQuery is a fast, concise,
33 JavaScript Library that simplifies how you traverse HTML documents, handle
34 events, perform animations, and add Ajax interactions to your web pages.
35
36 JQuery.pm is the main module. There are other modules such as Form,
37 TableSorter, Splitter, Taconite ..., all of which provide different
38 functionality. The main module needs to be instantiated, and each instance
39 of the other modules needs to be registered with the main module. It is
40 then the responsibility of JQuery.pm to produce the relevant HTML, css and
41 javascript code.
42
43 %prep
44 %setup -q -n %{upstream_name}-%{upstream_version}
45
46 %build
47 %{__perl} Build.PL installdirs=vendor
48 ./Build
49
50 %check
51 ./Build test
52
53 %install
54 rm -rf %buildroot
55 ./Build install destdir=%{buildroot}
56
57 %clean
58 rm -rf %buildroot
59
60 %files
61 %defattr(-,root,root)
62 %doc README Changes META.yml
63 %{_mandir}/man3/*
64 %perl_vendorlib/*

  ViewVC Help
Powered by ViewVC 1.1.30