/[packages]/cauldron/perl-Module-Build/current/SPECS/perl-Module-Build.spec
ViewVC logotype

Annotation of /cauldron/perl-Module-Build/current/SPECS/perl-Module-Build.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 24268 - (hide annotations) (download)
Wed Jan 19 14:47:28 2011 UTC (13 years, 2 months ago) by jquelin
File size: 2542 byte(s)
fix specs
1 jquelin 7396 %define upstream_name Module-Build
2     %define upstream_version 0.3607
3    
4     Name: perl-%{upstream_name}
5     Version: %perl_convert_version %{upstream_version}
6     Release: %mkrel 1
7     Epoch: 1
8    
9     Summary: Build and install Perl modules
10     License: GPL+ or Artistic
11     Group: Development/Perl
12     Summary: Curses interface for Config::Model
13     Url: http://search.cpan.org/dist/%{upstream_name}
14     Source0: http://www.cpan.org/modules/by-module/Module/%{upstream_name}-%{upstream_version}.tar.gz
15    
16     Buildrequires: perl(Archive::Tar)
17     BuildRequires: perl(Cwd)
18     BuildRequires: perl(Data::Dumper)
19     BuildRequires: perl(ExtUtils::CBuilder) >= 0.15
20     BuildRequires: perl(ExtUtils::Install)
21     BuildRequires: perl(ExtUtils::Manifest)
22     BuildRequires: perl(ExtUtils::Mkbootstrap)
23     BuildRequires: perl(ExtUtils::ParseXS)
24     BuildRequires: perl(File::Basename)
25     BuildRequires: perl(File::Compare)
26     BuildRequires: perl(File::Copy)
27     BuildRequires: perl(File::Find)
28     BuildRequires: perl(File::Path)
29     BuildRequires: perl(File::Spec) >= 0.82
30     BuildRequires: perl(Getopt::Long)
31     BuildRequires: perl(IO::File)
32     BuildRequires: perl(Test::Harness)
33     BuildRequires: perl(Text::Abbrev)
34     BuildRequires: perl(Text::ParseWords)
35     Buildrequires: perl(YAML)
36     # for %%check
37     BuildRequires: perl-devel
38    
39     # (tv) this is a soft dep (require instead of use); w/o it some builds failed with
40     # "Module::Build is not configured with C_support":
41     Buildarch: noarch
42 jquelin 24252
43 jquelin 7396 Suggests: perl-ExtUtils-CBuilder
44    
45     %description
46     Module::Build is a system for building, testing, and installing Perl modules.
47     It is meant to be a replacement for ExtUtils::MakeMaker. Developers may alter
48     the behavior of the module through subclassing in a much more straightforward
49     way than with MakeMaker. It also does not require a make on your system - most
50     of the Module::Build code is pure-perl and written in a very cross-platform
51     way. In fact, you don't even need a shell, so even platforms like MacOS
52     (traditional) can use it fairly easily. Its only prerequisites are modules that
53     are included with perl 5.6.0, and it works fine on perl 5.005 if you can
54     install a few additional modules.
55    
56     %prep
57     %setup -q -n %{upstream_name}-%{upstream_version}
58    
59     %build
60     %{__perl} Makefile.PL INSTALLDIRS=vendor
61     perl Build.PL installdirs=vendor
62     ./Build
63    
64     %install
65     rm -rf %{buildroot}
66     ./Build install destdir=%{buildroot}
67    
68     %check
69     ./Build test
70    
71     %clean
72     rm -rf %{buildroot}
73    
74     %files
75     %defattr(-,root,root)
76 jquelin 24252 %doc Changes INSTALL README META.yml
77 jquelin 7396 %{_bindir}/config_data
78     %{perl_vendorlib}/inc
79     %{perl_vendorlib}/Module
80 jquelin 24268 %{_mandir}/*/*

  ViewVC Help
Powered by ViewVC 1.1.30