/[packages]/cauldron/perl-Module-Build/current/SPECS/perl-Module-Build.spec
ViewVC logotype

Annotation of /cauldron/perl-Module-Build/current/SPECS/perl-Module-Build.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 67598 - (hide annotations) (download)
Thu Mar 10 11:58:03 2011 UTC (13 years, 1 month ago) by jquelin
File size: 2804 byte(s)
update to 0.3800
1 jquelin 7396 %define upstream_name Module-Build
2 jquelin 67598 %define upstream_version 0.3800
3 jquelin 7396
4     Name: perl-%{upstream_name}
5     Version: %perl_convert_version %{upstream_version}
6     Release: %mkrel 1
7     Epoch: 1
8    
9     Summary: Build and install Perl modules
10     License: GPL+ or Artistic
11     Group: Development/Perl
12     Summary: Curses interface for Config::Model
13     Url: http://search.cpan.org/dist/%{upstream_name}
14     Source0: http://www.cpan.org/modules/by-module/Module/%{upstream_name}-%{upstream_version}.tar.gz
15    
16     # for %%check
17    
18 jquelin 67598 BuildRequires: perl(CPAN::Meta) >= 2.110.420
19     BuildRequires: perl(Cwd)
20     BuildRequires: perl(Data::Dumper)
21     BuildRequires: perl(ExtUtils::CBuilder) >= 0.270.0
22     BuildRequires: perl(ExtUtils::Install)
23     BuildRequires: perl(ExtUtils::Manifest)
24     BuildRequires: perl(ExtUtils::Mkbootstrap)
25     BuildRequires: perl(ExtUtils::ParseXS) >= 2.210.0
26     BuildRequires: perl(File::Basename)
27     BuildRequires: perl(File::Compare)
28     BuildRequires: perl(File::Copy)
29     BuildRequires: perl(File::Find)
30     BuildRequires: perl(File::Path)
31     BuildRequires: perl(File::Spec) >= 0.820.0
32     BuildRequires: perl(File::Temp) >= 0.150.0
33     BuildRequires: perl(Getopt::Long)
34     BuildRequires: perl(IO::File)
35     BuildRequires: perl(Module::Metadata) >= 1.0.2
36     BuildRequires: perl(Parse::CPAN::Meta) >= 1.440.100
37     BuildRequires: perl(Perl::OSType) >= 1.0.0
38     BuildRequires: perl(Test::Harness)
39     BuildRequires: perl(Test::More) >= 0.490.0
40     BuildRequires: perl(Text::Abbrev)
41     BuildRequires: perl(Text::ParseWords)
42     BuildRequires: perl(version) >= 0.870.0
43     BuildRequires: perl-devel
44 jquelin 7396 # (tv) this is a soft dep (require instead of use); w/o it some builds failed with
45     # "Module::Build is not configured with C_support":
46 jquelin 67598 BuildArch: noarch
47 jquelin 24252
48 jquelin 7396 Suggests: perl-ExtUtils-CBuilder
49    
50     %description
51     Module::Build is a system for building, testing, and installing Perl modules.
52     It is meant to be a replacement for ExtUtils::MakeMaker. Developers may alter
53     the behavior of the module through subclassing in a much more straightforward
54     way than with MakeMaker. It also does not require a make on your system - most
55     of the Module::Build code is pure-perl and written in a very cross-platform
56     way. In fact, you don't even need a shell, so even platforms like MacOS
57     (traditional) can use it fairly easily. Its only prerequisites are modules that
58     are included with perl 5.6.0, and it works fine on perl 5.005 if you can
59     install a few additional modules.
60    
61     %prep
62     %setup -q -n %{upstream_name}-%{upstream_version}
63    
64     %build
65     %{__perl} Makefile.PL INSTALLDIRS=vendor
66     perl Build.PL installdirs=vendor
67     ./Build
68    
69     %install
70     rm -rf %{buildroot}
71     ./Build install destdir=%{buildroot}
72    
73     %check
74     ./Build test
75    
76     %clean
77     rm -rf %{buildroot}
78    
79     %files
80     %defattr(-,root,root)
81 jquelin 67598 %doc Changes INSTALL LICENSE META.json META.yml README
82 jquelin 7396 %{_bindir}/config_data
83     %{perl_vendorlib}/inc
84     %{perl_vendorlib}/Module
85 jquelin 67598 %{_mandir}/*/*

  ViewVC Help
Powered by ViewVC 1.1.30