/[packages]/cauldron/perl-Module-Build/current/SPECS/perl-Module-Build.spec
ViewVC logotype

Annotation of /cauldron/perl-Module-Build/current/SPECS/perl-Module-Build.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 7396 - (hide annotations) (download)
Wed Jan 12 17:44:03 2011 UTC (13 years, 3 months ago) by jquelin
File size: 2662 byte(s)
imported package perl-Module-Build
1 jquelin 7396 %define upstream_name Module-Build
2     %define upstream_version 0.3607
3    
4     Name: perl-%{upstream_name}
5     %if %mdkversion > 200900
6     Version: %perl_convert_version %{upstream_version}
7     %else
8     Version: %{upstream_version}
9     %endif
10     Release: %mkrel 1
11     Epoch: 1
12    
13     Summary: Build and install Perl modules
14     License: GPL+ or Artistic
15     Group: Development/Perl
16     Summary: Curses interface for Config::Model
17     Url: http://search.cpan.org/dist/%{upstream_name}
18     Source0: http://www.cpan.org/modules/by-module/Module/%{upstream_name}-%{upstream_version}.tar.gz
19    
20     Buildrequires: perl(Archive::Tar)
21     BuildRequires: perl(Cwd)
22     BuildRequires: perl(Data::Dumper)
23     BuildRequires: perl(ExtUtils::CBuilder) >= 0.15
24     BuildRequires: perl(ExtUtils::Install)
25     BuildRequires: perl(ExtUtils::Manifest)
26     BuildRequires: perl(ExtUtils::Mkbootstrap)
27     BuildRequires: perl(ExtUtils::ParseXS)
28     BuildRequires: perl(File::Basename)
29     BuildRequires: perl(File::Compare)
30     BuildRequires: perl(File::Copy)
31     BuildRequires: perl(File::Find)
32     BuildRequires: perl(File::Path)
33     BuildRequires: perl(File::Spec) >= 0.82
34     BuildRequires: perl(Getopt::Long)
35     BuildRequires: perl(IO::File)
36     BuildRequires: perl(Test::Harness)
37     BuildRequires: perl(Text::Abbrev)
38     BuildRequires: perl(Text::ParseWords)
39     Buildrequires: perl(YAML)
40     # for %%check
41     BuildRequires: perl-devel
42    
43     # (tv) this is a soft dep (require instead of use); w/o it some builds failed with
44     # "Module::Build is not configured with C_support":
45     Buildarch: noarch
46     BuildRoot: %{_tmppath}/%{name}-%{version}-%{release}
47     Suggests: perl-ExtUtils-CBuilder
48    
49     %description
50     Module::Build is a system for building, testing, and installing Perl modules.
51     It is meant to be a replacement for ExtUtils::MakeMaker. Developers may alter
52     the behavior of the module through subclassing in a much more straightforward
53     way than with MakeMaker. It also does not require a make on your system - most
54     of the Module::Build code is pure-perl and written in a very cross-platform
55     way. In fact, you don't even need a shell, so even platforms like MacOS
56     (traditional) can use it fairly easily. Its only prerequisites are modules that
57     are included with perl 5.6.0, and it works fine on perl 5.005 if you can
58     install a few additional modules.
59    
60     %prep
61     %setup -q -n %{upstream_name}-%{upstream_version}
62    
63     %build
64     %{__perl} Makefile.PL INSTALLDIRS=vendor
65     perl Build.PL installdirs=vendor
66     ./Build
67    
68     %install
69     rm -rf %{buildroot}
70     ./Build install destdir=%{buildroot}
71    
72     %check
73     ./Build test
74    
75     %clean
76     rm -rf %{buildroot}
77    
78     %files
79     %defattr(-,root,root)
80     %doc Changes INSTALL README
81     %{_bindir}/config_data
82     %{perl_vendorlib}/inc
83     %{perl_vendorlib}/Module
84     %{_mandir}/*/*
85    
86    

  ViewVC Help
Powered by ViewVC 1.1.30