1 |
%define upstream_name Mojolicious |
2 |
%define upstream_version 6.18 |
3 |
|
4 |
%global __requires_exclude perl\\(EV\\) |
5 |
|
6 |
Name: perl-%{upstream_name} |
7 |
Version: %perl_convert_version %{upstream_version} |
8 |
Release: %mkrel 1 |
9 |
|
10 |
Summary: A next generation web framework for Perl |
11 |
License: Artistic 2.0 |
12 |
Group: Development/Perl |
13 |
Url: http://mojolicious.org/ |
14 |
Source0: http://www.cpan.org/authors/id/S/SR/SRI/%{upstream_name}-%{upstream_version}.tar.gz |
15 |
|
16 |
BuildRequires: perl(ExtUtils::MakeMaker) |
17 |
BuildRequires: perl(IO::Socket::IP) >= 0.260.0 |
18 |
BuildRequires: perl(Pod::Simple) >= 3.90.0 |
19 |
BuildRequires: perl(Time::Local) >= 1.200.0 |
20 |
BuildArch: noarch |
21 |
|
22 |
%{?perl_default_filter} |
23 |
|
24 |
%description |
25 |
Back in the early day of the web there was this wonderful Perl library |
26 |
called CGI, many people only learned Perl because of it. It was simple |
27 |
enough to get started without knowing much about the language and powerful |
28 |
enough to keep you going, learning by doing was much fun. While most of the |
29 |
techniques used are outdated now, the idea behind it is not. Mojolicious is |
30 |
a new attempt at implementing this idea using state of the art technology. |
31 |
|
32 |
%prep |
33 |
%setup -q -n %{upstream_name}-%{upstream_version} |
34 |
|
35 |
%build |
36 |
%__perl Makefile.PL INSTALLDIRS=vendor |
37 |
%make |
38 |
|
39 |
%check |
40 |
make test |
41 |
|
42 |
%install |
43 |
%make_install |
44 |
|
45 |
%files |
46 |
%doc Changes LICENSE META.json META.yml MYMETA.yml examples |
47 |
%{_bindir}/mojo |
48 |
%{_bindir}/hypnotoad |
49 |
%{perl_vendorlib}/* |
50 |
%{_mandir}/man1/* |
51 |
%{_mandir}/man3/* |
52 |
%_bindir/morbo |