1 |
%define upstream_name Net-DNS |
2 |
%define upstream_version 0.77 |
3 |
|
4 |
Name: perl-%{upstream_name} |
5 |
Version: %perl_convert_version %{upstream_version} |
6 |
Release: %mkrel 4 |
7 |
|
8 |
Summary: Perl interface to the DNS resolver |
9 |
License: GPL+ or Artistic |
10 |
Group: Development/Perl |
11 |
Url: http://search.cpan.org/dist/%{upstream_name} |
12 |
Source0: http://www.cpan.org/modules/by-module/Net/%{upstream_name}-%{upstream_version}.tar.gz |
13 |
|
14 |
BuildRequires: perl(Digest::HMAC) >= 1.10.0 |
15 |
BuildRequires: perl(Digest::MD5) >= 2.130.0 |
16 |
BuildRequires: perl(Digest::SHA) >= 5.230.0 |
17 |
BuildRequires: perl(ExtUtils::MakeMaker) |
18 |
BuildRequires: perl(IO::Socket) >= 1.240.0 |
19 |
BuildRequires: perl(MIME::Base64) >= 2.110.0 |
20 |
BuildRequires: perl(Test::More) >= 0.520.0 |
21 |
BuildRequires: perl-devel |
22 |
|
23 |
%{?perl_default_filter} |
24 |
|
25 |
%description |
26 |
Net::DNS is a collection of Perl modules that act as a Domain Name System (DNS) |
27 |
resolver. It allows the programmer to perform DNS queries that are beyond the |
28 |
capabilities of gethostbyname and gethostbyaddr. |
29 |
|
30 |
The programmer should be somewhat familiar with the format of a DNS packet and |
31 |
its various sections. See RFC 1035 or DNS and BIND (Albitz & Liu) for details. |
32 |
|
33 |
%prep |
34 |
%setup -q -n %{upstream_name}-%{upstream_version} |
35 |
|
36 |
%build |
37 |
%{__perl} Makefile.PL INSTALLDIRS=vendor < /dev/null |
38 |
%make |
39 |
|
40 |
%check |
41 |
%{__make} test |
42 |
|
43 |
%install |
44 |
%makeinstall_std |
45 |
|
46 |
%files |
47 |
%doc Changes META.json META.yml MYMETA.yml README TODO demo |
48 |
%{_mandir}/*/* |
49 |
%{perl_vendorarch}/auto/Net |
50 |
%{perl_vendorarch}/Net |