1 |
%define upstream_name CPAN-Meta |
2 |
%define upstream_version 2.150010 |
3 |
|
4 |
Name: perl-%{upstream_name} |
5 |
Version: %perl_convert_version %{upstream_version} |
6 |
Release: %mkrel 4 |
7 |
|
8 |
Summary: Parse META.yml and other similar CPAN metadata files |
9 |
License: GPL+ or Artistic |
10 |
Group: Development/Perl |
11 |
Url: https://metacpan.org/dist/%{upstream_name} |
12 |
Source0: https://cpan.metacpan.org/authors/id/D/DA/DAGOLDEN/%{upstream_name}-%{upstream_version}.tar.gz |
13 |
|
14 |
BuildRequires: perl(CPAN::Meta::YAML) >= 0.11.0 |
15 |
BuildRequires: perl(Carp) |
16 |
BuildRequires: perl(Encode) |
17 |
BuildRequires: perl(Exporter) |
18 |
BuildRequires: perl(ExtUtils::MakeMaker) |
19 |
BuildRequires: perl(File::Spec) >= 0.800.0 |
20 |
BuildRequires: perl(File::Spec::Functions) |
21 |
BuildRequires: perl(JSON::PP) >= 2.272.0 |
22 |
BuildRequires: perl(Test::More) >= 0.470.0 |
23 |
BuildRequires: perl(lib) |
24 |
BuildRequires: perl(strict) |
25 |
BuildRequires: perl(vars) |
26 |
BuildRequires: perl(warnings) |
27 |
BuildArch: noarch |
28 |
|
29 |
Obsoletes: perl(Parse::CPAN::Meta) < 2.150010-1 |
30 |
|
31 |
%{?perl_default_filter} |
32 |
|
33 |
%description |
34 |
*Parse::CPAN::Meta* is a parser for META.yml files, based on the parser |
35 |
half of the YAML::Tiny manpage. |
36 |
|
37 |
It supports a basic subset of the full YAML specification, enough to |
38 |
implement parsing of typical META.yml files, and other similarly simple |
39 |
YAML files. |
40 |
|
41 |
If you need something with more power, move up to a full YAML parser such |
42 |
as the YAML manpage, the YAML::Syck manpage or the YAML::LibYAML manpage. |
43 |
|
44 |
%prep |
45 |
%setup -q -n %{upstream_name}-%{upstream_version} |
46 |
|
47 |
%build |
48 |
%__perl Makefile.PL INSTALLDIRS=vendor |
49 |
%make |
50 |
|
51 |
%check |
52 |
make test |
53 |
|
54 |
%install |
55 |
%make_install |
56 |
|
57 |
%files |
58 |
%doc Changes LICENSE META.json META.yml MYMETA.yml README |
59 |
%{_mandir}/man3/* |
60 |
%{perl_vendorlib}/CPAN |
61 |
%{perl_vendorlib}/Parse |