1 |
%define upstream_name RPM-Spec |
2 |
%define upstream_version 0.05 |
3 |
|
4 |
Name: perl-%{upstream_name} |
5 |
Version: %perl_convert_version %{upstream_version} |
6 |
Release: %mkrel 2 |
7 |
|
8 |
Summary: A very simplistic read-only method of accessing RPM spec files |
9 |
License: GPL+ or Artistic |
10 |
Group: Development/Perl |
11 |
Url: http://search.cpan.org/dist/%{upstream_name} |
12 |
Source0: http://www.cpan.org/modules/by-module/RPM/%{upstream_name}-%{upstream_version}.tar.gz |
13 |
|
14 |
BuildRequires: perl(ExtUtils::MakeMaker) |
15 |
BuildRequires: perl(Moose) |
16 |
BuildRequires: perl(MooseX::Types::Moose) |
17 |
BuildRequires: perl(MooseX::Types::Path::Class) |
18 |
BuildRequires: perl(Path::Class) |
19 |
BuildRequires: perl(Test::More) |
20 |
BuildRequires: perl(namespace::autoclean) |
21 |
BuildArch: noarch |
22 |
|
23 |
%description |
24 |
*WARNING: This code is actively being worked on, and the API may change.* |
25 |
|
26 |
RPM::Spec provides simplistic access to the different bits of information a |
27 |
spec file provides... It is basically a collection of different parsing |
28 |
routines that were scattered through a bunch of other modules. |
29 |
|
30 |
%prep |
31 |
%setup -q -n %{upstream_name}-%{upstream_version} |
32 |
|
33 |
%build |
34 |
%{__perl} Makefile.PL INSTALLDIRS=vendor |
35 |
|
36 |
%make |
37 |
|
38 |
%check |
39 |
%make test |
40 |
|
41 |
%install |
42 |
%makeinstall_std |
43 |
|
44 |
%files |
45 |
%doc Changes TODO META.yml README |
46 |
%{_mandir}/man3/* |
47 |
%perl_vendorlib/* |
48 |
|
49 |
|