/[packages]/cauldron/perl-RPM4/current/SPECS/perl-RPM4.spec
ViewVC logotype

Annotation of /cauldron/perl-RPM4/current/SPECS/perl-RPM4.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 14433 - (hide annotations) (download)
Thu Jan 13 15:24:36 2011 UTC (13 years, 3 months ago) by jquelin
File size: 1598 byte(s)
imported package perl-RPM4
1 jquelin 14433 # This spec is in the SVN
2     # $Id: perl-RPM4.spec 141783 2007-03-12 14:05:45Z nanardon $
3    
4     %define module RPM4
5     %define name perl-%{module}
6     %define version 0.23
7     %define release %mkrel 11
8    
9     %define rpm_version %(rpm -q --queryformat '%|EPOCH?{[%{EPOCH}:%{VERSION}]}:{%{VERSION}}|' rpm)
10    
11     Name: %{name}
12     Version: %{version}
13     Release: %{release}
14     Summary: Perl bindings to use rpmlib and manage hdlist files
15     License: GPL
16     Group: Development/Perl
17     Source: %{module}-%{version}.tar.gz
18     Patch0: RPM4-fix-build-with-rpm46.patch
19     Url: http://search.cpan.org/dist/RPM4/
20     Buildroot: %{_tmppath}/%{name}-root
21     BuildRequires: perl-devel >= 5.8.0
22     BuildRequires: rpm-devel
23     BuildRequires: perl-Digest-SHA1
24     BuildRequires: librpmconstant-devel
25     BuildRequires: packdrake
26     BuildRequires: perl-MDV-Packdrakeng
27     BuildRequires: gnupg
28     Requires: perl
29     # we can now expect librpm API to be at least backward compatible
30     Requires: rpm >= %{rpm_version}
31    
32     %description
33     This module provides a perl interface to the rpmlib.
34    
35     It allows to write scripts to:
36     - query rpm headers,
37     - query rpm database,
38     - build rpm specs,
39     - install/uninstall specfiles,
40     - check dependencies.
41    
42     It include:
43     - rpm_produced, give what rpm will be produced by a src.rpm or a specfile.
44    
45     %prep
46     %setup -q -n %{module}-%{version}
47     %patch0 -p1 -b .rpm46
48    
49     %build
50     %{__perl} Makefile.PL INSTALLDIRS=vendor
51     %make
52    
53     %check
54     PERL5DIR=`pwd`/src/blib/arch TMPDIR=/tmp %make test
55    
56     %clean
57     rm -rf $RPM_BUILD_ROOT
58    
59     %install
60     rm -rf $RPM_BUILD_ROOT
61     %makeinstall_std
62    
63     %files
64     %defattr(-,root,root)
65     %doc ChangeLog README
66     %doc examples
67     %_bindir/*
68     %{perl_vendorarch}/*
69     %{_mandir}/*/*
70    
71    

  ViewVC Help
Powered by ViewVC 1.1.30