/[packages]/cauldron/perl-RPM4/current/SPECS/perl-RPM4.spec
ViewVC logotype

Annotation of /cauldron/perl-RPM4/current/SPECS/perl-RPM4.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 181577 - (hide annotations) (download)
Wed Dec 14 19:37:56 2011 UTC (12 years, 3 months ago) by tv
File size: 1490 byte(s)
- disable tests segfaulting in rpmSpecBuild()
- disable tests using unimplemented functions regarding rpm-4.9
- disable 2 tests that fails with rpm-4.9
  (all functions needed by iurt & youri* pass the testsuite)
- implement more functions with rpm-4.9
1 jquelin 14433 # This spec is in the SVN
2     # $Id: perl-RPM4.spec 141783 2007-03-12 14:05:45Z nanardon $
3    
4     %define module RPM4
5     %define name perl-%{module}
6 tv 181577 %define version 0.25
7 tv 165910 %define release %mkrel 1
8 jquelin 14433
9     %define rpm_version %(rpm -q --queryformat '%|EPOCH?{[%{EPOCH}:%{VERSION}]}:{%{VERSION}}|' rpm)
10    
11     Name: %{name}
12     Version: %{version}
13     Release: %{release}
14     Summary: Perl bindings to use rpmlib and manage hdlist files
15     License: GPL
16     Group: Development/Perl
17     Source: %{module}-%{version}.tar.gz
18     Url: http://search.cpan.org/dist/RPM4/
19 sander85 104940
20     BuildRequires: perl-devel >= 5.8.0
21     BuildRequires: rpm-devel
22     BuildRequires: perl-Digest-SHA1
23     BuildRequires: librpmconstant-devel
24     BuildRequires: packdrake
25     BuildRequires: perl-MDV-Packdrakeng
26     BuildRequires: gnupg
27    
28 jquelin 14433 Requires: perl
29     # we can now expect librpm API to be at least backward compatible
30     Requires: rpm >= %{rpm_version}
31    
32     %description
33     This module provides a perl interface to the rpmlib.
34    
35     It allows to write scripts to:
36     - query rpm headers,
37     - query rpm database,
38     - build rpm specs,
39     - install/uninstall specfiles,
40     - check dependencies.
41    
42     It include:
43     - rpm_produced, give what rpm will be produced by a src.rpm or a specfile.
44    
45     %prep
46     %setup -q -n %{module}-%{version}
47    
48     %build
49     %{__perl} Makefile.PL INSTALLDIRS=vendor
50     %make
51    
52     %check
53     PERL5DIR=`pwd`/src/blib/arch TMPDIR=/tmp %make test
54    
55     %clean
56     rm -rf $RPM_BUILD_ROOT
57    
58     %install
59     rm -rf $RPM_BUILD_ROOT
60     %makeinstall_std
61    
62     %files
63     %defattr(-,root,root)
64 tv 165905 %doc README
65 jquelin 14433 %doc examples
66     %_bindir/*
67     %{perl_vendorarch}/*
68     %{_mandir}/*/*
69    
70    

  ViewVC Help
Powered by ViewVC 1.1.30