1 |
jquelin |
14433 |
# This spec is in the SVN |
2 |
|
|
# $Id: perl-RPM4.spec 141783 2007-03-12 14:05:45Z nanardon $ |
3 |
|
|
|
4 |
|
|
%define module RPM4 |
5 |
|
|
%define name perl-%{module} |
6 |
|
|
%define version 0.23 |
7 |
|
|
%define release %mkrel 11 |
8 |
|
|
|
9 |
|
|
%define rpm_version %(rpm -q --queryformat '%|EPOCH?{[%{EPOCH}:%{VERSION}]}:{%{VERSION}}|' rpm) |
10 |
|
|
|
11 |
|
|
Name: %{name} |
12 |
|
|
Version: %{version} |
13 |
|
|
Release: %{release} |
14 |
|
|
Summary: Perl bindings to use rpmlib and manage hdlist files |
15 |
|
|
License: GPL |
16 |
|
|
Group: Development/Perl |
17 |
|
|
Source: %{module}-%{version}.tar.gz |
18 |
|
|
Patch0: RPM4-fix-build-with-rpm46.patch |
19 |
|
|
Url: http://search.cpan.org/dist/RPM4/ |
20 |
|
|
Buildroot: %{_tmppath}/%{name}-root |
21 |
|
|
BuildRequires: perl-devel >= 5.8.0 |
22 |
|
|
BuildRequires: rpm-devel |
23 |
|
|
BuildRequires: perl-Digest-SHA1 |
24 |
|
|
BuildRequires: librpmconstant-devel |
25 |
|
|
BuildRequires: perl-MDV-Packdrakeng |
26 |
|
|
BuildRequires: gnupg |
27 |
|
|
Requires: perl |
28 |
|
|
# we can now expect librpm API to be at least backward compatible |
29 |
|
|
Requires: rpm >= %{rpm_version} |
30 |
|
|
|
31 |
|
|
%description |
32 |
|
|
This module provides a perl interface to the rpmlib. |
33 |
|
|
|
34 |
|
|
It allows to write scripts to: |
35 |
|
|
- query rpm headers, |
36 |
|
|
- query rpm database, |
37 |
|
|
- build rpm specs, |
38 |
|
|
- install/uninstall specfiles, |
39 |
|
|
- check dependencies. |
40 |
|
|
|
41 |
|
|
It include: |
42 |
|
|
- rpm_produced, give what rpm will be produced by a src.rpm or a specfile. |
43 |
|
|
|
44 |
|
|
%prep |
45 |
|
|
%setup -q -n %{module}-%{version} |
46 |
|
|
%patch0 -p1 -b .rpm46 |
47 |
|
|
|
48 |
|
|
%build |
49 |
|
|
%{__perl} Makefile.PL INSTALLDIRS=vendor |
50 |
|
|
%make |
51 |
|
|
|
52 |
|
|
%check |
53 |
|
|
PERL5DIR=`pwd`/src/blib/arch TMPDIR=/tmp %make test |
54 |
|
|
|
55 |
|
|
%clean |
56 |
|
|
rm -rf $RPM_BUILD_ROOT |
57 |
|
|
|
58 |
|
|
%install |
59 |
|
|
rm -rf $RPM_BUILD_ROOT |
60 |
|
|
%makeinstall_std |
61 |
|
|
|
62 |
|
|
%files |
63 |
|
|
%defattr(-,root,root) |
64 |
|
|
%doc ChangeLog README |
65 |
|
|
%doc examples |
66 |
|
|
%_bindir/* |
67 |
|
|
%{perl_vendorarch}/* |
68 |
|
|
%{_mandir}/*/* |
69 |
|
|
|
70 |
|
|
|