/[packages]/cauldron/perl-RPM4/current/SPECS/perl-RPM4.spec
ViewVC logotype

Annotation of /cauldron/perl-RPM4/current/SPECS/perl-RPM4.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 48941 - (hide annotations) (download)
Tue Feb 8 10:04:37 2011 UTC (13 years, 2 months ago) by dmorgan
File size: 1648 byte(s)
Add patch to build against new rpm 4.8
1 jquelin 14433 # This spec is in the SVN
2     # $Id: perl-RPM4.spec 141783 2007-03-12 14:05:45Z nanardon $
3    
4     %define module RPM4
5     %define name perl-%{module}
6     %define version 0.23
7 dmorgan 47268 %define release %mkrel 11
8 jquelin 14433
9     %define rpm_version %(rpm -q --queryformat '%|EPOCH?{[%{EPOCH}:%{VERSION}]}:{%{VERSION}}|' rpm)
10    
11     Name: %{name}
12     Version: %{version}
13     Release: %{release}
14     Summary: Perl bindings to use rpmlib and manage hdlist files
15     License: GPL
16     Group: Development/Perl
17     Source: %{module}-%{version}.tar.gz
18     Patch0: RPM4-fix-build-with-rpm46.patch
19 dmorgan 48941 Patch1: RPM4-0.23-rpm48.patch
20 jquelin 14433 Url: http://search.cpan.org/dist/RPM4/
21     Buildroot: %{_tmppath}/%{name}-root
22     BuildRequires: perl-devel >= 5.8.0
23     BuildRequires: rpm-devel
24     BuildRequires: perl-Digest-SHA1
25     BuildRequires: librpmconstant-devel
26 dmorgan 47268 BuildRequires: packdrake
27 jquelin 14433 BuildRequires: perl-MDV-Packdrakeng
28     BuildRequires: gnupg
29     Requires: perl
30     # we can now expect librpm API to be at least backward compatible
31     Requires: rpm >= %{rpm_version}
32    
33     %description
34     This module provides a perl interface to the rpmlib.
35    
36     It allows to write scripts to:
37     - query rpm headers,
38     - query rpm database,
39     - build rpm specs,
40     - install/uninstall specfiles,
41     - check dependencies.
42    
43     It include:
44     - rpm_produced, give what rpm will be produced by a src.rpm or a specfile.
45    
46     %prep
47     %setup -q -n %{module}-%{version}
48     %patch0 -p1 -b .rpm46
49 dmorgan 48941 %patch1 -p1
50 jquelin 14433
51     %build
52     %{__perl} Makefile.PL INSTALLDIRS=vendor
53     %make
54    
55     %check
56     PERL5DIR=`pwd`/src/blib/arch TMPDIR=/tmp %make test
57    
58     %clean
59     rm -rf $RPM_BUILD_ROOT
60    
61     %install
62     rm -rf $RPM_BUILD_ROOT
63     %makeinstall_std
64    
65     %files
66     %defattr(-,root,root)
67     %doc ChangeLog README
68     %doc examples
69     %_bindir/*
70     %{perl_vendorarch}/*
71     %{_mandir}/*/*
72    
73    

  ViewVC Help
Powered by ViewVC 1.1.30