1 |
jquelin |
14433 |
# This spec is in the SVN |
2 |
|
|
# $Id: perl-RPM4.spec 141783 2007-03-12 14:05:45Z nanardon $ |
3 |
|
|
|
4 |
tv |
1317319 |
%define upstream_name RPM4 |
5 |
tv |
2001263 |
%define upstream_version 0.47 |
6 |
jquelin |
14433 |
|
7 |
|
|
%define rpm_version %(rpm -q --queryformat '%|EPOCH?{[%{EPOCH}:%{VERSION}]}:{%{VERSION}}|' rpm) |
8 |
|
|
|
9 |
sander85 |
840886 |
%{?perl_default_filter} |
10 |
|
|
|
11 |
tv |
1317320 |
Name: perl-%{upstream_name} |
12 |
|
|
Version: %upstream_version |
13 |
tv |
2089249 |
Release: %mkrel 5 |
14 |
tv |
1317320 |
Summary: Perl bindings to use rpmlib and manage hdlist files |
15 |
|
|
License: GPL |
16 |
|
|
Group: Development/Perl |
17 |
ovitters |
1576130 |
Source0: https://cpan.metacpan.org/modules/by-authors/id/T/TV/TVIGNAUD/%{upstream_name}-%{upstream_version}.tgz |
18 |
|
|
Url: https://metacpan.org/release/RPM4 |
19 |
sander85 |
104940 |
|
20 |
tv |
1317320 |
BuildRequires: perl(Carp) |
21 |
|
|
BuildRequires: perl(Digest::SHA1) |
22 |
|
|
BuildRequires: perl(DynaLoader) |
23 |
|
|
BuildRequires: perl(Exporter) |
24 |
|
|
BuildRequires: perl(ExtUtils::Depends) |
25 |
|
|
BuildRequires: perl(ExtUtils::MakeMaker) |
26 |
|
|
BuildRequires: perl(ExtUtils::PkgConfig) |
27 |
|
|
BuildRequires: perl(File::Temp) |
28 |
|
|
BuildRequires: perl(Getopt::Long) |
29 |
|
|
BuildRequires: perl(MDV::Packdrakeng) |
30 |
|
|
BuildRequires: perl-devel >= 5.8.0 |
31 |
|
|
BuildRequires: pkgconfig(rpm) >= 4.12.0 |
32 |
|
|
BuildRequires: perl-Digest-SHA1 |
33 |
|
|
BuildRequires: librpmconstant-devel |
34 |
|
|
BuildRequires: gnupg |
35 |
jquelin |
14433 |
# we can now expect librpm API to be at least backward compatible |
36 |
tv |
1317320 |
Requires: rpm >= %{rpm_version} |
37 |
jquelin |
14433 |
%description |
38 |
|
|
This module provides a perl interface to the rpmlib. |
39 |
|
|
|
40 |
|
|
It allows to write scripts to: |
41 |
|
|
- query rpm headers, |
42 |
|
|
- query rpm database, |
43 |
|
|
- build rpm specs, |
44 |
|
|
- install/uninstall specfiles, |
45 |
|
|
- check dependencies. |
46 |
|
|
|
47 |
tv |
183471 |
It includes: |
48 |
jquelin |
14433 |
- rpm_produced, give what rpm will be produced by a src.rpm or a specfile. |
49 |
|
|
|
50 |
|
|
%prep |
51 |
tv |
1317319 |
%setup -q -n %{upstream_name}-%{version} |
52 |
ovitters |
878001 |
%autopatch -p1 |
53 |
jquelin |
14433 |
|
54 |
|
|
%build |
55 |
|
|
%{__perl} Makefile.PL INSTALLDIRS=vendor |
56 |
tv |
1013443 |
%make_build |
57 |
jquelin |
14433 |
|
58 |
|
|
%check |
59 |
tv |
1013949 |
%ifarch x86_64 |
60 |
tv |
1169125 |
make test TEST_VERBOSE=1 |
61 |
tv |
1013949 |
%endif |
62 |
jquelin |
14433 |
|
63 |
|
|
%install |
64 |
tv |
1168633 |
%make_install |
65 |
jquelin |
14433 |
|
66 |
|
|
%files |
67 |
tv |
1317320 |
%doc META.json META.yml MYMETA.yml README examples |
68 |
jquelin |
14433 |
%doc examples |
69 |
|
|
%_bindir/* |
70 |
|
|
%{perl_vendorarch}/* |
71 |
tv |
1590046 |
%{_mandir}/*/* |