1 |
# This spec is in the SVN |
2 |
# $Id: perl-RPM4.spec 141783 2007-03-12 14:05:45Z nanardon $ |
3 |
|
4 |
%define upstream_name RPM4 |
5 |
%define upstream_version 0.47 |
6 |
|
7 |
%define rpm_version %(rpm -q --queryformat '%|EPOCH?{[%{EPOCH}:%{VERSION}]}:{%{VERSION}}|' rpm) |
8 |
|
9 |
%{?perl_default_filter} |
10 |
|
11 |
Name: perl-%{upstream_name} |
12 |
Version: %upstream_version |
13 |
Release: %mkrel 5 |
14 |
Summary: Perl bindings to use rpmlib and manage hdlist files |
15 |
License: GPL |
16 |
Group: Development/Perl |
17 |
Source0: https://cpan.metacpan.org/modules/by-authors/id/T/TV/TVIGNAUD/%{upstream_name}-%{upstream_version}.tgz |
18 |
Url: https://metacpan.org/release/RPM4 |
19 |
|
20 |
BuildRequires: perl(Carp) |
21 |
BuildRequires: perl(Digest::SHA1) |
22 |
BuildRequires: perl(DynaLoader) |
23 |
BuildRequires: perl(Exporter) |
24 |
BuildRequires: perl(ExtUtils::Depends) |
25 |
BuildRequires: perl(ExtUtils::MakeMaker) |
26 |
BuildRequires: perl(ExtUtils::PkgConfig) |
27 |
BuildRequires: perl(File::Temp) |
28 |
BuildRequires: perl(Getopt::Long) |
29 |
BuildRequires: perl(MDV::Packdrakeng) |
30 |
BuildRequires: perl-devel >= 5.8.0 |
31 |
BuildRequires: pkgconfig(rpm) >= 4.12.0 |
32 |
BuildRequires: perl-Digest-SHA1 |
33 |
BuildRequires: librpmconstant-devel |
34 |
BuildRequires: gnupg |
35 |
# we can now expect librpm API to be at least backward compatible |
36 |
Requires: rpm >= %{rpm_version} |
37 |
%description |
38 |
This module provides a perl interface to the rpmlib. |
39 |
|
40 |
It allows to write scripts to: |
41 |
- query rpm headers, |
42 |
- query rpm database, |
43 |
- build rpm specs, |
44 |
- install/uninstall specfiles, |
45 |
- check dependencies. |
46 |
|
47 |
It includes: |
48 |
- rpm_produced, give what rpm will be produced by a src.rpm or a specfile. |
49 |
|
50 |
%prep |
51 |
%setup -q -n %{upstream_name}-%{version} |
52 |
%autopatch -p1 |
53 |
|
54 |
%build |
55 |
%{__perl} Makefile.PL INSTALLDIRS=vendor |
56 |
%make_build |
57 |
|
58 |
%check |
59 |
%ifarch x86_64 |
60 |
make test TEST_VERBOSE=1 |
61 |
%endif |
62 |
|
63 |
%install |
64 |
%make_install |
65 |
|
66 |
%files |
67 |
%doc META.json META.yml MYMETA.yml README examples |
68 |
%doc examples |
69 |
%_bindir/* |
70 |
%{perl_vendorarch}/* |
71 |
%{_mandir}/*/* |