1 |
jquelin |
4550 |
%define upstream_name Test-Perl-Critic-Progressive |
2 |
|
|
%define upstream_version 0.03 |
3 |
|
|
|
4 |
|
|
Name: perl-%{upstream_name} |
5 |
|
|
Version: %perl_convert_version %{upstream_version} |
6 |
umeabot |
1806193 |
Release: %mkrel 10 |
7 |
jquelin |
4550 |
|
8 |
|
|
Summary: Gradually enforce coding standards |
9 |
|
|
License: GPL+ or Artistic |
10 |
|
|
Group: Development/Perl |
11 |
ovitters |
1576519 |
Url: https://metacpan.org/release/%{upstream_name} |
12 |
|
|
Source0: https://cpan.metacpan.org/modules/by-module/Test/%{upstream_name}-%{upstream_version}.tar.gz |
13 |
jquelin |
4550 |
|
14 |
|
|
BuildRequires: perl(Carp) |
15 |
|
|
BuildRequires: perl(Data::Dumper) |
16 |
|
|
BuildRequires: perl(English) |
17 |
|
|
BuildRequires: perl(Exporter) |
18 |
|
|
BuildRequires: perl(File::Spec) |
19 |
|
|
BuildRequires: perl(FindBin) |
20 |
|
|
BuildRequires: perl(Perl::Critic) |
21 |
|
|
BuildRequires: perl(Perl::Critic::Utils) |
22 |
|
|
BuildRequires: perl(Test::Builder) |
23 |
|
|
BuildRequires: perl(Test::More) |
24 |
|
|
BuildRequires: perl(base) |
25 |
|
|
BuildRequires: perl(strict) |
26 |
|
|
BuildRequires: perl(warnings) |
27 |
|
|
BuildArch: noarch |
28 |
|
|
|
29 |
tv |
736012 |
%{?perl_default_filter} |
30 |
|
|
%global __requires_exclude %{?__requires_exclude:%__requires_exclude|}perl\\(Perl::Critic(::Utils)?\\)$ |
31 |
jquelin |
37208 |
|
32 |
jquelin |
4550 |
%description |
33 |
|
|
Applying coding standards to large amounts of legacy code is a daunting |
34 |
|
|
task. Often times, legacy code is so non-compliant that it seems downright |
35 |
|
|
impossible. But, if you consistently chip away at the problem, you will |
36 |
|
|
eventually succeed! Test::Perl::Critic::Progressive uses the the |
37 |
|
|
Perl::Critic manpage engine to prevent further deterioration of your code |
38 |
|
|
and *gradually* steer it towards conforming with your chosen coding |
39 |
|
|
standards. |
40 |
|
|
|
41 |
|
|
The most effective way to use Test::Perl::Critic::Progressive is as a unit |
42 |
|
|
test that is run under a continuous-integration system like CruiseControl |
43 |
|
|
or AntHill. Each time a developer commits changes to the code, this test |
44 |
|
|
will fail and the build will break unless it has the same (or fewer) |
45 |
|
|
Perl::Critic violations than the last successful test. |
46 |
|
|
|
47 |
|
|
See the the "NOTES" manpage for more details about how this test works. |
48 |
|
|
|
49 |
|
|
%prep |
50 |
|
|
%setup -q -n %{upstream_name}-%{upstream_version} |
51 |
|
|
|
52 |
|
|
%build |
53 |
|
|
%{__perl} Makefile.PL INSTALLDIRS=vendor |
54 |
|
|
|
55 |
ovitters |
1576519 |
%make_build |
56 |
jquelin |
4550 |
|
57 |
|
|
%check |
58 |
ovitters |
1576519 |
%make_build test |
59 |
jquelin |
4550 |
|
60 |
|
|
%install |
61 |
wally |
1473309 |
%make_install |
62 |
jquelin |
4550 |
|
63 |
|
|
%files |
64 |
|
|
%doc Changes LICENSE META.yml README |
65 |
|
|
%{_mandir}/man3/* |
66 |
tv |
736012 |
%perl_vendorlib/* |