/[packages]/cauldron/php-ming/current/SPECS/php-ming.spec
ViewVC logotype

Contents of /cauldron/php-ming/current/SPECS/php-ming.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 48124 - (show annotations) (download)
Sun Feb 6 23:04:18 2011 UTC (13 years, 2 months ago) by spuhler
File size: 1187 byte(s)
removed buildroot definition from .spec

1 %define modname ming
2 %define dirname %{modname}
3 %define soname %{modname}.so
4 %define inifile 33_%{modname}.ini
5
6 Summary: Ming extension module for PHP
7 Name: php-ming
8 Version: 5.2.10
9 Release: %mkrel 10
10 Group: Development/PHP
11 URL: http://www.php.net
12 License: PHP License
13 # S0 is taken from php-5.2.x CVS
14 Source0: ming.tar.gz
15 Patch0: php-ming-0.4.2.diff
16 BuildRequires: php-devel >= 3:5.2.0
17 BuildRequires: libming-devel
18 Epoch: 0
19
20 %description
21 This is a dynamic shared object (DSO) for PHP that will add ming (Flash - .swf
22 files) support.
23
24 %prep
25
26 %setup -n ming
27 %patch0 -p1
28
29 %build
30
31 phpize
32 %configure2_5x --with-libdir=%{_lib} \
33 --with-%{modname}=shared,%{_prefix}
34
35 %make
36 mv modules/*.so .
37
38 %install
39 rm -rf %{buildroot}
40
41
42 install -d %{buildroot}%{_libdir}/php/extensions
43 install -d %{buildroot}%{_sysconfdir}/php.d
44
45 install -m755 %{soname} %{buildroot}%{_libdir}/php/extensions/
46
47 cat > %{buildroot}%{_sysconfdir}/php.d/%{inifile} << EOF
48 extension = %{soname}
49 EOF
50
51 %clean
52 rm -rf %{buildroot}
53
54 %files
55 %defattr(-,root,root)
56 %doc CREDITS EXPERIMENTAL
57 %config(noreplace) %attr(0644,root,root) %{_sysconfdir}/php.d/%{inifile}
58 %attr(0755,root,root) %{_libdir}/php/extensions/%{soname}
59
60
61

  ViewVC Help
Powered by ViewVC 1.1.30