/[packages]/cauldron/php-tclink/current/SPECS/php-tclink.spec
ViewVC logotype

Contents of /cauldron/php-tclink/current/SPECS/php-tclink.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 19879 - (show annotations) (download)
Sat Jan 15 23:45:52 2011 UTC (13 years, 3 months ago) by spuhler
File size: 1888 byte(s)
removed buildroot definition from .spec
1 %define modname tclink
2 %define dirname %{modname}
3 %define soname %{modname}.so
4 %define inifile A13_%{modname}.ini
5
6 Summary: TCLink enables credit card processing via the TrustCommerce payment gateway
7 Name: php-%{modname}
8 Version: 3.4.5
9 Release: %mkrel 11
10 Group: Development/PHP
11 License: LGPL
12 URL: http://www.trustcommerce.com/tclink.html
13 Source0: http://www.trustcommerce.com/downloads/tclink-%{version}-php.tar.gz
14 Patch0: TCLink-3.4.0-lib64.diff
15 BuildRequires: php-devel >= 3:5.2.0
16 BuildRequires: tclink-devel >= 3.4.4
17 BuildRequires: openssl-devel
18 Epoch: 1
19
20 %description
21 This package provides a module for using TCLink directly from PHP scripts.
22 TCLink is a thin client library to allow your e-commerce servers to connect to
23 the TrustCommerce payment gateway.
24
25 %prep
26
27 %setup -q -n tclink-%{version}-php
28
29 # fix strange attribs
30 find . -type d -exec chmod 755 {} \;
31 find . -type f -exec chmod 644 {} \;
32
33 %patch0 -p0
34
35
36 %build
37 %serverbuild
38
39 phpize
40 %configure2_5x --with-libdir=%{_lib} \
41 --with-%{modname}=shared,%{_prefix} \
42 --with-ssl=%{_prefix}
43
44 %make
45 mv modules/*.so .
46
47 %install
48 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
49
50 install -d %{buildroot}%{_libdir}/php/extensions
51 install -d %{buildroot}%{_sysconfdir}/php.d
52
53 install -m0755 %{soname} %{buildroot}%{_libdir}/php/extensions/
54
55 %{__cat} > %{buildroot}%{_sysconfdir}/php.d/%{inifile} << EOF
56 extension = %{soname}
57 EOF
58
59 %post
60 if [ -f /var/lock/subsys/httpd ]; then
61 %{_initrddir}/httpd restart >/dev/null || :
62 fi
63
64 %postun
65 if [ "$1" = "0" ]; then
66 if [ -f /var/lock/subsys/httpd ]; then
67 %{_initrddir}/httpd restart >/dev/null || :
68 fi
69 fi
70
71 %clean
72 [ "%{buildroot}" != "/" ] && rm -rf %{buildroot}
73
74 %files
75 %defattr(-,root,root)
76 %doc LICENSE README tcexample.php tctest.php doc/*
77 %attr(0644,root,root) %config(noreplace) %{_sysconfdir}/php.d/%{inifile}
78 %attr(0755,root,root) %{_libdir}/php/extensions/%{soname}
79
80

  ViewVC Help
Powered by ViewVC 1.1.30