/[packages]/cauldron/picard/current/SPECS/picard.spec
ViewVC logotype

Contents of /cauldron/picard/current/SPECS/picard.spec

Parent Directory Parent Directory | Revision Log Revision Log


Revision 1088374 - (show annotations) (download)
Wed Mar 1 13:35:42 2017 UTC (7 years, 1 month ago) by gw666
File size: 4550 byte(s)
the contrib plugins are gone
1 %define rel 1
2 %define prerel 0
3
4 %if %{prerel}
5 %define release %mkrel -c %prerel %rel
6 %define srcname %{name}-%{version}%{prerel}
7 %else
8 %define release %mkrel %rel
9 %define srcname %{name}-%{version}
10 %endif
11
12 %define mutagen 1.22
13
14 Summary: The official MusicBrainz tagger
15 Name: picard
16 Version: 1.4
17 Release: %{release}
18 Url: http://musicbrainz.org/doc/MusicBrainz_Picard
19 Source0: http://ftp.musicbrainz.org/pub/musicbrainz/picard/%{srcname}.tar.gz
20 # Plugins:
21 Source6: http://users.musicbrainz.org/~luks/picard-plugins/open_in_gui.py
22 Source20: http://github.com/voiceinsideyou/creaps-picard-plugins/raw/master/titleversion.py
23 Source21: http://github.com/voiceinsideyou/creaps-picard-plugins/raw/master/titlesort.py
24 Source22: https://github.com/voiceinsideyou/picard/raw/plugins/contrib/plugins/removeperfectalbums.py
25 Source23: https://raw.github.com/encukou/picard-plugins/master/autosave.py
26 # search plugins https://github.com/brianfreud/Picard-plugins
27 Source25: https://raw.github.com/brianfreud/Picard-plugins/master/SearchAMG.py
28 Source26: https://raw.github.com/brianfreud/Picard-plugins/master/SearchDiscogs3.py
29 Source27: https://raw.github.com/brianfreud/Picard-plugins/master/SearchAmazon3.py
30 Source28: https://raw.github.com/brianfreud/Picard-plugins/master/SearchCastAlbums3.py
31 Source29: https://raw.github.com/brianfreud/Picard-plugins/master/SearchFilmMusziek3.py
32 Source30: https://raw.github.com/brianfreud/Picard-plugins/master/SearchGMR.py
33 Source31: https://raw.github.com/brianfreud/Picard-plugins/master/SearchGoogle3.py
34 Source32: https://raw.github.com/brianfreud/Picard-plugins/master/SearchLortelArchives3.py
35 Source33: https://raw.github.com/brianfreud/Picard-plugins/master/SearchSoundtrackCollector3.py
36 Source34: https://raw.github.com/brianfreud/Picard-plugins/master/SearchSoundtrackINFO3.py
37 Source35: https://raw.github.com/brianfreud/Picard-plugins/master/SearchEbay.py
38 Source36: https://github.com/Sophist-UK/Picard-Plugins/raw/master/musicbee_compatibility.py
39 Source38: https://github.com/Sophist-UK/Picard-Plugins/raw/master/copy_to_comment.py
40 Source39: https://github.com/Sophist-UK/Picard-Plugins/raw/master/abbreviate_artistsort.py
41
42 License: GPLv2+
43 Group: Sound/Utilities
44 BuildRequires: python-devel >= 2.7
45 BuildRequires: mutagen >= %mutagen
46 BuildRequires: libdiscid-devel
47 Requires: mutagen
48 Requires: python-qt4 >= %mutagen
49 #gw for fpcalc (AcoustID calculation)
50 Requires: chromaprint
51 #gw for CD lookup
52 Recommends: python-discid
53 #gw for metaflac:
54 Recommends: flac
55 #gw for wvgain:
56 Recommends: wavpack
57 Recommends: mp3gain
58
59 %description
60 MusicBrainz Picard is the official MusicBrainz tagger, written in Python.
61
62 Picard supports the majority of audio file formats, is capable of using audio
63 fingerprints (PUIDs), performing CD lookups and disc ID submissions, and it has
64 excellent Unicode support. Additionally, there are several plugins available
65 that extend Picard's features.
66
67 When tagging files, Picard uses an album-oriented approach. This approach
68 allows it to utilize the MusicBrainz data as effectively as possible and
69 correctly tag your music. For more information, see the illustrated quick start
70 guide to tagging.
71
72 Picard is named after Captain Jean-Luc Picard from the TV series Star Trek: The
73 Next Generation.
74
75 %prep
76 %setup -q -n %{name}-release-%{version}
77 %autopatch -p1
78
79 %build
80 python setup.py config
81 python setup.py build
82
83 %install
84 python setup.py install --root=%{buildroot}
85
86 PLUGINDIR=%{buildroot}%{python_sitearch}/picard/plugins/
87 install -m 0644 %{SOURCE6} ${PLUGINDIR}
88 install -m 0644 %{SOURCE20} ${PLUGINDIR}
89 install -m 0644 %{SOURCE21} ${PLUGINDIR}
90 install -m 0644 %{SOURCE22} ${PLUGINDIR}
91 install -m 0644 %{SOURCE23} ${PLUGINDIR}
92 install -m 0644 %{SOURCE25} ${PLUGINDIR}
93 install -m 0644 %{SOURCE26} ${PLUGINDIR}
94 install -m 0644 %{SOURCE27} ${PLUGINDIR}
95 install -m 0644 %{SOURCE28} ${PLUGINDIR}
96 install -m 0644 %{SOURCE29} ${PLUGINDIR}
97 install -m 0644 %{SOURCE30} ${PLUGINDIR}
98 install -m 0644 %{SOURCE31} ${PLUGINDIR}
99 install -m 0644 %{SOURCE32} ${PLUGINDIR}
100 install -m 0644 %{SOURCE33} ${PLUGINDIR}
101 install -m 0644 %{SOURCE34} ${PLUGINDIR}
102 install -m 0644 %{SOURCE35} ${PLUGINDIR}
103 install -m 0644 %{SOURCE36} ${PLUGINDIR}
104 install -m 0644 %{SOURCE38} ${PLUGINDIR}
105 install -m 0644 %{SOURCE39} ${PLUGINDIR}
106
107
108 %find_lang %{name}
109 %find_lang %{name}-attributes
110 %find_lang %{name}-countries
111 cat %{name}-*.lang >> %name.lang
112
113 %files -f %{name}.lang
114 %doc AUTHORS.txt COPYING.txt INSTALL.txt NEWS.txt
115 %{_bindir}/%{name}
116 %{python_sitearch}/*
117 %{_datadir}/applications/%{name}.desktop
118 %{_iconsdir}/hicolor/*/apps/*

  ViewVC Help
Powered by ViewVC 1.1.30